Digitone pattern change from Octatrack


#1

Since the last firmware i thought the pattern change bug should be fixed… but maybe im doing somthing wrong here? I have the octa and the digitone both set to pattern lenght 16 steps but when i switch patterns on the Octa, the digitone still takes one pattern longer to switch. Any ideas?

edit:
after a bit of investigating, it seems to work if i set the octa to send program changes when changing patterns, but not when i send pattern changes via the parts, eg. the octas midi channels. Thats kinda disappointing, i have to say.


Still having late pattern changes on digitone OS 1.02
#2

i already answered to you in the bug report thread before i have seen this thread.
first and just to be sure set the change length on the DT to 16 or 8 (should not be necessary if pattern length is 16)

when you want to change via the parts, you always have to send the pattern change in the pattern BEFORE it should change - it can’t be on 1, cause that would be already in the new cycle and you wouldn’t want to change it there - even if people insist that it should be like that - it is an impossible concept, that would mess with your timing
(AR and A4 are exceptions to this concept and i am not aware of any other sequencers that could do it like this.)


#3

makes sense in a way.
unfortunately there is no way to send the PC in advance with the octatracks Parts as its not possible to send the pc on a specific step.

To make this right, the octa would have to see in advance if there is a pattern change in any of the 8 midi channels in an upcoming part change and send it in advance :stuck_out_tongue: Or they add instant pattern change on the DT like with the a4.


#4

So to clarify… no sync’d Pattern changes with the OT via the sequencer - only via Midi?


#5

patter change is always midi, so i dont get your question… to clarify: it only works when you change pattern on the OT to go to the corresponding (same number) pattern on the digitone. like a direct connection. This has to be set in the midi settings.
if you make the pattern changes in the octas midi channels instead -which is settable per part (not per pattern)- and where you could manually choose WHICH pattern on the digitone you want to jump to , then the PC-command is again late - eg its unusable.


#6

Essentially I have the DN connected to the OT (with CC Direct Connect enabled) and changing patterns on the OT jumps to the same pattern on the DN… except late.

I’ve not tried it via the midi track page settings. But it sounds like that too will be late.

Any workaround? Or am I doing this wrong?


#7

do you have the newest firmware on the DN?
Also you Change lengh in the track lenght settings has to be right (16 steps)


#8

Yeah my bad - I think I had something set up wrong. Thanks for the help.


#9

Ok…it stopped working for me again…this is really frustrating … I have all the machines on the newest os. Digitone is always to late when I change from octa, even change len is set to 16 . Analog 4 later in the midi chain is behaving correctly.

Can anyone confirm whether it’s working or not working and send me the exact settings Whatever it is? I have no clue what to change…super strange as it was working before.


#10

Have you contacted Elektron support ?


#11

Jes


#12

Yesterday it worked for some hours… now again not. Didn’t change anything in between . Completely unreliable. This makes using digitone in a life set almost unusable. Can anyone confirm that it’s working for him/her?


#13

Can you explain how you have things set up?

Are you using song mode on the OT to change the patterns? or are you changing the patterns manually?

Do you have the sync setings of the OT set to send transport, clock and prog ch [project -> midi -> sync]
And obviously those same options set to receive on the digitone? You can try explicitly setting what channel the machines send/listen to Program CH on rather than using auto.

How are the machines connected? Midi out from OT directly connected to Midi in on Digitone?

It’s important to note that if you have both machines connected to each other and you are both sending and receiving clock/etc, you can end up creating feedback loops which cause unusual behavior once the midi buffer size is exceeded. It’s often a good idea when experiencing issues to make sure data is always only flowing in one direction.


#14

There is no feedback loop cause no midi input on ot . I’m manually changing patterns. Digitone is directly connected to OT. Pattern change on 16 steps in both machines. All pattern change commands are in channel 16. Tried other channels same result. Only on auto channel I couldn’t get it to change pattern on digitone at all(even Auto channel is on ch 11 on both machines) . Funnyly sometimes it works for a couple of minutes, then again not. It’s completely maddening. And I already spend hours on this now .


#15

Also tried to setup fresh projects on all machines. Didn’t help. Ot is not sending any other midi.


#16

I noticed another strange thing. The analog 4 actually responds the same way, if you have patterns longer than 16 steps. So it takes an extra 16 steps until it switches pattern, even ch length is set to 16. What is ch.len then for? I don’t get it. And I don’t get how this is supposed to play together. This is really bad design, especially considering that all machines are from the same company.


#17

Or I’m doing something completely wrong. But I don’t think so…


#18

Just ran into this problem preparing for my last show… ended up stopping and starting the OT on beat (clocked by a TR8) to line up the OT and the DN over the beat correctly, but it was hectic doing that.

Did you ever find a solution, or is this still a live bug?


#19

Same problem here. OT to Rytm and then to DN. Changing patterns manually on OT. Rytm changes accordingly but on certain patterns (let’s say B01) the DN doesnt switch to B02 along with OT and Rytm but instead starts over on B01 for half a bar and changes to B02 on the beat. And then it continues to stay half a beat behind. Unbelievingly annoying!