Digitone / Digitone Keys 1.31 : bug reports

Last firmware is 1.31.
The manual can be found here.

Remember to back up before upgrading and even load a new empty project to avoid any damage to your current project.
And avoid upgrading before a gig. :tongue:


You encountered something wrong in this OS and want to check if others can replicate it ?
Here is the place.

Doesn’t replace a support ticket, of course, but you might want to check if it’s not a feature before declaring a bug :wink:

Please report all bugs via the Support Tickets section on elektron.se if they have not already been confirmed below.


2 Likes

Hi,
It’s pretty quiet here, I think I did find something unusual, but not specifically for 1.31, it was there in previous OS versions.

I noticed something strange going on in projects where I use sounds with the LP4 filter, some notes wouldn’t sound the same as I ‘designed’ them, this is when it occurs:

When a voice (one of the 8 dots in the voice menu) is first used by a sound (any sound), then used by a sound with the LP4 filter, the first note of that LP4-filtered sound will sound different than following notes of the same sound. (ok, hope you can still follow …)

To reproduce it, I restricted a track to a single voice. In the image below you can see 8 notes, the first 4 are from a sound with an LP2 filter, on the last 4 notes I applied an LP4 filter using parameter locks. The latter 4 notes should sound identical to each other, because I copied them. The first one however clearly sounded louder.

Depending on the exact filter settings, this first note is sometimes louder, sometimes quieter than the following notes, but in most cases it clearly sounds different, and specifically at the beginning of the note…

(I got similar results when a voice is first used by one track, then by another track with an LP4-filtered sound)

1 Like

I updated the DN yesterday and today a weird thing happened 3 times. It seems sometimes the audio “motor” starts popping and clicking so I have to restart it to stop happen.

Maybe at 30 min or 1h of being using it.

Now I turned it off, I suppose it´s because of the update.

It happened again, an hour and a half after. Here´s a sound demo:

I´m using Ableton 11 on MacOS 10.14.6, no Overbridge plugin, and together with the AR that doesn´t have any problem, nor other sounds from Ableton.

Hey Elektronauts,

first time around here, my DN arrived last week. I think I found a bug or at least a non-standard midi implementation for the send CC-Value of Track mutes. I want to send the mute of the midi-tracks out to my gear, so CC94 on ch5-8. From my understanding a momentary or latching button should send 0 or 127 as values, the DN send 0 or 1 (1 for mute on). Is this known or discussed anywhere (yes, search function used) or should I open a ticket?

  • mo

Welcome to the forum!

You are correct: the MIDI specification for Control Change messages suggests that a switch should transmit either 0 (off) or 127 (on) and a receiver should recognize values 0 to 63 for one state of a switched function and 64 to 127 for the other state.

However, Elektron (like many manufacturers) often ignore these small details in the MIDI specification. Many other Elektron instruments use a scheme like 0 for off and 1 to 127 for on, so I expect that this implementation on the DN is intentional, rather than a bug.

You could submit a feature request for a change to feature-request@elektron.se, but it may not be high priority for them to implement because there would need to be some regard for backward compatibility, and for compatibility with other Elektron instruments that use the same system.

2 Likes

I think I may have come across a bug, but I can’t seem to replicate it or even know when it happens. I’ve noticed that sometimes I’ll go to the LFO page of a synth I’ve made and I find that one, if not both, of the LFOs has been set with the DEST to LFO1SPD. Now, don’t get me wrong, sometimes I modulate the LFO1SPD, but I shouldn’t be able to set LFO 1 to modulate it’s own speed, and yet, as you can see in the picture below, that is exactly what is happening. That first LFO should be set to FILTFREQ. The only way to get it to the correct spot is to reload the sound, but if I didn’t save the sound, or made tweaks as I worked it into a song, I may not have access to that. It’s so very odd.

I’m gonna bump this thread to see if anyone else has experienced the above issue. I put in a support ticket, but I’m finding more and more tracks with this problem in my set and it’s ruining months and months of work.

Can anyone confirm that you can no longer P-Lock the LEN parameter from an external Midi keyboard (Auto Channel) by holding down a step and pressing and releasing a key on the keyboard? Live recording works, but I can’t get this to work at all.
Tested on both regular and midi tracks!

The master effects on external synths connected via input turn off as expected when pressing stop twice.

However, when resuming/restarting (ie pressing play again) the master effects remain off if no internal sounds are being sequenced (either no trigs at all or all muted)

It is necessary to play at least one trig on an internal track (even if its muted!) for the master effects to “wake up”.

(if stop is pressed once, the master effects remain on and are present when restarting the pattern)

Yeah, it’s a bit annoying but I think it’s like that by design. I suppose it makes sense if you have to stop a runaway delay in an emergency for example!
It still catches me out regularly when I’m using my Digitone keys to play another synth, wondering why everything sounds so dry.
“Where’s my reverb?”

Well I know the double click that cuts the effect trail is definitely intended. On an internal track, when you resume play, the effects are on again - makes sense.

but why would the master effects remain off. Doesnt make sense to me, but Im wide open. Anyway, I submitted a ticket Ill see what comes back and post here.

(btw Ive seen this issue reported as far back as version 1.2 I think, so perhaps its on the list)

Response from Elektron support:

Thanks for the report!
This is actually the expected behavior and not a bug. After you load/reload a project, or after pressing [STOP] + [STOP], you must trig or play an audio track to activate the effects for the External Inputs. Since the effects are shared with the internal audio tracks, they must be stopped also for the External Inputs in these situations. Since the External Inputs do not have a track of their own that can be triggered separately (like on the Analog Rytm/Four), there is no way to start the effects again without triggering an audio track. We are looking into possible ways to improve how this works and are aware that it can be confusing.

If you’re not using the audio tracks, I recommend placing a trig on the first step of one of the audio tracks anyway - and turn down e.g. the AMP volume for it. The effects will then start when the pattern starts playing. Another approach would be to try and press [STOP] instead of [STOP] + [STOP] to not kill the effects.
Kind Regards,

Patrik - Elektron

On Sun, 12 Sep at 10:44 PM , My email:
The master effects on external synths connected via input turn off as expected when pressing stop twice.
However, when resuming/restarting (ie pressing play again) the master effects remain off if no internal sounds are being sequenced (either no trigs at all or all muted)
It is necessary to play at least one trig on an internal track (even if its muted!) for the master effects to “wake up”.
(if stop is pressed once, the master effects remain on and are present when restarting the pattern)

Thank you!

3 Likes

Not sure if that’s a bug, but I’m trying to p-lock the volume value in AMP settings but it resets to 100 when I reload the project or restart the Digitone.

Noticed recently that on OS1.30A, and with OS1.31 too, the OCT Transpose Minus button is erratically skipping an octave when pressed on my Digitone Keys and jumps 2 instead of 1 octave lower. Not sure if this is OS related or a hardware issue. The OCT Transpose Plus Button is working as expected.

I already filed a support ticket. Anyone else DNK owners having this issue?

Update: Ok Support says that it’s a hardware issue. Have to send it in.

Hello!
DN Version 1.31 here.

Im having issues with buttons consistantly skipping a page when you go from any single page menu to a two page menu, practially registering a single press as two.

Example 1:

  • Im in SYN1 (page 1)
  • Go to Pattern Menu
  • Go back to SYN1, (you can see page 1 briefly flashing) its now on page 2
    Expected result: SYN1 (page 1)

Example 2:

  • Im in AMP (page 1)
  • Go to [FUNC]+DELAY
  • Go to FLTR, (you can see page 1 briefly flashing) it skips to page 2
    Expected result: FLTR (page 1)

This behaviour happens with all* buttons on my digitone so i doubt its a hardware defect, including all [FUNC] accessible menus, regardless of the destination or initial page, as long as its a two page menu.

*TRIG seems to be the only single page button that doesnt make others skip a page, making switching menus behave like expected.

TLDR:

Going from any non two page menu into a two page menu makes button tap register press and unpress as two taps.

P.S. at first i was assuming it was some sort of performance oriented feature, but it just gets in the way a lot, making me stop what im doing and check which page im actually on + its not consistant like with TRIG unicorn.

Thanks!


EDIT: Elektron support confirmed that its a known issue and its being worked on :black_heart:

1 Like

When using Control All, Function does not enable the value snapping for parameters as it does when not using Control All. Somewhat frustrating.

Sorry if I am placing this report in the wrong thread. I am using Digitone firmware 1.30A. I didn’t see any mention of the following behavior for 1.30A or any other version. Here’s the issue:

When the tempo is below 50 bps, the Digitone starts vomiting out multiple occurrences of this MIDI message:

20:0 System exclusive F0 F7

Above 50 BPS, these messages are only sent occasionally. Below 50, so many are sent that my script processing the MIDI input is overrun and the automation fails to work correctly.

I am not going to call this a b*g. Maybe it is a feature I just don’t understand. And since the behavior is not mentioned on the forums, I am not so sure upgrading to 1.31 will fix the problem.

Thanks for any guidance!

Why don’t you just update and see? Quite a few bug fixes and changes in the two updates since 1.30A, and this MIDI message thing doesn’t really seem like the kind of (large enough) thing that would be mentioned in release notes.

Upgraded successfully to 1.31 !!!
Problem persists:

20:0 System exclusive F0 F7
…message sent many, many times, when the tempo of my Digitone (global or pattern) is set below 50 bpm.

Luckily, I rarely set the tempo below 50 while running automation, so it’s not a crushing issue. Does anyone have a spare minute to check this behavior on their Digitone?