Digitone / Digitone Keys 1.31 : bug reports

I love my Digitone Keys, but for the past 2 or 3 years I’ve had it (sold and rebought once) I’ve had the same bugs where the thing will just freeze up during live recording sometimes. MOST of the time it remembers what I was just doing so it isn’t too much of an issue, but after spending 2 or 3 hours on a sequence this morning it randomly froze and I lost everything totally killing whatever inspiration I had lol. This bug has been there for 2+ years along with the first note in a sequence randomly not playing when its a little behind the first beat in micro timing - its been like 2 years now - pretty please fix this stuff.

My understanding is that the first step never plays when its micro-timing is offset left-of-center. I would like a fix, but thinking about the problem makes me understand why the problem exists.

1 Like

That makes sense - more egregious to me are the issues with live recording, as someone who isn’t a natural keyboard player I rely on the sequencer somewhat heavily when composing, having it freeze every other time I try to track something live is more of an issue.

If I understand correctly, the same issues have persisted on two different DNK (or did you re-purchase the same DNK?).

Have you tried the temporary save feature (FUNC+YES) during your live sequencing sessions? It is a great feature that, sadly, I have not gotten in the habit of using. Not sure if that would help you avoid losing work.

Have you upgraded the firmware? Is it possible to recreate a use-case that freezes the DNK? Does it ever crash while it’s idle? Do the freezes coincide with the beginning/ending of a pattern? Have you tried changing the settings of the Voice menu to limit the number of voices per part or change the rules for voice swapping? I could imagine that causing fussy behavior. And, are you applying real-time parameter settings with one hand while playing the piano keys with the other hand? This, I also imagine, could overwhelm the DNK. Just a few thoughts…

Good luck!

I had some freezing issues too when using a DN with my MPC. Seems like some midi messages make it crash sometimes (CC120 and CC123). Do you have any external midi devices connected to the DNK?

I get the occasional freeze accompanied by a high pitched digital shriek, followed by erratic boot behaviour. Its usually when I have been using arps and it is a total flow killer.

Are you using soundlocks/arps heavily? CTRL all?

I found I can minimise this by assigning voices to that specific track, so the sound engine is never doing extreme parameter jumps when the voice retriggers. It still happens sometimes though, unfortunately.

I do have it hooked up to a Digitakt and sometimes sending info to a micromonsta 2, but this was happening when I was just doing stuff on the DNK alone I think.

@djenzyme thats basically the behavior I get, though the erratic boot behavior has gotten better over time. I’m not using any locks or arps at all, I do fairly straight ahead pop/disco stuff so I rarely do much programming on the DNK, more on the DT which works fine.

System Exclusive F0 F7 (many, many times sent)…
Behavior on Digitone at BPM < 50
Also happens on Digitakt.

When master delay and overdrive are on (running external audio through) and I reload the pattern to a temp save, sometimes the master effects stays on but the screen changes to show its off. Have to wiggle the corresponding knobs to get it to actually reset.

1 Like

I have reported the following issue to Elektron support which seems to occur, when recording/monitoring audio via direct USB connection into any kind of recording software (tried Audacity, Bitwig, Ocenaudio). While they weren’t able to reproduce yet and asked for more info I’d thought it might be a good idea to ask around if anybody else ran into the same problem?

  1. In all recordings with internal reverb there is some “pinging” artifact to be heard after a while.
  2. When only recording the dry signal (Reverb to Main == off), no artifacts.
  3. When only recording the reverb (only routing Reverb to Main) the artifacts occur.

You can hear it here at around 10secs:

… and here at around 4secs:

Not 100% sure whether this relates to firmware or not (hardware?!). Would anyone possibly be so kind to check and confirm, please?

PS: I also checked different buffer sizes without success…


There’s a bug where the arp keeps going even after a pattern and sound change. I’ve reported it and have yet to hear back if they can recreate it.

Do you have a cable plugged in midi input?

I like this sound of unwanted ghost in the machine trying to get out.

1 Like

No. Digitone runs standalone at the moment.

Ghosts. Yeah, let the right ones in! :grin:

1 Like

And USB midi input is disabled or not?
Overbridge is on? Or are you in Audio USB mode?

Sorry, if I didn’t describe it precise enough.

  • USB-Audio.
  • No Overbridge.
  • USB-Midi input is off. (if that’s the second option in the menu?)

Strange thing is, it only happens with USB Audio plugged in. Just main outs are fine, headphone also.

1 Like

In midi menu > port config, you can disable any usb midi incoming signal by choosing “midi” (= midi cable input, as opposed to usb or usb+midi)

Okay, got that. Didn’t change anything, though.

But hey, many thanks for taking some time to look into this!!

1 Like

Update: This little reverb-glitch has been reproduced by Elektron and will be investigated further.


Possible bug with LFO fader

The LFO fader does not update reliably for me after changing its value.
Example to reproduce:

  1. Go to a new, clean track (sine wave only)

  2. Go to the LFO page. Set Destination to “Ratio C” and the Depth to 10. This makes a very obvious “wobwob”/laser sound.

  3. Now go to LFO page 2. Change the FADE to a value of 10. Holding down one of the trigs you will hear a slow fadeout of the wobwob, so that after about a minute you will only hear the original sine.

  4. Now if you press the trig or any other trig, there will only be a sine sound. If you change the fader to other positive values you won’t hear any difference.

  5. However, if you change the fader back to 0, the wobwob will return.

  6. If you create a pattern with the sound, the first time through the pattern the fader does not work, but subsequent times it seems to. It is not consistent.

Important extra information. If I change the LFO mode to triggered (TRG) I get the behavior I expect (different fader values cause fade-in/out at different rates, and works every trig). This implies the fader is not always reset in LFO free-running mode.

Anyone else see this. Or am I misunderstanding correct behavior?

There has been some similar discussion some time ago on this topic: Digitone / Digitone Keys 1.21 : bug reports - #132 by Cuttlefish

You could argue it’s expected behavior, considering a continuously running LFO never being affected/reset by a trigger. Still I’m kind of with you challenging the logic behind that implementation. Or the documentation of the functionality in the manual at least.

I kind of expected the same. Being able to fade LFO in and out, independent of the trigger mode selected.

Why not give it a try, file an official report with Elektron and hear what they say? :slight_smile: