Digitakt OS 1.40A (Now 1.40B) is here - Song mode fixes, Fill fixes

Both Filter Frequency and Filter Env should revert back to its original state. At least it does on a Digitakt with 1.30B.


There are some posts on the Digitone 1.40A thread suggesting Control-All revert doesn’t work, but fewer both here and there than I might expect for such a favourite feature. Intermittent bug? I am now hesitant to apply these upgrades.

1 Like

Yeah right?! I just took so long to notice because I am not playing with them very often these days, plus, Songmode was distracting me from using that feature… but could it be that it is everywhere but not many people uses it, as we thought?? Like, the two first persons in here had no idea about it… I hope is intermittent. And I am going to try to install 1.40A again. and see if it works.


after asking Elektron about it. they told me that it is a known issue and that it’s being fixed for the next update, btw. I hope it comes soon.


Thanks for the info on this!

Anybody know where the release notes are for this? The RELEASE NOTES link here doesn’t work: Support & Downloads for Digitakt | Elektron

I’d like to know what bugs have been addressed.

List of changes from OS 1.40 to 1.40A


Saving a song to a project now works the same as saving a pattern to a project. After using SAVE TO PROJ in the SONG menu, the song is saved without needing to save the project afterward. However, the project needs to be saved before switching to another project to retain the changes.

Bug fixes

Latching FILL mode did not work.

The playhead (the red LED moving on the TRIG keys when the sequencer is running) was not visible when in KEYBOARD mode.

The MASTER parameter page always reverted to page 1/3 when switching track.

In SONG mode, queuing a pattern to play after the song is complete while a song row is repeating was ignored and instead the pattern playing on the song row kept playing after the song ended.

In SONG mode, if a song row was set to loop indefinitely, queuing another row to play did not have any effect since it was not prioritized over playing the indefinitely looping row.

In SONG mode, the swing setting from a queued song could be carried over and affect the currently playing song.

The graphical keyboard only indicated one pressed black key at a time even if multiple black keys were pressed.

The PATTERN menu could under some circumstances be accessed by pressing [FUNC]+[SONG MODE].

Keyboard mode could in some cases unexpectedly change to GRID RECORDING mode when switching tracks.


Seems like pressing [NO] (while holding down [FUNC]) to revert Control-All changes back to their original state is still not working in 1.04A.

I’m surprised I haven’t seen it mentioned more, since it’s an effect I use a lot. Anyway, I hope it gets fixed soon.

In the meantime, folks can work around this by doing a quick “pattern copy” before you start messing with Control-All so that you can “paste” back to where you were. A bit of a clunky workaround but it’ll do for now.


Mentioned below, but revert is still not working on the DT, at least not on mine (running 1.40A).

You can also press FUNC + YES first before CTRL+ALL to temporary save the pattern and press FUNC + NO to reload it.


It is again in 1.40B



1 Like

I’m working with DT only a few weeks, so forgive me if I overlooked something.
Can other users confirm that 1.40B breaks the sample preview right after it has been recorded? The preview does work after saving the sample.

1 Like

I assume you mean the sample preview Fn + YES in the sample screen:

Just tried several times (on 1.40B) and the sample preview always works in my case:

  • If I go back and forth from / to the sample menu: preview works
  • If I mute / filter the track I assigned the sample to: preview works
  • Save the sample and do not assign it to a track: preview works

Can you reproduce it in a new project? If so, can you post the exact steps you do how to reproduce this issue?

1 Like

Yes, preview with the Fn + YES buttons.

I create new project, set external input to 127, midi A to ch 9, press sample menu, set thr, in L+R and arm it.
I press trig 9 to make external synth play a sound and record it.
Recorded sample shows up in display and preview does not preview the sample nor does it show a moving pointer.

Going to export the project and will post it later. Though I doubt it will be of any use because preview DOES work as soon I have saved te sampl.

[Test_Preview_1.40B.syx|attachment] (removed)

The exact same issue also exist when sampling from USB source!

And since I connected it to the computer, I reverted it back to 1.40A.
Unfortunately the problem is not solved.
Since I updated to 1.40A and to 1.40B within a week, I didn’t sample with 1.40A.
I am pretty sure the preview worked as expected with 1.40.

you can’t preview the recording, if you are still on a midi channel.
just select an audio track (e.g 1–8). now the preview [FUNC + YES] should work!

works on the lastest firmware, too.


Chips! You are right @AM!
Preview does not work when a midi track is still selected.

What genius decided to disable preview but keep all other sample functions available when on midi channel?

I was about to do a factory reset, and inevitably return it back to the shop :roll_eyes:

1 Like

glad I could help you with this — happy sampling!

off topic

I think it’s no bug. technically there is no sound engine behind a midi channel to preview the recording.
by the way, the digitakt will add all settings of the selected audio track to preview the recording. Which I think is a nice feature. :slightly_smiling_face:


TRK+Func to view mutes while in Grid Rec is no more in 1.40B

When did this one disappear? @DaveMech will be fuming! :grimacing: