Digitakt OS 1.40A (Now 1.40B) is here - Song mode fixes, Fill fixes

Hi, I’ve just found it:



Could not download on Firefox or Safari (OS X Monterey)? Had to use Chrome. What has happened to their website?

Dunno. Monterey worked fine for me.

1 Like

The DK 1.40A download worked just fine for me in Firefox a few seconds ago. Someday perhaps I will understand computers.


Apparently there is a bug on the Digitone with the func+no. Is it the case with Digitakt too ?

[FUNC]+[NO] works fine on Digitakt after upgraded OS.

1 Like

Great ! Thanks :slightly_smiling_face:

In SONG mode, if a song row was set to loop indefinitely, queuing another row to play did not have any effect since it was not prioritized over playing the indefinitely looping row.

This was bugging me the most!

Yay! fill latch is back :smiley:
Thanks @Elektron :heart: love my Digitakt!

Is this a confirmed bug??: My controlall is working good, but then when I press “no”, it’s not coming back to the last state. Can anybody confirm this bug?I think is quite important to have missed it.

I think Function - No should reload the pattern and reset any changes made since the last kit save. Works on my DT.

I’m not talking about reload the last saved pattern. I’m taking about trk+encoders and control the parameters of all 8 tracks at once and then while keep pressing trk, pressing no and coming back to the point before you used control all.

@vamoscreciendo this is the way for what you are looking to do.

This is not what he’s looking for. He’s talking about resetting any parameter to the previous value when you press “no” while using CTRL+ALL.

I just tested it on my DT (with firmware 1.30B) and this is working as described: Pressing “no” will reset to the previous value.

From the manual:

If you press and hold [TRK] and change a parameter setting, this change will affect this parameter in all the audio tracks in the pattern. Press [NO] before you release [TRK] to revert the parameter changes. The control all functionality is not available for the MIDI tracks.

I’m not updating (yet) my DT, so maybe someone with 1.40A could test / confirm this?


Oh cool! I didn’t know you could do that!

@maerteijn and @vamoscreciendo
Apologies for misleading :pray:
Misinterpretation from my part.

I did not even know about this one :joy:


Gonna try this out today! :partying_face:

Just to clarify, this means that:
I am starting to use the Ctrl All function with the TRK button. I start with Filter Frequency, then Filter Env. At that stage, if by maintaining TRK and pressing NO, it means only Filter Env will revert back to its original state on all tracks?

it should all revert, as long as you keep pressing TRK. in my DT not even one parameter is being reverted. so it is a bug (can someone confirm?). I tryed on my DN 1.40 (didn’t update to 1.40A yet) and it is working as it should.