DIGITAKT not connecting to computer


#1

Hi Everyone,

Currently my Digitakt isn’t connecting to Transfer app (1.0.0), it only connected before I updated the Digitakt to OS 1.04, I updated it’s system with the Transfer app, then it never accepted to connect again. (I tried the methods listed in the forum to try to get it to connect but none worked)

It doesn’t connect to my computer either as a soundcard or anything.

Am I the only one experiencing this? I was thinking that this was quite common and we will see fixes in the next update, but I just want to make sure that I’m not in this camp all by myself :smiley:

Thanks,


#2

Here comes the pain train… maybe Elektron will learn, or maybe we’ll just move on.


#3

What? You mean it might not be fixed?


#4

On the System config, perhaps the usb isn’t configured properly?


#5

check to make sure USB midi is enabled and no other applications are accessing the digitakt.
The one time I couldnt get transfer to connect I has USB midi disabled.


#6

It is set on USB for both input and output, there are no other devices connected, no DAW running, it was working perfectly fine before the 1.04 digitakt update.


#7

If your on Mac you can verify that DT is showing up correctly as a midi device in audio/midi setup under applications/utilities… There should be a Digitakt reference in the midi window, and it shouldn’t be greyed out.
I would verify that you have a non-greyed out DT reference that matches the name of the ports your enabling in C6…
If so maybe try selecting the correct ports again in C6, if you haven’t already…
:banana::banana::banana:


#8

I had the same problem. I read in another thread on the topic to go to MIDI settings and set your Auto channel to channel 14.

After I did this, I’ve had no connection issues.


#9

I just love updating to get better perfomance/features, and getting my setup crippled instead. This is why I’m always eager to update and demand constant updates from developers and manufacturers of the stuff I use. Updates are clearly the future of creativity. [/sarcasm]


#10

@bananas have you tried the method where you:

  • start the transfer app
  • select the OUTPUT midi device
  • select the INPUT midi device

That has worked for me before!

I can confirm that I’ve used the current transfer app with my DT 1.04 to transfer heaaaaps of samples, very, very slowly :smiley: Keep trying, and try to take the step-by-step troubleshooting approach… and try not to take too much to heart the grumpy people in the thread.

:heavy_heart_exclamation:


#11

Try this, Start a new project and see if the transfer app connects


#12

Wow! This worked! I tried all the channel 14 stuff and output then input before, and nothing worked!
Thanks a whole bunch @jefones this solved it for me!

Thanks a lot everyone for your kind help! @Open_Mike @Nagualizer @tengig @Ryan :heart_eyes:


#13

I’m still curious about the Soundcard functionality though, is it working for you guys?

What about individual track output (for the 8 channels), it’s not yet available (until overbridge) am I right?


#14

I think none of the cool computer-linked stuff will work until the new Overbridge + DT firmware are released :slight_smile: I think it is reasonable to expect that that will happen some time in the next couple of months.

Glad you got it working!


#15

Just wanted to let you know that the problem is back lol.

It just worked that instance (I didn’t actually transfer anything when it worked, it just connected and I was shown the transfer box), and when I tried doing it a few days later it didn’t connect. And now I sometimes don’t even have the DIGITAKT as a choice in the dropdowns. I tried restarting both computer and digitakt, disconnecting everything else, trying MIDI+USB and USB only, AUTO CH is set to 14.

It just suddenly worked as I was writing this post, though I dragged some files into Transfer, and a few seconds later it crashed.

Hmm… I wonder


#16

Do you have any midi cables in or out of the Digitakt? Make sure you select Digitakt for input and output on the transfer app, and not your sound card! The app switches my select to sound card sometimes.

n.


#17

Nope, it’s only connected via USB. No DAW open nor any soundcard connected.

The weird thing is the one time it worked and I tried uploading files, Transfer crashed.


#18

Digitakt to laptop…no hub in between? Check midi and channels settings?

n.


#19

This is ever so out on a limb: Are you using the USB cable that came with the Digitakt? If not, try that one.

When I first got mine, I found the connection was flaky using some generic USB cable I had, but not the nice red one that came with the DT. It was reproducible then, even though that generic cable worked with all my other gear.


#20

@Novem No hub, midi and channel settings are all OK. It was working fine on the same settings before I updated to 1.04. As a matter of fact, it’s Transfer that I used to perform the update.

@mzero Yes I’m using it, I also tried the other MIDI cable that came with the A4