Digitakt: MIDI triggers synth and kick

Digitakt is connected to PC via OB and MIDI to Minlogue XD, DAW is Ableton 10.

MIDI A is set as the channel for the Minilogue but whenever I program a sequence on the DT on MIDI A it triggers the Synth and the Kick on Channel 1. Its driving me crazy and stopping me making any music.

Can anyone help?

I’m sure there are better ways but you could try deactivating “receive notes” on the Digitakt

What is Trig Key DST set to in this menu?

image

Best regards,

Gino

States whether the trig Keys trig the DT or an external hardware :slight_smile:
In your photo @Gino it will only trig DT.

This is also the case for encoders and mutes :slight_smile:

Hope this helps,
V

Another thing to check is the midi channels, as they should be different (between Midi-A and T1).

1 Like

Doesnt matter what I set it to it triggers the kick although it is a lot quieter on int+ext

LOL - Thanks, but I wasn’t the OP :slight_smile:
I was asking the OP what the state of that setting is. :grinning:

Oups :slight_smile:
There you go for the OP
:slight_smile:

1 Like

Ok - Did you check the midi channels on the DT?

It’s this one:

Yes, all as CH1 = 1 etc. Tried changing them, turning them all off, still triggers the kick

Hmmmm… for Midi-A, what channel is it on?

image

I don’t know Ableton, but in my DAW I have to tell the DT VST to pass through the midi channels. Otherwise they will map to CH1, which is the kick. Does Midi-B also trigger the kick? If so, something in your chain is mapping to CH1, and you have midi-doubling.

I think ive stumbled across it. In OUTPUT TO it was set to MIDI+USB, if just set to MIDI it doesn’t trigger the kick any more. Also I didnt know that the MIDI settings were per project and not global unless Im wrong.

1 Like

Cool, glad you sorted it out! All musicians should make music first and foremost :slight_smile:

Yes midi settings are per project. I also learned that one the hard way.

Best regards,

Gino

Thanks, hopefully thats the last of it. Im too tired to make anything now :frowning:

Hallo guys, I have the exact same problem, but setting “Output to MIDI” doesn’t allow me to use the DT with Overbridge, of course. Is there a way I could make DT work with OB and avoiding this triggering? On my DT, all MIDI tracks trigger Track 1 (poor track 1!). I’m totally stuck, any help would be appreciated.

Thanks

Andrea

I’ve overcome this by changing the Auto Channel and FX channels. By default I think they’re on 9-10, so I changed them to 15-16 and it solves this issue. This has to be changed in midi config per project though. No way around it that I can see. The only downside is not really being able to use channels 15-16 if they’re needed.

Hallo @DataStrain, thank you for you suggestion. I tried it but it doesn’t solve my issue, every MIDI triggers Track 1. The problem does go away when I change the Output to only MIDI, like suggested by @kelvin, but what I’m trying to do is using my setup with Overbridge. I also tried to change every possible combination of channels but without luck unfortunately.

That’s odd @andreaavellino I’ve been using this way and using OB for a while now.

Hallo @kelvin , I just realized that if I switch off/on the DT, as well as Ableton, it does work but like 40% of the times… totally random. I’m using Ableton Standard on Windows 10, maybe on Mac is more stable!

I’m on Win 10 with Ableton Standard as well and it works fine for me. Is everything updated to latest version on OB etc?