Digitakt + Digitone MIDI Setup

Hi there,

I’m trying to run the following setup but I can’t get it working the way I want it to:

Keystep (Out) --> Digitakt (In) - Digitakt (Thru) --> Digitone (In)

I want the Keystep to trigger both units to play and stop as well as send Midi notes to the Digitone. But I’m losing the sync from the Digitakt when using the Thru port. In this setup the Keystep sends out the clock and I need to dial in the right BPM which is very uncomfortable. The Digitakt should act as the master clock for everything else.

Someone said in another post to use a Midi Merger for this kind of purposes but I’m still unsure how to connect it right.

Any kind of help would be much appreciated!

Of course you loose the sync from the digitakt, because MIDI thru just mirrors what’s coming in to MIDI in.

In your setup you need to combine Digitakt Thru and Digitakt Out into a single MIDI signal. That’s what a MIDI merger box does. It takes multiple inputs and generates a single output from them.

So:

Digitakt Thru -> Merger Box In1
Digitakt Out -> Merger Box In2
Merger Box Out -> Digitone In

Can’t this be solved with firmware by allowing a midi merge feature? The strymon effects boxes have the ability to change the Midi Out port to Out/Thru/Merge.

I’m experiencing this same issue trying to merge digitakt data with my iPad midi out data.

Can’t you do : digitakt out -> keystep in -> keystep out -> digitakt in -> digitakt thru -> digitone in ?

This way, you would send the clock from the DT to the keystep, and it would send it back to the DN via thru ?

2 Likes

I think you can go:
Keystep out–>DT in, DT out–>DN in

Using the Keystep set to the autochannel of the DT, you can play the DN by having a a DT midi track selected and set to output to a corresponding channel of the DN…

Not sure if the transport from Keystep will work as you can’t separate the clock receive from transport receive on the DT and I’m not sure if you can on the Keystep. If the Keystep can send just transport then you can set the DT to receive only transport not clock, and set it to transmit both clock and transport…

If clock and transport are tied together on Keystep this might still work for you if your OK starting and stopping from the DT, just don’t set it to receive clock…
An option to explore anyway…

3 Likes

What Mike said.

You should be able to use transport from teh keystep, if you enable receive transport and send transport in the midi settings. Also, obviously make sure you set the same for clock send/receive on both units. DT (send+receive) (DN receive)

1 Like

This setup works surprisingly well! But I’m not able to use the transport from the Keystep and there’s no option in the Midi setting of the Digitakt to enable only transport. Just “Clock Send”, “Clock Receive”, “Prog Ch Send”, Prog Ch Receive".

Thx anyways guys!

I found out it’s easier to use the Auto Channels of both units, so you can switch between them with just two midi channels.

1 Like

I’m trying to do a similiar set-up and I think I’m following this advice but it’s not working. I’m kinda stumped.

There are a few alternatives described in the topic. Let us know what MIDI cable configuration you are using and what is working and what is not.

1 Like

Thanks Peter. I’ve got a midi cable going from Linnstrument out to Digitone In. The Linnstrument is set to channel 10 and the Digitone is set to channel 10 for auto channel. All that works great. Then I’ve got another mid cable going from Digitone Thru to Digitakt in. I’ve got the Digitakt set to auto channel 11 but nothing happens (even when I switch the Linnstrument to 11). If I set the Linnstrument to channel 9, 10, 12-16, I see a visual indication that the DT received a note. Nothing gets sent to the DT with the Linnstrument set to 1-8 (maybe because the DN is claiming those?)

Connect the MIDI OUT of the Digitone to the MIDI In of the Digitakt.

Leave the Digitone auto channel at 10.

Set one of the Digitone’s MIDI sequencer tracks to be on channel 11. Select that track.

Set the Digitakt’s auto channel to be 11. Select the audio track you want to play on the Digitakt.

The Linnstrument should now play the Digitakt’s audio track.

Let us know if that works and we can refine things later.

4 Likes

Dude you’re awesome! That worked, thanks so much!

For some reason the Digitone keyboard plays left to right through all the DTs tracks instead of different pitches in the selected track. I don’t care though cause the Linnstrument works great.

2 Likes

You may have transposed the Digitone’s trig-key-keyboard down to the lowest octave. If you transpose it up by one or more octaves, you should put the trig-key-keyboard into the note range to which the Digitakt responds chromatically.

2 Likes

What i have going on is Sledge > Digitakt IN > Digitakt OUT > Digitone IN

I wanted to be able to play the digitone from my midi controller with the common DT + DN setup. I wanted DT to send clock and pattern change + start and stop.

I have the DT tracks 1-8 set to off and tracks A-H set to 1-8.
on tracks 9-12 i set the midi channel on the SRC page to 1,2,3,4.

On Digitone i set track 1-4 to midi channel 1-4.

I also set mute destination on the DT to INT+EXT so i can use the DT for mute groups.

In order to play different tracks on the digitone i cycle through the corresponding midi track on my sledge and it works perfectly.

I hope this makes sense. :slight_smile: