Digitakt 1.20 : Bug reports

Firmware 1.20 is now released.
Discuss here

Remember to back up before upgrading and even load a new empty project to avoid any damage to your current project.
And avoid upgrading before a gig. :tongue:


You encountered something wrong in this OS and want to check if others can replicate it ?
Here is the place.

Doesn’t replace a support ticket, of course, but you might want to check if it’s not a feature before declaring a bug :wink:

Please report all bugs via the Support Tickets section on elektron.se if they have not already been confirmed below.


2 Likes

Someone on the Facebook Group posted about this and I just tested it.
On Midi tracks when recording in real time, either using an external keyboard or the chromatic mode, holding a note over any recorded note now deletes the old notes, as if it were a mono track on overwrite, not a poly track on overdub. The poster also can’t record note lengths via a keyboard, everything just records the set note length in the track. He’s on a Prophet 6, I’m not finding that on a Peak.

6 Likes

This is being discussed on the Digitone 1.30 bugs thread too, it is a known behaviour and something that will be investigated afaict

Bug fix:
Im just leaving this here for anyone who might have the same Problem as i did.
Digitakt didnt show up in Overbridge on Win10 with the newest updates.
To fix this Problem, i had to go to Win10 Audio Devices and disconnect the Digitakt as an Audio Device. Then, after restarting the Overbridge Mode on the DT, it works perfectly fine.
Hope this helps, cheers!

2 Likes

Digitakt 1.20 / Overbridge 2.0.39.10 / Windows 7 x64 (fully updated)

SYSTEM… USB config 3 options:
Overbridge works OK, USB midi works OK, but
the 3rd (USB Audio/MIDI), the new USB Class Compliant driver, fails with error
“This device cannot start. (Code 10)” [2x devices marked with issues ! @ device manager] —
there is though one device that can be recognized, totally there are 3 new USB devices, 1 device Ok, 2 devices with issues.

2020-06-12 01_24_47-Computer Management
Overbridge should not be related, as the new option is an independent driver and OS should install it automatically.
It seems there might be some kind of incompatibility with windows 7 or this is my specific issue,
Any user feedback for windows 7 and the new driver?

1 Like

Hi. You need to install Overbridge with driver signing disabled on Win 7 - this is an F8 boot option. Have a search on the forum - it’s been described step by step in the past and this should get you up and running.

I haven’t tried the latest versions yet, but have both Digi machines working with Overbridge on Win 7 x64.

Hope that helps!

The Reverb / Delay Parameter per Track is a bit wobbly when pushing the knob while turning it. Like a latency (it jumps unexpectedly). Very annoying.

3 Likes

Overbridge works ok. That means this is not a signing issue. It is disabled anyway. The new driver has the problem and it is a native OS driver, nothing to do with overbridge exept if there is a conflict with it but I do not think so. There was an other point that the driver installation reported ‘unknown device’ and the message was that the device firmware cannot report corectly its specifications or somerthing like this.

Well, that sounds like a driving signing issue to me - Windows can’t see the devices properly. At least, that was the experience I and others had here until we installed with driving signing disabled. I’d recommend uninstalling Overbridge completely and reinstalling with signing disabled. Just trying to help - up to you!

While still usable The retrig length parameter still moves a bit too fast like it has the wrong resolution, it makes it hard to lock onto certain lengths Must have not been adjusted in 1.20…

6 Likes

Got the 1.20 installed on the Digitakt, even did it 2 times. I can route audio from pc and ipad TO the digitakt via usb and use the headphone output of the digitakt to listen to the audio from the pc or ipad.

But I cannot get the inputs on the digitakt to transport any audio TO the pc or ipad. I connected an A4 to the inputs of the DT and I checked levels of the A4’s output before on the same ports with headphones. I can even monitor the audio inside the DT via headphones on the DT.

Did anyone get the inputs of the Digitakt transporting audio via usb successfully? Did I miss a step?

1 Like

i think the DN can do this but the DT’s inputs are not available over class-compliant audio - you need to use OB for that.

3 Likes

Anyone else finding that when you press down and turn knobs, sometimes it jumps right back to the opposite value? e.g. you press and turn to +64 and it’ll jump to -64? Didn’t used to happen I don’t think

4 Likes

yes, i see that too - already reported.

3 Likes

Just some notes to clear things up. “Class Compliant USB devices. This means that to communicate with the computer, they use drivers that are built right into the host computer’s operating system. These drivers are written by Microsoft (or Apple for Macintoshes), and come pre-installed on all computers.”

Source
https://www.alesis.com/kb/article/1619

Confirming I have this same behaviour. Using midi keyboard (Novation SL MK3) - Digitakt doesn’t record note length, and recording is destructive (removes previously recorded note(s) on same step rather than just adding new note(s)). I submitted a ticket.

4 Likes

Same here, ever since upgraded to 1.20, Note Length won’t be recorded in real time recording when I use external keyboard (Arturia Keystep in my case).
On version 1.11 it was working fine.
If I use Digitakt pads with chromatic mode it will record Note Length as usual.

Elektron, please fix this.

4 Likes

Agree. This is a major bug that needs a quick fix.

1 Like

A support ticket has been created for this. Any feedback from windows 7 users will be helpful. Win 10 works ok and reports correctly 2x “elektron digitakt” devices on the same system.

1 Like

You need to use the auto MIDI channel when recording from an external keyboard.