Digitakt 1.10: bug discussion

You encountered something wrong in OS 1.10 and want to check if others can replicate it ?
Here is the place.

Doesn’t replace a support ticket, of course, but you might want to check if it’s not a feature before declaring a bug :wink:

Please report all bugs via the Support Tickets section on elektron.se if they have not already been confirmed below.


Unless I missed it I don’t see anything about the issue with the Digitakt being midi slaved and missing the first step/note when pressing play from a controller. Anyone update already and tried it out?


(Digitakt 1.10) Uh did they get rid of note value (1/4, 1/8, 1/16) parameter settings in the lfo page? Why? Also can we please get ms based values for the attack and release in the MB compressor?


There was note values on the lfo page? Which parameter?

I thought it was lfo speed but realized I may have been thinking of the retrig speed parameter.

If you hold func and adjust lfo speed you still get the 8.0/16.0/32.0/etc values as they were before the update.


My open hi hat mute light is still mirrored/flipped 1.10… does any one else suffer from this ? support did say it was a known bug , wondering if its just a few boxes that suffer from it ?


Mutes light haven’t been fixed apparently, very annoying bug


Are there no release notes available yet? I didn’t see a link.

1 Like

they are in the zip but not separate on the site

Overbridge support added.
Increased the number of LFO speed snap values.
Adjusted size of icons in the SETTINGS menu.
It is now possible to perform copy, paste and clear operations on the MIDI parameter pages.

Bug fixes
Parameter locking a trig and pressing the [BANK] key at the same time caused unwanted
behaviors and errors.
On a parameter locked step, MIDI CC both sent the default value and the locked value.
While playing a sound, there was an audible click when amp pan was set to full left or right if the
track level and amp volume were both set to max.
Sample waveforms from the previous project were not cleared when loading a new project where
the corresponding sample slots were empty.
Digitakt could not connect to Transfer when auto channel was set to 1.
The compressor’s dry/wet level (MIX parameter) did not react to its assigned CC due to a conflict
with the LFO depth CC LSB parameter. The LFO depth CC LSB parameter is now changed to 110.
Controlling the MIDI tracks VAL parameters with external CCs did not work.
The wrong parameter was sent externally from LFO MULT when changing the parameter on the
The sequencer switched to the new pattern when the user aborted the pattern paste/clear
Samples loaded to RAM could not be previewed in SAMPLE MANAGER.


I still have a ticket open regarding this matter… Sadly it is not mentioned in the release notes, but I have to admit that I had no time yet for to test it.

Nope. Still has that problem…

Ah well, maybe in the next one

next one should be the looping preview option for short samples. then the preview options would be perfect.

1 Like

I have the same problem. Missing the first note when slaved, in my case with the RC-505 looper. All other slaved gear (Sh-01a, TR-08, Monologue… dont have that problem).

I got midi tracks A, B, C and D set up to control the channels of a DSI Tetra.
The CC values are set up on the Digitakt so I can shape the voices of the Tetra via midi. In each pattern I got different CC values for the midi tracks.

When I have the sequencer running and I switch patterns, often times the new CC values are not updated and the old sound is still triggered from the Tetra. The new CC values show up though, when I stop the sequencer and manually trigger one of the midi tracks, it’s all fine.

Anybody else able to replicate this? I’ve been working on a somewhat extended set and was heavily relying on the correctly shaped voices from the Tetra.

If i understand your problem correctly…
it won’t update the CC values until a trig with those settings has been played,
I solve this by putting a lock trig on first step of new pattern, but it has its uses too


Oh wow, this works. Thanks for the help!
It’s strange though, before OS 1.10 I was on 1.08 and the CC values updated without problem when switching patterns.

that was a bug i think , maybe linked to this

On a parameter locked step, MIDI CC both sent the default value and the locked value…

or maybe a new bug … i prefer it not sending something unless i tell it to / free lfo sending stuff out.
though i dont use this function very much.

Increased the number of LFO speed snap values.

Seems like a somewhat odd list:

Would’ve expected either 4 in there, or no 12. Anyone have any idea why it’s this list?

Would also be nice if one wouldn’t have to turn a gazillion degrees to cycle through these options. Seems like encoder handling/acceleration is still not very good :cry: