Digitakt 1.04 : Bug reports


#585

good to know. yes they are crazy sensitive


#586

Hello every one
i’ll write the setup first :
Digitakt midi out to Rytm midi thru to Blofeld kb midi out to Digitakt in

first, the track 9 of the digi is set to channel 14 bank 2 prog 50
the blofeld is set to channel 14, when i hit the trig 9 on digi it doesn’t recall the right prog inside the blofeld (it plays bank 1 prog 1) if i move the bank value in digi it doesn’t work but if i set manually the bank to 2 in blofeld then the prog value of the digi is working inside the blofeld…
second i manage quickly to write a sequence live in midi track 9 of the digi from the kb of the blofeld but it stopped almost directly the Rytm sound !! the sequencer of the rytm was still playing but only on a 16 steps pattern and like i said without sound !!
Same thing happens if instead of playing the blofeld kb i am just playing the trig 9 of the digi…
Perhaps there is no bug and i missed something inside the setting i don’t know if some one can help :blush:
P.s. will it be possible in a future os to play chords directly from a keyboard inside the sequencer of the digi ?


#587

My trick to clear p-locks and to enable midi and such is to use 3 fingers to quickly press the encoder down. Took a few tries but I can clear/enable most stuff in 1 go now. By using 2-3 fingers the chances you rotate it while pressing is greatly reduced. At least for me.


#588

Hey all!

I am often experiencing hanging notes when playing a sample in FWD-L mode. I’m using one of the stock single-cycle waveforms, all settings are default e.g. amp envelope hold time is note length and decay is short (15-20). When I play this sample chromatically, some notes will get “stuck”, a note will hang until I press another one. While recording in chromatic mode, notes actually hang more often and they all register with a note duration of 128 (see the screenshot).

Is this a known issue? Really hoping this gets fixed in the next update.

Artemiy


#590

I sure did, and I wrote about that. The amp env is pretty much a gate, very short decay time. Also, env would not affect the trig length anyway. There is also no consistency to this issue - like sometimes it happens, sometimes not. Like DT is in a bad mood or something :slight_smile:


#592

I changed in my rytm the prog receive setting to no, so now it’s ok but the rytm doesn’t follow the prog change of the digi…
The digi freeze sometimes i have to restart it.


#593

One other issue I am having is as follows: when loading a project, I press play right after seeing the LOAD OK on the screen. However, it seems like it still needs like 0.5 to 1.0 sec to complete loading samples, so what you hear is your pattern playing with wrong samples for a split second. I wish that Digitakt would display LOAD OK when it actually finishes loading 100% of the sample data.


#595

I have had this problem playing on the chromatic keyboard as well, seems to happen when two adjacent notes are played in sequence fairly quickly, one right after the other (kind of in a legato style). Sometimes it happens, sometimes not. Try doing quick little two-note combos, using notes that are physically right next to each other, and see if you can replicate. I was able to replicate numerous times last time I intentionally tried, like a week ago. Can’t tell if it’s based on some very specific timing scenario or the notes being close to each other, or if it’s just a totally random thing, but I was definitely able to make it happen multiple times.

I wonder if it’s something that’s happening to a lot of people and they don’t even realize it because they’re mostly going to be using finite samples that end anyway, even if the length is set to 128, whereas single-cycle waveforms will go on forever.

Might be worth trying to set your sample to just regular “forward play”, not loop, and change it to a sample, not a waveform, then live-record and try to capture a hung note, maybe see if it’s happening with all samples or just single-cycles, or just “forward loop” or something? Might be kind of tedious I guess, but in the name of science! Probably would want to set the default sample length real short, so if you do get a random “128 length” you’ll hear the difference and can go back and look at the recorded trigs to confirm?

Didn’t really think of all this at the time, but I’m gonna go back and try some of these scenarios. Will report my findings. :slight_smile:


#596

Yeah this is how I’m doing it, like you have to “claw” grab the button… like… “YOU’RE NOT FREAKIN MOVING ON ME THIS TIME”


#598

I’m hoping for a configuration page to set stuff like encoder acceleration and sensitivity, led brightness and custom colours for each mode and whatever else could be user configurable. But only once the bugs are ironed out.


#600

Yes I do hope this gets fixed in 1.10, that’s actually the only bug I have encountered so far :slight_smile: Did not push it to the limit with MIDI sequencing, only played with two mono synths at the same time (NYX and 0-coast), all worked fine.


#601

I’m not sure if this a bug or a feature and/or user error but I’m having some issues with live recording tweaks to certain stuff like filters messing up the sound.

To repeat create a new project, new pattern, track 1 a single cycle with amp to inf, place a trig on step 1 and press play; a constant tone that ‘restarts’ every 16 steps. So far so good.

Enter live record mode and do some filter tweaking, once the pattern repeats the amp seems to be messed up.

What I expect: Recording of the parameter I’m changing. doing it manually with trigless trigs works but takes a while.

What I get: The amp or something being messed up. I understand there will some steppyness without parameter slides but something more is happening.

I am doing something wrong or is this by design or a bug?


#602

I recorded some live tweaks of the filter and had similar results. Didn’t sound great, needs some way to make parameters transition between trigs more smoothly. What do the other boxes have? You mention slides?


#603

As an update on my previous problems I have discovered that the D encoder behaves like a fast select for microtiming and as it allready bugs out and brings the src page up without being touched I can only assume it is also responsible for the phantom movements I am battling against whilst adjusting microtiming. I wish they would hurry up and get it fixed, I dont need new features and I have got used to not having working midi but I do expect the 8 audio tracks and the hardware that controls them to work properly.


#604

I don’t think this is has something to do with the lack of slides. It must be a bug. Can’t be that recording some filter sweeps should change the note length/amp settings. If I manually p-lock filter sweeps it works fine. Highly annoying though.


#605

There are missing destinations LFO on track 8, I do not have the parameters of samples (tune, Play Mode, Bit Reduction…) it’s a bug?? or it’s normal??


#606

Just checked on mine, they’re all present on all tracks including track 8. Are they also missing when you load the demo project?


#607

I have all LFO destinations on all tracks


#608

I made a factory reset the same, but I just noticed that it was only on one pattern, really fishy, I copied the pattern from next to it and here it is back


#610

The NEI & /NEI conditional trigs seem weird- like they’re not functioning properly.

I have a standard 4/4 beat just using the BD and SN.

The BD is four to the floor, the SN on beats 1 and 3.

Just for the sake of science I have only the BD on the 2nd and 4th beat with conditionals.

The 2 beat has the NEI conditional, the 4 beat has the /NEI conditional.

What happens is- the BD plays normal the first run of the pattern, but both conditional trig(while being the opposite) fail to trigger on the second run through.

I’m not familiar with the NEI conditionals- but that’s not right, right?