Digitakt 1.04 : Bug reports


#514

I’ve had one crash in dozens of hours of use. Not bad for a non-final OS, from my point of view. Yes, I admit I have a biased point of view having a smooth experience and still in my Elektron honeymoon period. (Plus I come from Korg electribe world, where you get 26 megs and sequences get stale fast.)

The Digitakt is vastly more stable than my iMac. Or my car. Or my brain. All of which I paid far more for.


#515

Yeah, I often wish that press+turn was actually a fine rather than course adjust


#516

My problem was that loading a project caused the DT to crash. The issue started when I tried to load a new project whilst the DT was receiving midi note data from my DAW. I turned off the DT for more than a minute and unplugged all the midi cables and this seemed to clear things and now it works as normal. So the bug would be freezing if project is changed whilst the DT is receiving midi data.


#517

I know this was a problem with earlier firmware version, but with 1.04 I am all of a sudden having issues dialing in a specific percentage / value for trig conditions on the D encoder. It definitely skips from 3% to 9% to 14% etc.
Anyone experiencing this again?


#518

Dont think it went away, I dont find much use for the % my self so not used it for a while but its not the only parameter that moves in chunks.
Noticed a new super annoying phantom trigger problem, this time with microtiming. If I hold a trig to nudge the microtiming while playing very often it moves on its own just like the encoders, except this actually moves the microtiming instead of bringing a window up, no specific direction either. You have to keep a close eye on the screen as you work or before you know it its making its own decisions and messing the groove up, I only noticed when investigating why a pattern I had made had lost its rythm.


#519

Trying to figure out whether this one is a bug or user error…

I can not record midi from external devices. The Digitakt receives MIDI messages when the MIDI track is selected (the corresponding pad for the selected track is flashing when I play notes on the keyboard, and it seems to send midi as well), but when i press record, it does not detect the MIDI notes.

“Manual insert” of MIDI notes (via the UI) works, and I can control external gear, once the MIDI messages are there.

It does seem to pass through the MIDI to other devices via the MIDI out of the Digitakt, also when record is active.

Have tried both via USB and MIDI cable.


#520

Func+arrow left or right nudges all trigs in a track without bringing up the micro timing menu. Could this be what’s happening to you?


#521

95% of my gear has worked day in and day out for years and years without a single crash. The DT is way too buggy to not be considered still in Beta IMO. Elektron should not have released it in the state that it was in. They should have released it at a reduced price and as a Beta model.


#522

With the two price hikes, unit is now 729 retail in the states, it would seem like it was released as beta at a lower price.


#523

I preordered mine from Sweetwater, and it’s still listed at the same price now as it was then. Maybe it’s different where you are though.


#524

I got mine from Sweetwater preorder 649. They are listed on Sweetwater right now for 729. Does Sweetwater do different pricing in different places?


#525

Same price here on Sweetwater of $729 (San Diego, CA).
Probably due to increased “America First” taxes on everyone from our SELF PROCLAIMED “Most amazing, best at everything, your eyes are lying because I’m always right, fearless, smartest, most healthy, orange leader’s FANTASTIC” handling of our country.

Anyway, kind of glad I got mine before the price went up even if I have to wait for the pattern change bug to get fixed…


#526

No its the microtiming graphic. I hold func, press one of the arrows to bring up the graphic and while I am making my own adjustments the digitakt adds some of its own, sometimes several places. It has definitely reached the point where as soon as I can make a backup its going back, I dont see anyone else with so many problems so it cant be software.


#528

I meant to say func but I am sure you knew that, either way my digitakt has problems where as your one (as you have told us)does not, so why spend your time in a bug report thread nit picking those who do, do you work for elektron?.


#529

@phaelam is just trying to help. There have been a number of bugs posted about that ended up being user error rather bugs. Also if the error can be duplicated by another user it confirms that it’s a bug.

I am also interested in this micro timing bug you are experiencing. Just want to make sure that I’m getting what you are doing.
So, when you are in grid record and you hold down the trig or trigs you want to microtime are you pressing anything other that the trig(s) and the arrow? If you are pressing Func+arrow left or right you will nudge every trig In the track. I only ask this cause you’ve mentioned holding func to activate the micro timing menu a couple times.


#531

1,000% agreement here… many of us request this!


#532

Do you have a midi cable plugging in? I find that my DT is more unstable when I have one plugged in.


#533

Anyone having Random switching off, keys locked on occasion when it restarts.

Happens every time I use it, but just earlier I was moving cords and it cut out, then restarted. So, I’ve picked up the power brick and given it a shake, and the DT does it’s cutting off and on dance.
Everything is securely plugged in, so I’m suspicious of dodgy connections in the brick.

If anyone is experiencing this cutting out issue (I haven’t even used the midi yet) can you try giving the power brick a little shake and see if that’s what’s making yours cut out?


#534

@catchthehare This is not a bug, you can’t dial every TC percentage. Each :3lektron: groovebox works the same in this regard.


#535

@phaelam is genuinely trying to help.
A weirdness is a bug if it can be reproduced.
Please have a read at the Guidelines.
This forum reflects what we all put within. Let’s keep it friendly!

A quick reminder : if you manage to consistently reproduce a bug or get it reproduced by another user, please write a ticket to :3lektron: support so that we have a chance it’s corrected in next OS.
:3lektron: doesn’t necessarily read this topic.