C6 SysEx Manager not getting Catalina 64-bit update

Welcome to the forum!

There is no need for any software for use with Octatrack. You can transfer samples and firmware updates using USB Disk Mode or by putting the CF card in a card reader attached to your computer.

Just read the instructions in the manual for upgrading the OS.

Thanks Peter. I don’t actually have a card reader (plus the card is stuck in my OT), so I was hoping to do this with Sysex. I know how to put the OT in usb disk mode, however I still need a way to send the OS update file to the Octatrack, yes? So far since I’ve update my laptop to High Sierra neither C6 or Sysex works at all for me. Am I missing something?

You didn’t read the instructions in the manual!

When upgrading the OS in this way an Octatrack MkII OS file, with the file extension .bin, needs to be placed in the root of the Compact Flash card.

You can do this in the OT’s USB Disk Mode.

I did read the manual… lmao. They don’t explain how to do it at all. I have no idea what the “root” of the flash card means. Care to elaborate on how that works

C6 works fine on High Sierra, it’s Catalina and onwards that is incompatible :wink:

Edit: but you don’t use it for updating Octatrack, doh!

You guys are really confusing me. Literally in the directions to upgrade OS for the Octatrack it says you can use the sysex file or the .bin file. I haven’t had any luck sending the sysex file with c6 or sysex librarian, and don’t understand the .bin root card placement either… so can anyone clarify?

Plug USB cable in OT and computer, put OT in USB disk mode.

On your computer, open the OT drive in Explorer/Finder and copy the file to the root of the OT drive, i.e. not in a sub-folder/directory


Description here:

That worked. Thank you so much!

1 Like

hi guys, hopefully someone can chip in with useful info- i need to back up my DN but my mac is Catalina so its my understanding that C6 will not work. I’d assumed i could get this done via Transfer, but it appears not (certainly Transfer doesnt respond when i set the DN to sysex send, despite being otherwwise connected and communicating with the DN). Any solutions?

they’re all above you ^

ok sorry, genuinely didnt find this thread in my (admittedly short) search. have used sysex librarian in the past successfully, but for whatever reason its not communicating with the DN now. i’ll investigate further. cheers!

1 Like

make sure it’s up to date - works fine on Mojave and folk are having no issues using it on Catalina afaict - it’s the ideal Mac backup tool until such tasks are eventually possible via Transfer


its definitely up to date- no doubt its something im overlooking (wouldnt be the first time) so i’ll persevere when i have more time on my hands

1 Like

the way that overbridge works on a mac means that you can end up with multiple midi device entries for one unit …

potentially there can be three drivers in Audio Midi Setup on e.g. an A4, one for USB MIDI one for OB mode and one when an Audio/USB Class Compliant mode is on

sometimes audio midi setup needs a spring clean so as to present the right devices (i.e. delete all those e.g. A4 entries and then connect the A4 and enable all three modes, then the entries will be freshly repopulated)

The point to mention this is to prioritise that the USB MIDI mode is teh one chosen on teh device and that this is set before starting Sysex Librarian - after that it should be fairly straightforward to back stuff up using ‘record many’ or ‘record single’

Has anyone found a way to do this yet on Catalina 10.15.7 with machinedrum?

I’d head over to the x. 04 thread. Plenty of people using every OS over there for transferring firmware and samples.

What precisely do you want to do?

Thanks for the tip! :pray:

I found a way, I just want to backup the machine then update it. Found out that snoize’s sysex librarian worked with catalina and now the machine connects. Happy days.
Just worried that my backup on the machine (selected backup ALL and have the file on computer now) actually contains it all if the update fails on the machine I’d like to not loose the work.