Best way to connect Digitakt & Digitone?


Hello Elektronauts!

How I connect the wonderful Digitakt & Digitone-Machines best way playing smooth together?
It would be great if someone could write me a little instruction : )
How to set up MIDI, AUDIO and internal Settings, and whats maybe to consider.

Thank you very much and have a nice weekend,

Alex : )


Page 67 (section 16.2) of the Digitone manual details a typical setup for using the Digitakt and Digitone together. Have fun. :okej:


Oh! Thank you very much!

Best, Alex : )



So, i connected and set it up like written in the manual ( and BOs Video) all wents well, Digitakt sends Clock to Digitone, but Programchanges , like synchron Patternchanges don’t run.
What doing im wrong? Patterns don’t change on both machines when i change a pattern on the digitakt, nothing happens on the Digitone?
I have checked all settings, (send, receive etc on both devices)

Thank youuuu!

Best, Alex : )


I’ve had the same issue- you have to specify a specific channel for the pgch to be sent and received.

Also, if you’re doing poly rhythms, make sure the ch. length is the same


As Ryan said, there’s a specific setting for the MIDI channels used for sending & listening to program change instructions - in MIDI -> CHANNELS, and scroll to the bottom.



ON digitakt MIDI > Channels > Prog Chg Out Ch 1 & ON digitone Channels > Prog Chg IN also Ch 1 RIGHT?!
Only one takt later the digitone steps in, they are not change the pattern at the same time …


Make sure you have both updated to the latest OS. 1.02 for tone and 1.08 for takt. This was a known bug in the previous takt OS’s. If not that, make sure ch. length matches on both.


Small counter arguement/Devils advocate for anyone reading this thread:

One thing I would say, my initial messing around linking these two together, after having created a ton of beats/loops/whatever on them individually, mixing and matching pattens on them both is some of the most fun I’ve had. (the midi link was still linking the tempo) I wouldn’t have found out if I had linked up the program midi switcher straight away.