Analog rytm mk2 midi clock issue logic x


#1

Hi guys, i’m a newbie of this forum.
Here is my question regarding my new Rytm MK2.
I have problems with MIDI CLOCK synch using Logic Pro X as Master.

Everything works fine except for a strange fluctuation of the TEMPO, it changes on every measure up to ± 5 bpm.

For example, let’s assume that my DAW project is fixed on 120bpm.
On first bar the Rytm’s display shows 120bpm, but on the next it starts changing randomly to 118 than 122 and so on, even 126 sometimes.

I’m confused, i didn’t have any similar problems before with my other gear.
I have already set my Rytm synch preferences to MIDI only, but the problem it’s still there. I though it was an issue with the swing amount, but the problem it’s the same with every kit/every pattern.

I read of similar problems on some other threads, but i can’t understand if my issue is due to MIDI jitter or something else entirely.

My routing MIDI setup is the following :
Logic X ----> send MIDI clock/data to Audio Interface(Focusrite Clarett)
Focusrite Clarett MIDI OUT cable ---------> MIDI IN Rytm plug
Thanks to whom will have the patience to help/reply.

I will upload a short video of the issue if this can help find a solution.
see ya - Giorgio


#2

But what does it sound like? The MIDI bpm display will tend to fluctuate as the receiving device continuously calculates what the BPM may be, based on the incoming clock.

Try a simple test: Logic click track w/a snare on the Rytm. Play and see if they audibly stay in sync.


#3

While I agree that if it sounds right, then nothing else matters, I think displayed fluctuations of up to 5bpm seems unusual and may indicate a problem.

I’m using bitwig as master. If I send clock via midi through a motu 128 to a roland tr8, I see the displayed tempo fluctuating at approx 0.1 bpm. And I can hear the slight phasing effect if I try to match something like a 4 beat kick pattern with one I already recorded. But I can ignore that. I’m using usb from bitwig to sync my rytm and a4 and the displayed bpm does not appear to fluctuate at all.

Do you have the ability to try usb instead of midi to see if that makes a difference?

David


#4

Not yet. I think that i’ll have to wait until February for Overbridge…than i’ll use usb midi synch instead of midi cable.


#5

For what i’ve seen, this fluctuations are real, i can hear them clearly…but they are also pretty visible by looking the transient form. Maybe, my MIDI clock is bad, and the fluctuations are too big for my AR to handle.


#6

You should not need overbridge for midi clock over usb. Once you connect the usb cable the rytm should show up as another midi device. (Maybe disconnect the midi cable when you first do this so you can see which is which). I’m using usb on a win 7 system with bitwig. It works well - I found the timing was approx 3ms better this way compared to midi cable.


#7

i’ll try it right away. Let’s see what happens


#8

IT WORKS. Via usb, it works like a charm with no jitter at all, max ±0,1bpm, but there’s not an issue…I don’t know why, but i was strangely obsessed by the idea that my DAW wouldn’t have recognized my AR without a software plugin/driver like Overbridge…thanks you guys. :wink:


#9

Ha! Nice. I have to admit that I also came to usb almost as a last resort. I even went out and bought a new midi interface when I got the rytm because I had run out of ports. I had some occasional timing issues though - which I probably could have lived with - but I tried usb just on the off chance it might work better - and it did!


#10

You don’t need Overbridge to use the USB port for MIDI.


#11

@ Sbatakkio85

Im having the same issue. Can you please tell me the steps you took in logic?

I have my rytm mkii connected via usb, and i see it as external midi in logic and i get sound but i cant get it to sync and to start /top at the same time.

Thanks :slight_smile:


#12

Hi, just go on midi preferences, midi sinch, and then select Elektron midi usb interfacce on destination 1 or 2. That’s it. If you need i can send you a screenshot


#13

@ Sbatakkio85 Thanks that did the trick :robot:


#14

Glad to help…see ya!