USB devices losing connection, windows 10

Ive just started having major problems with my gear losing USB connection on windows 10.
overbridge stops recognizing my gear, also my other synths connected by USB stop being recognized and no longer show in the list in ableton, it seems the drivers are all failing if something is switched off and it will not connect again until i restart the computer, and even restarting the computer gets stuck…

something is corrupted and locking up my USB connections,
has anyone experienced something like this and can save me some time trying to fix it?

Start by cleaning up all the devices that have been connected! Unplug all the USB devices before using this Tool (Device Cleanup Tool):

https://www.uwe-sieber.de/misc_tools_e.html

Then plug in one by one msking sure it is fully installing/working before moving on to next.

Make a note if which USB port you using for each device and avoid swapping around.

3 Likes

thanks man will give it a try.
trying one by one until i get a fault sounds like a good idea

I’ve just experienced a whole circus of “now you see me, now you don’t” with my M:S synced with my DN in Overbride/Ableton.
I have a lot to investigate but i was just gonna make a similar thread and ask where i could find older versions of Overbridge.

I’m missing versions between 2.0.41 and 2.0.47 and i’d like to make some tests to compare behaviours.
I didn’t use Overbridge until recently but it’s the first time i’m having so much problems with connections, engine status, sync/transport…

Gah, I hate win10 forced to update to it recently and found it to be pretty flaky (brand new installation on brand new PC) spent 40 minutes yesterday just trying to get a 35 byte sysex message to send, on XP or 7 it would have just worked without any fuckery in about 1 minute or less.

It takes hours to remove all the shit stuff that comes by default, they really don’t want you to, and to set it up like a usable OS by fucking off all the crappy self hiding scroll bars, putting shortcuts back that they went to great lengths to hide under the fisher price facade, like my computer, explorer, device manager, and other stuff that is actually useful. I hate it so much, proper dumbed down bloated shite “consumer” OS.

I have not really tried OB properly yet since updating, but I don’t have much faith TBH.

1 Like

Did you try it? I’m experiencing something similar.

Not yet, I haven’t used my gear much but happened again last night.
So might try it soon… I’ll let you know

Strange you are having similar problems,
maybe it is something to do with overbridge as I originally thought?

The latest OB version was super stable until recently. Do you have an Elektron Overhub? I have one and just like that, without moving or connecting anything, one of the USB connector stopped working. I’m wondering if this could be the reason why sometimes my Elektron devices get disconnected.

yep i have overhub but have DT/DN directly connected to computer…
I just turned everything on and still everything dies loses connection even DN/DT

could be windows update or overbridge or driver problem?

I would be very surprised if it were OB. How can it goes from stable to unstable.

Something has changed in the Matrix.

1 Like

The tool would not work for me, would not open
didn’t have any problems for a while now can’t even turn all my gear on…
all USB just dies…

Do you or anyone else have any ideas ?

I’ve been trying for hours just to be able to switch my gear on without it failing

You tried with going back to an earlier update version of W10?
I’m just wild guessing as non-expert.

1 Like

Thanks, if I can’t figure it out I may have to try something like this…
The computer won’t shut down when I’m having the problem and must force it to power off…
Something is corrupted…

I have just seen that your first post is 13 days ago. Officialy its 10 days to roll back. You see if its greyed out.
Don‘t know if its a good idea to try this below to change rollback time or a clean install is probably better. Or its anyway something completely different.

Didn’t see it mentioned in the thread so if you haven’t done so already, check the USB Selective Suspend options in your power settings. Also, is it running in fast boot mode? (Also known to cause issues with startup and shutdown)

1 Like

Go into device manager.
Go to USB serial bus controllers.
Go down each one on the list and do the following:
Right click - update driver - Browse my computer for drivers - Let me pick from
available drivers - select whichever is displayed.

This will reset your USB port and usually gets dead USB devices working again.

1 Like