Question about using midi auto channel with my Syntakt and Minifreak

hey all. I’ve got a syntakt and an arturia minifreak. My ideal setup would be to use the minifreak to control whatever track I have selected on the syntakt, and for one one of those channels to point back to the minifreak. I’m trying to get this to work, but it isn’t working as expected.

In order to accomplish this, I connected the two devices via midi, turned off local control on the minifreak, and set autochannel on the syntakt to the channel that the minifreak was coming in on.

This works great for the keyboard, but I’ve realized that most of the knobs on the minifreak no longer work. Anything that is a parameter (envelope values, oscillator parameters, etc) doesn’t work at all on the minifreak while local control is off. I would kind of expect these midi signals to get sent to the syntakt and then get sent back to the minifreak, but they don’t.

Is there some kind of setting I need to set on the syntakt to have CC sent by the minifreak sent back out of the syntakt? I’ve confirmed that the minifreak is sending out midi signals for those knobs (most are CC, but I found one that’s "general purpose)…

Set 8 CCs in appropriate page ?
Elektron and midi…:expressionless:


In theory using a midi machine sent to MF’s receive channel and turning on the Values 1-8 will by default both respond to and send CCs 70-77 on the MiniFreak—so they should remotely control themselves, on what are usually by default the filter and filter envelope controls…


IIRC it responds to 70-77 only, and send what you set, isn’t it?
Don’t know if all Minifreak knobs can be usefull considering this…


Got it. Yeah, the Minifreak has far more than 8 knobs that I consider essential for operation. I guess the workflow of using the midifreak to control the syntakt and also controlling itself isn’t really an option.

I also have a Zoia that I want to add to the mix, as well as a midi splitter. Maybe I can do something to send midi back to the minifreak from itself, but only when I want to. That will enable me to control the syntakt instruments via my keyboard without the minifreak making a sound as well. A bit cumbersome, but maybe it’ll be worth it.

Yes, Zoia can be a really good midi processor I used to make midi scenes from Octatrack crossfader. You can easily remap CCs, make a switch for that feature.

If you have problem setting it, don’t hesitate to ping me…

1 Like


Now that I think about it, this is actually probably the best way to do it. I could send midi from the MF to the Zoia, and use a button to decide if I want that midi to go to the syntakt or back to the zoia.

Then, I no longer have to give up one of my syntakt tracks for the MF. I was using that channel to route midi back to the MF, but the zoia takes care of that. I was likely going to use the MF sequencer anyway.

I could even create a page on the zoia that lets me decide which syntakt track to send the midi to, rather than using autochannel. That could even be a good way to use it for my other two items, an NTS-1, subharmonicon, and the zoia itself. I’ve got a splitter, but could also use midi-thru for a lot of that.

This honestly sounds kind of fun to set up.


It sounds like you may have found a solution with the Zoia.

But I set up my Syntakt and MicroFreak together as a test.
It can be a bit risky to have MIDI in/out cables connected between two devices like this, as you could create a MIDI feedback loop that crashes them.

But a setup which seemed to work was:

  • MicroFreak Output Channel 14 (the Syntakt Auto channel)
  • MicroFreak Receive on Channel 16 (unused)
  • ST MIDI Clock/Transport/Prog Ch. Send Enabled
  • ST MIDI Clock/Transport/Prog Ch. Receive Disabled
  • ST Track 8 (any should work) assigned a MIDI machine, sending on Ch 16 for the MicroFreak.

The key to making it work was to not disable local control on the MF.

If I want to sequence one of the ST tracks using the MF keyboard, all I do is select that track and turn down the MF’s volume to 0 so I don’t hear local playback.

If I want to sequence/play the MF, I select Track 8 and turn the volume back up.
Doing it this way means you are not locking out the local control.

It’s far from ideal - especially if you’re wanting to do this in a ‘live’ setup.
But it works if you’re more comfortable using a keyboard to sequence tracks on the ST and don’t have a dedicated MIDI controller.

It doesn’t seem like recording automation from the MicroFreak works in this setup though.
If I adjust the amp attack I do see trigless trigs (yellow) being placed in the sequencer, but they don’t seem to actually do anything.
So if you’re wanting to automate parameters on the MF via the sequencer, it should be done via your eight assignable CC values from the ST side.

Turning the Minifreak down when I don’t want to hear it definitely isn’t really in the vein of what I’m trying to do, but I appreciate the suggestion.

Yeah, it’s far from ideal.
Unfortunately there’s no real “MIDI Mode” for the keyboard to use it as a proper controller.

I ran across the same issue with the OT and minifreak, even with direct cc enabled on the ot (so it should pass through any cc).

Its a shame i really wished to use it as a proper master keyboard for the elektron. Hopefully arturia will come out with a local off for the keys only.