Program change messages not handled as expected

i am having this same problem, only, no DAW, the same sync issue occurs just using the Octatrack as a midi master! if the AR has an advanced pattern length longer than the OT pattern, then the program change is queued and waits for the amount of steps specified by the CHNG param. so frustrating!

any good news on this issue?

Bump! Would love to see my boxes responding to program change instantaneously in Direct Jump mode. It’s such a terribly annoying thing… makes my live twice as complicated in terms of sequencing

bump again for solutions. @Olle, devs, any chance of an optional “immediate prog chg” setting now that overbridge is out?

No. Because.

I can understand why this is not possible to send changes instantly because it needs to be cued up and all,
But the changing late when sending program changes at the correct time (early) before end of pattern From the Octatrack, doesn’t work when in advanced mode inf, Chang 64 it changes late. this wouldn’t be the same problem would it? Not getting any answers about this?

Sorry, that’s just not true !

A4/AK can change patterns instantly with multimap at the press of key or at the reception of a midi note…

MD and MnM can do this too if I remenber correctly…Any other machine in the world does this…

After a long exchange, following a support ticket, where I have been explained what was a midi cable.
I finally got taken seriously.
Then my interlocutor changed. We stopped talking about latency, and midi limitations and then came the magic words : politics, design choices, product lines etc…Which means : because.
You can find extracts of my ticket here and on muff wiggler…

If I read through the lines, I’m pretty sure they did this so that you never get clock/sync drifts when changing patterns with pchanges because the implementation wasn’t so good.

What can back this point is that you can make perfectly timed instant pchange using a midi processor.
Send a pchange from any device to a midi processor.
Midi processor store pchange, send a stop message to any of your elektron box, send pchange, and send start message.
Problem solved, no drift, no sync issue and more messages,processing and time used than a simple pchange…

They could have left the user to decide if latency/drift was acceptable or not but they would have get requests and support tickets to improve this behaviour with tons of threads…Easier to blame midi specs imho.

1 Like

Yep. :wink: You can use any midi message. The best being notes for Octatrack.
Instant program change OT pattern - possible?

1 Like

i agree with what you are saying about instant pc ,
but im talking about a separate issue,
when you send a pc from the octatrack to the analog rytm cued up early before end of the pattern to do a pattern change as its designed to do,
if the rytm is in advanced mode,and your pattern length is set to 128, 256 or INF or anything other than the exact CHNG length the CHNG setting doesnt work properly, the pattern changes late!
seems to a bug or something with the CHNG setting when receiving PC…
ive looked further and CHNG didnt work at all in previous OS

I understand what you mean. Unfortunately the current workaround is using a midi processor.

im honestly pretty surprised one of the main elements of the elektron sequencer doesnt work when linked to other elektron gear, they can work stand alone correctly but cant change patterns chained together using all the cool polyrhythm stuff properly…

funny thing is, it does work when you change patterns via overbridge channel 16

Chng in advanced mode not only doesn’t work with external PC but doesn’t work in chains or song mode. The parameter only seems to function when using sequential change manually on the machine.

(I’m on an old OS but I’ve heard nothing saying it’s any different currently)

1 Like

Do you know if this Is how it always has been or is it a bug?

My workaround is to use the overbridge plugin channel 16 and use the lowest notes to have them change at the same time and then you can use this feature like inf settings and it works.
I guess because it’s not a pc message… But I would like to do it without the computer

It’s always been like this at least since 1.31B when I tested. I’ve always considered it a bug but after reading the discussion I’ll link below that includes responses from support I’ve been meaning to give it some more thought and decide again. I do think chng should work from external PC but am now unsure about how I feel about chains and songs and haven’t taken the time to thoroughly think it over.

It has the same behaviour on all there gear, it works properly when changing patterns by hand,
So why shouldn’t it work the same from pc or chains/songs…
At the moment it is Changing but late from pc so that certainly isn’t by design.
Definitely a bug

unfortunately i have had an identical merry-go-round conversation with support. same thing down to the T. first an intern giving copy pasted replies about very rudimentary things (tech support equivalent of “did you turn it off and back on again”), then got handed off to someone more knowledgeable, who was disappointingly evasive about the issue, until finally admitting that this was a known problem and that there was internal conflict about how to address it (“i will ask the engineers again if they would consider changing it”), and concluding with the manual reference. when i pointed out the machine does not behave as described in the manual i was told “oops we should take that out of the manual.” frustrating, because the way the CHNG function is described in the manual would be a perfectly intuitive function. i hope with the increasing frequency of support tickets they will finally do something about it.

I’ve messaged support getting similar story, don’t think it’s going to change or maybe can’t be changed it’s the same on every elektron. So if using inf settings just have to change by hand on each device or use overbridge and channel 16 the Chng value works via overbridge.
It certainly doesn’t work correctly when using pc messages, and works just fine without.
So no point dwelling on it I guess just have to work around the limitation unfortunately