Problem recording velocity in live recording mode


#1

Hello,

I am new to the Elektron galaxy and recently joined with an Analog Four (v2). I spent a lot of instructive times watching videos, RTFM and also reading some very interesting topics on this forum (thank you !)

I still have a problem with the velocity recording, for which i dont find any solution, so i am thinking maybe some of you can help me to understand better what is happening :

  • I am a keyboard player. My Analog Four is connected by MIDI to a Nord Piano.

  • When i play with the keyboard on a synth track, the sound is nice. I can play with the velocity and the synth answer properly.

  • My problem is when i do a live recording of a keyboard sequence, the velocity is not properly recorded in the p-lock. Some trigs are p-lock with the velocity as i played them, but most of the trigs are not p-lock and then played at the velocity level of the track.

The result is a very messy sound (which could be nice sometimes but not always)
and a lot of misunderstanding !

Is it a normal behaviour for the beast ? Or do you have any idea where the problem could come from ?

I tried on different kit, different track, different sound… And i always have the same problem…

Thank you !


#2

Doesn’t sound right, it’s not normal and doesn’t make much sense

Ensure your Nord is set to the (exclusively numbered) Auto channel on the A4 - so if Auto Channel is 10 or whatever set 10 (which will not be used by another MIDI service on the A4)

Keep it simple - and record basic passes of notes onto a new pattern via the Nord, if you are getting Notes with no velocity assignment then that is odd - that sounds like the step recording mode was used on the A4 (as it has no velocity) - sounds like it could also be a case of recording parameter locks and confusing those for notes ? I dunno, don’t know the nord or your midi setup

but if you attempt to do simple methodical tests and still get inconsistencies then it may be a bug - but try with as little gear connected as possible and try a different input device if you can too - it makes no sense for the A4 to record the MIDI note but drop? the velocity !


#3

thanks for your answer avantronica !

i made some new test today. First, i made sure that the auto midi channel on the A4 is the 1, and turned off every other midi tracks. I made test with the Nord Piano, and also with a Arturia keylab. Same result.

I still have the problem but i think i understand when it is appearing. It seems to be when i play note legato (start playing the second note before totally releasing the first one). Then the second note has no velocity parameter locks (and same for the next…)

Is it a bug or you think it is normal ? Do you have any idea how to fix ? it seems like a big problem as there is no sustain on this synth so how do you record soft keys ?