Pattern change OT from TR8S

Are you sure your tr8 is changing patterns in that first video…it looked to me to only be changing the pattern variation(staying on same pattern)…hard to tell.

As my posts above I had to set the OT to master. then TR8 changed on point.


Can you post some photos of the settings you have in the Octatrack for this. Mainly the bank and pattern and CC set up please.

With OT master clock, PChanges should be sent in Midi > Sync menu, not in Midi Note Setup (more appropriate for synth presets changes).

PChanges sent in Sync menu are sent before the end of the current pattern, Pchanges sent in Midi Note Setup are sent at the beginning of next pattern.

OT slaved, with a midi processor, you can have direct pattern change.
You have to map the TR8S PChange to the following messages :

1 Like

I have the OT as master and yes I realize that I did get my jd-xa to do it set 1 cc control to 0 and a second to 32 I think then set bank to 85 and pattern to which preset I want. I just cannot figure out the tr-8s.

1 Like

The TR-8S does not respond to Bank Select messages: just use Program Change messages.


Ok so I just set up the midi channel and set bank to off and program to a number and it should work? Do I need to do any thing in the MIDI NOTE SETUP menu?

It depends what method you are using for sending Program Change messages. See the other topic that you created on this subject:

1 Like

OT master-
Transport send on, clock send on, Prog change send on.

TR8 slave -
Rx start/stop on.
Rx program change on

Set both to same midi channel.

1 Like

Any delay when changing pattern from the ot?
There is a one bar delay in the digitakt when having octatrack as master…

1 Like

Hi! I have the same problem with TR6S. I understand that it’s been a long time) Do you remember if you managed to find a solution then?

same issue here, did you find a solution? :slight_smile:

Nope, I have changed my workflow instead

This a known problem (i’m trying to do the PG thing from an OT to a Digitone)…i’ve sent an update request to elektron, they’ve confirmed the issue to me.

please send a mail to elektron, it needs to be fixed asap

gonna report that too :slight_smile:
I am now running the TR8s as a master clock and sending program change to the OT which then sends program change via MIDI OUT to Digitone. This works for me and they stay synced up when changing pattern. Unfortunately they still are both at least one bar late when changing.

Did not find any workaround yet.

1 Like

I realise this thread is a bit old, but maybe others stumble upon it in the future and are interested in the results (as I was today).

My setup is OT (v1.40a) as midi master and TR-8S (v2.51) as slave, connected like: OT midi out -> Midi solutions Quadra Thru -> TR-8S midi in. I can confirm this works well, e.g. regarding Program Change, with no delay. I’ve successfully tested both methods (1. “OT Global program change” and 2. “Program change on OT midi channel”) as described, in a concise way, by @PeterHanes, here Pattern changes on tr-8s by octatrack - #7 by PeterHanes.

Regarding lag when changing patterns, I understand the issue since I’ve seen it myself when slaving my friend’s DigiTakt, and it changes pattern one “master length” late. However, I don’t have the same problem with my TR-8S. So far, it’s changed pattern at the correct time together with my other gear (Analog Rytm and Minitaur). I can’t say that I did anything special to achieve this. Once I figured out how to set up Program Change on the TR-8S (basically to set “Utility->MIDI: Rx Prog Chg” to On and change “Utility->MIDI: Pattern Ch” to the channel your OT is sending Program Change on) it’s just worked.

Happy to answer if anyone has specific follow up questions :slight_smile:

1 Like

still an issue (i don’t have a quadra thru, it should work without one) here ->Bump

I have this issue as well.

I’m using Digitakt as the brain, all the other gear are in sync, except for tr8s. It goes out of sync on every pattern change :frowning_face:

Tried everything but couldn’t find a solution so far. This is just unbelievable…

Stll having this issue today.

Hi @venusexmachina

Downgrading to firmware version 2.0 solves the issue.

This is the thread where I learned about that workaround. Hope it helps!

1 Like

I’ve just received my new tr8s with firmware v2.51

Is it possible to downgrade?
Where do I get v2.0?