Overbridge issues with MacOS 10.15.6?

I upgraded overbridge to the latest version yesterday ( and after that experienced some weird crashed (kernel panic type) so I figured it might be related.

Then I noticed there was a MacOS update available (10.15.6) and installed that.

Now, overbridge doesn’t see my Analog Rytm and Analog Heat anymore. I’m running the latest firmware on both. I’ve tried uninstalling and re-installing Overbridge as well.

No luck :cry:

Anyone else experienced this? Suggestions are welcome…

OK never mind. I plugged everything in again after using my laptop for something else, and now the Engine shows the devices and everything just magically works again.

I did open the Overbridge Control Panel this time, maybe that changed something… Odd.

But no, it’s back again. Had a freeze of my OS and tried several restarts to get the devices back but nothing so far. I’ll take this up with support.

Found this related thread about issues with the latest Overbridge

1 Like

OK I think I found the source of the connection problems. It was Overhub. I took the external power off the hub then reconnected both usb and power and devices appeared again.

The connection problems were likely unrelated to the crashes caused by the latest Overbridge software, so I think I’ll just downgrade that until they’ve figured it out.

OK so today I’m back to my computer not recognising my devices and no amount of restarting, unplugging, rewiring seemed to fix anything :frowning:

I want to downgrade but I can’t find any release archive. If anyone still has the previous MacOS version of overbridge please PM me.

I had to reinstall overbridge completely a few times to get this version to recognise the devices, also try switching to midi mode then back to overbridge mode on devices

I’m still having problems with crashes on windows and other people also are having problems… loading old projects because of the substantial updates to the digitone and digitakt os has caused backward compatibility problems
Also I have to switch on my elektron gear only after opening a project or it will crash
I’m hoping the next update fixes the problems from

My problems seemed to be related to Overbridge again. Where last time I simply fixed it by disconnecting and re-connecting things (trying out different ports too), this time I somehow couldn’t get it to work again.

But then I tried connecting my devices directly to my laptop without Overhub and that worked.

I was using a cable I bought myself to go from usb-c (laptop) to usb 3 micro male b (overhub) and maybe that cable is not the best quality.

I then tried connecting Overhub via the original usb a male cable via a usb a -> usb c adapter cable and that worked.

Strangely after that I tried Overhub again with the other cable and it worked as well. I have reconnected and powered off/on things many times before, so I have no idea why it is working now again. The connection of the cable seems to be stable even when I wiggle it around.

So yeah, I guess what I’ve learned from this is that you better first try swapping different cables / adapters before reinstalling Overbridge many times over. It’s a lot quicker :slight_smile:

That may have been your problem but it’s not for me as I’ve used the same exact cables and setup and it worked prior to and I’ve tried using different ports etc anyhow

i am done with that sh*t. I try to get my Analog heat Mk1 and my Digitakt to work since years! if I could I would… I don’t know… sorry… i’m so annoyed. so much money … for nothing. Electron make big promises and then? again nothing…

Ohhh … I did it. Threw the Digitakt out the window. It was just annoying. To put my mind at ease, I ordered the new NI Machine +.