Overbridge 2.0.17 Public Beta

That’s weird - that happened to me last night but with the Analog Keys. Everything was frozen on the device - completely unresponsive to any input - but I could still send notes & controls to it via the OB plugin. Had to reboot the AK to regain any direct control.

digitakt os upgrade is stuck at ca 40% “receiving” firmware 1.11b7 - transfer on macbook has long ago sent 100%…

- digitakt still was in usb-overbridge-mode. duh.


Did yours STROM app stopped also working?

I also changed to a previous iPad…it can be from it too. Anyone?

Unfortunately I might be seeing the same thing :frowning:

Are you hearing a buzz when the DT freezes?
It’s happened to me twice so far, and both after about 30 minutes of working.

Too bad because the previous beta was working great for me (Win 10, DT as audio interface, FL Studio 20).

The other issue I’m seeing is that the DT VST can take 30 seconds to initialize/connect.
I opened a support ticket for this one, and they have the OB logs.

Best regards,


This might be a dumb question but… there’s nothing special that has to be done in order to refresh the VST plugin if the new beta of Overbridge is installed with plugins, correct? In other words, the new plugin should be correctly referenced and loaded in any project which was made containing the old VST plugin.

1 Like

Correct unless it was before the plugin was signed as Elektron before in the earliest betas it was something else

1 Like

since i updated to the new build my analog rytm mk2 keeps on crashing. never had this issue on the last build. it sounds like it got stuck in one sound on 64th notes! have to restart it afterwards just to have this issue 2 minutes later again.

Also it appears that the samples on my elektron are still there but cant be assigned through the AU (Field is blank after a while)

1 Like

Just tried the update. Firmware is working fine on digitakt and digitone. But Overbridge 2.017 wont Install on macOS 10.14.5. The installation Process aborts in the middle. After that, System security informs me, that it has blocked the software, because it has no legitimation. After I grant that, uninstall and retry, the Installation process aborts again. :frowning:

Installer Issue on Win 10



re-downloaded three times, checked archive for errors - nothing. anyone else?

OB Engine is not running, rebooted.

EDIT: Reinstalling OB 2.0.16 allowed me to successfully install OB 2.0.17. - working now.

I had that result but using Wine on Linux, so I assume it is to do with that as I’ve never had any luck getting it to run properly with an earlier version of OB2; though the full GUI will appear, the A4 will.not connect.

I also tried installing OB 2.0.17 on a 64 bit Win 10 virtual machine, and while it now installs, I get just black windows when opening the Overbridge Engine or anything else. Again, this may just be a result of using a virtual desktop.

I am also having the same problems. Sound disappears almost completely if drawing even a simple slope for frequency. It works quite well if I only set one value once through automation though.

Two questions regarding sampling on the Digitakt through the Overbridge VST. Forgive me if I’m missing something obvious here, but I read through the manual and didn’t find anything answering this.

  1. Should I be able to send audio to the VST and record it into the Digitakt? I’m okay with running audio cables from my interface into the Digitakt’s inputs but I just wanted to check if I’m supposed to be able to avoid that. I can send audio to the track that the Digitakt is on in Bitwig but it doesn’t make it to the Digitakt.
  2. Is it normal that input monitoring doesn’t work from the Recorder screen on the Digitakt itself? Turning it on doesn’t seem to do anything. It records fine, though, and playing back recorded samples works as expected.

Thanks all!

1 Like

Latest firmware on DT and OB beta seem to work fine now ! Finaly able to sequence and record external gear through Audient and 8 channels ADAT simultaneously with the DT separate channels through OB in sync. :grinning:

With this version I am experiencing issues with my AR MK1 vsti plugin when assigning a sample from the file menu to the sound pool. After opening a project in ableton, I start editing my sound in overbridge only to be halted by the fact that the sample file and folder menu are not visible.


The standalone AR editor version displays both files and folders correctly and only after I have exited ableton and run the standalone version will the issue go away. Rebooting my project in ableton after running the standalone AR editor seems to correct the issue. The issue is quite random and doesn’t necessarily happen every time that I open the vsti plugin to make edits with samples.


Will you add also pads for changing patterns and bank inside the overbridge app and are you planning to join the sample & sysex management into the overbridge plugin?

1 Like

Please report issues using this link, as I just have:

Nobody’s going to bother reproducing things mentioned in this thread (at least, I don’t think so). It’s kind of a pain, but it’s the only way the developers will have an organized way to look at these issues. I’m as disappointed as all of you that this is still as buggy as it is, but let’s help them get somewhere positive.


Not so long as you actively remember to move the right VST (Not stand-alone) files into your selected VST folder with every update.

I think all I did was run the uninstaller? That’s what I was promoted to do, if I recall.

One thing I spotted is that the version number is in the lower right of the VST (at least it is for DT)


That helped me confirm that I was running the latest one.

Best regards,



@Gino that’s mad smart, thanks