Octatrack OS 1.40A: bug reports

Yes I use the midi update midi out to midi in, but the channels are nicely set. Only one channel mapped maptrack

So first remove the midi cable and ensure everything works as it should.

It is impacting incoming midi notes lol, on the last arp Param IMO (length)


I got my Octatrack mk 2 a year ago and have been enjoying the ride so far. However, I have encountered this issue for which I have not found a solution yet. Sometimes when I activate arranger mode (func + arr), the project menu opens up at the same time. This happens randomly and can break the flow when playing live. Has anyone else encountered this? Is there a possible solution? Thanks in advance!

Yeah, there seem to be a bug on mk2s and IIRC Elektron are working on a fix already.
For some users Func + Arranger opens the midi sync menu, for others it’s a different button combo executing wrong commands.

Might be a good idea to contact Elektron support, so they know what they’re dealing with and don’t miss any specific issues there.


There seems to be a bug in the handling of micro timing of the final step in a pattern, at the time the master track loops back to step 0. A trig placed on any of the the last 3 micro positions is not being played.

For more details see Last 3 positions of micro timing not playing on master reset

This is especially problematic when you live-record un-quantized notes, because for example if you let a recording run for one cycle and then you trigger your first note which was meant to land on step 0 a little bit early, it will be dropped from playback (if it coincides with master track reset). That is how I ran into the bug.


I’m getting the ‘FUNC + ARR’ opening ‘MIDI SYNC’ also on my grey MK2. I’m getting the same issue when I press ‘FUNC + REC3’ also. I’ve submitted a support ticket so Elektron know.

Update: I heard back from Elektron, this is what they said “This is a confirmed bug and we will fix it in a future OS.”.


Just experienced the issue with Trig2 triggering Trig10. At first it was only happening with Scenes but now it’s happening when I’m choosing Patterns. Bummer! Still patiently waiting for the firmware update.

EDIT: Went for it and opened the OT just enough to access the inside and applied a bit of contact cleaner to the board. Let’s see!

EDIT v2: Contact Cleaner seems to have worked. Putting here for future reference and for others who might have this issue as well.


is your OT mk1 or mk2? I would love to know your procedure to try it out myself! I’ve been having way to many issues with this bug and the OT is the heart of my setup. Thus I’m stuck now in terms of playability.

1 Like

Hey, it’s a Grey MKII. Which issue are you experiencing? Scene 2 triggering Scene 10, or Pattern 2 triggering Pattern 10?

Don’t wanna jinx it but I think I was able to fix my Pattern 2 triggering Pattern 10 with the help of some contact cleaner. However, the issue of Scene 2 triggering Scene 10 still persists.

hey Tatak! My issue is related to those buttons. It happens when I am in Mixer mode and use the trigs to mute multiple audio/midi channels. I have also an MKII in grey. When I hold trigs 2 + 9, trig button 10 starts flashing randomly as if it was false triggered multiple times. It feels like a false electrical contact, that’s why your solution gave me hopes. I contacted support and sent them a link to a private video on YouTube so that they can see exactly what’s happening. Asked them as well for an old firmware to downgrade and see if it is software related. Other than that I thought of sending the OT for a check-up/repair if it isn’t stupidly expensive. Let’s see what they reply. In the meantime I’ll try the contact cleaner trick! Any recommended brand? Was thinking about trying CRC since it seems to be very pure (no residues after application).

Oh I only used the can I use for cleaning my electric guitar pots, it’s ABRO, I think. But if you have one that’s really nice, go ahead and try it out?

And yes, it’s the same issue I have. Before applying the contact cleaner, Trig 10 flashes like it’s having a party when I press and hold Trig 2.

I’m hoping Elektron gets to fix this sooner than later for both of us, cos I always worry that the issue comes back when it’s least expected.

1 Like

im experiencing three issues since updating:

  1. the distortion in both filter fx and lofi fx causes audio to glitch out on neighbor and master tracks. the compressor also shows this behavior sometimes.

  2. some flex track feeds back into themselves when changing parts. restarting the ot fixes this behavior.

  3. either my knobs - or the software - is making settings move randomly by +/- 3 clicks.

i would like to add that i am generally experincing audio glitch out, in what appears to have nothing to do with the sample playback, but the audio stream from the track before it goes to main out.

im on 140a, with a mkII from 2019.

Do you have a cable incoming on your OT MIDI IN port?
Do you have a USB cable attached?

No. but i have experienced in later OS versions that an attached usb cable could “corrupt” a sample in the same way - in audio editor it would sound muffled and distorted. same if i found the sample in the audio folder. if i listened to the sample on my computer when connected it sounded fine though. very weird.

but just to rule out : i have no midi connections, no usb, no streaming from static, and lots of flex memory left. i have also gone trough all the trigs, settings etc etc. i am on a new project with one bank active - there is nothing else on the ot as i wiped it before update.

These two are most annoying.

1 Like

I was one 1.30b and my OT froze up.
Rebooted still froze.
VG Test mode OK.
Updated to 1.40D through midi, only way possible.
It freezes on the 1.40 logo screen, restarting it may or may not start all the way but then it’s frozen again.
With or without the card, same results.

I feel you. I always did the update copying BIN file on the card and never had problems, finger crossed.

Are you 100% sure of the way you do the midi update ?

Sympathy here too. Would hate that

Sorry no tips I’ve always done the bin thing. Hope it can get worked out

1 Like

Is there such a firmware?