Octatrack not instantly playing what it is recording through recording buffer

As per Merlin’s guide, I tried a very interesting trick :

But so far, record trigger and sample trigger being on the same step (triggering the recording buffer) doesn’t yield the same result as what is described in the guide.

The playing of the sample buffer, will randomly stop after a bar, or even half a bar, thus disabling me from playing instantly what has been recording.

This should be possible as also specified by this elektronaut post : OT live sampling without a gap in sound - #3 by sezare56

After tinkering for a bit, I found elektronauts posts about microtiming but by doing so, my recording buffer playing in the flex track, wasn’t synced anymore to my live input.

Since the live input is a drum machine, the result is inaudible.

I am pretty sure I am missing something here but unable to put the finger on it.

Than you very much in advance for your help !

1 Like

Trying playing with the amp envelope?

1 Like

attack is 0, rest is inf

thank you for the suggestion though

Is OT receiving clock from the drum machine?


OT is not receiving its clock from the drum machine
OT’s clock is from DT midi out above it
Drum machine’s clock is received from the OT

1 Like

Does the technique work if OT is set to internal clock?


I didn’t try that yet.

Do you think that the sample read could stutter /stop from the clock drift from the DT?

Yes, and someone might correct me soon I’m sure but what I believe is happening is the incoming clock has jitter and OT is trying to timestretch the sample on playback but as there is no data ahead of the “play head” (because it is being recorded on the fly) it just gives up.

I don’t do what you are describing here so I don’t know if it would work, but if external clock is important then one thing to try could be to turn timestretch off for that track and see if that helps.


Yes, possibly, btw I’d also disable timestretch, or add significant microtiming.

Definitely. And if can’t record a perfect loop if slaved.

With OT clock, you can play buffer without microtiming if you record AB/CD.
Even with timestretch on (neutral pitch).

If you record SRC3, +1 microtiming.
If you use timestretch with pitch up, you need to increase microtiming (+7 at 120 bpm for pitch +12). Quick pitch shift variations can cut the sound.


So I made a test slaving OT from ST.
As @JSZ pointed at, timestretch on (neutral pitch) makes recording playback more sensible when tempo increase.
You can add microtiming to improve it, but anyway why using timestretch in that case ?
If you want to use pitch shift up, you have to increase microtiming much more, same if you want to use RATE=TSTR (very interesting btw).

With timestretch off, it works surprisingly well, even changing tempo quickly from 30 to 300 bpm !

Anyway I’d choose OT master if possible. I have to test with my RC500 looper as master btw, because its timestretch fluctuation sucks…


After checking my setup, I believe this is what is happening too.

I turned the timestretch off, (it was on auto) and it solved the issue.

I am still receiving the clock from the Digitakt though, and it works fine, I am going to keep it this way :slight_smile:

Thank you very much fo your expertise and ability to pinpoint the issue so fast @JSZ & @sezare56 !! Much appreciated !