Noise generator on one track gets “reset” by TRG on another?

I noticed tonight that if you have sustained noise on one track (e.g. mute the oscillators, turn the noise up, set a trig with infinite length), and another track is playing which has “TRG” (oscillator retiring) turned on, then the noise on the first track “resets” every time the other track has a trig.

It’s really obvious if you try it, e.g. on the second track add a full bar of trigs, turn the oscillator down and turn on TRG on osc 2 page 2. You should hear that the noise changes from a smooth “untuned radio” type sound, to a periodic sound that repeats every 1/16th note. If you mute the second track, the effect goes away, and if you mess with the pattern of trigs, you can tell the noise resets whenever there is a trig on the other track.

I’m sure there are creative uses for this but it’s not what I wanted as I was hoping to add some noise “swooshes” over my track but as one of my sounds has TRG on, it sounds really weird.

Looking at the manual I can’t see anything about this, nor can I see why it would be so based on the block diagrams - each track has its own digital noise generator, according to that, so it shouldn’t be a single shared noise source that is being reset. Maybe it actually is just a single source? Or maybe this is a bug?

I don’t have it hooked up to record an example unfortunately. I’m on 1.40a, need to upgrade tomorrow, so if this has been fixed already, my apologies!

1 Like

Worked around by putting both osc’s to Input and boosting everything as high as I could (overdrive, level etc) and using the natural noise of life :wink: which actually added a nice dimension to the track as you can faintly hear the tuned oscillators mixed with it (some bleed I guess). Every cloud etc!

Tried here just now on my AK and i see what you mean - weird! I wasnt aware that the noise was really a ‘fixed’ waveform that can be retriggered with Osc Retrig. Would be better if other tracks didn’t interfere though! Might be worth reporting to support…?

1 Like

Yeah weird eh? I will report it to them, thanks for confirming!

1 Like

no dice on a fix on a Mk2 running 150A

this is a good catch, pretty esoteric bug as well, but it appears to be just that, it makes no sense

even using the toggle for use track sounds makes no difference

kinda subtle, but not cool for the reasons discussed - definitely report this and update us

1 Like

Yeah, unless there is a single digital noise source shared between all tracks I guess… even then it might be nice to have the option to exclude noise from TRG. Also weird that the noise sounds identical every time! Maybe its not very random…

Anyway, submitted a bug report to Elektron so let’s see :slight_smile: Thanks for checking!

1 Like

well, the original random LFO wasn’t, so you may be right, it’s (the noise?) a fixed lookup table !!

it’s maybe not the end of the world as is, but it’d be nice if it was addressed, perhaps removing retrig from noise will sort it

1 Like

The specs list 1x noise generator per voice.


Yep, that’s why I think this is unexpected! But you never know, specs can diverge from reality haha

good point, the variations and modulations you can apply attest to that possibility - i see no need to ever retrigger a noise source if that’s happening - this may be teh bug, certainly when it’s retriggering another track’s noise somehow (or sounds like that)


I don’t think it’s a lookup table, because that would take up quite some space for no real reason.

A digital random generator for audio which doesn’t need to fulfill cryptographic needs is cheap to implement, but I guess they apply the same seed value when it resets (== always produces the same sequence of random values).

1 Like

fair enough - but the LFO was a fixed random profile originally, it ran through the same random values if you didn’t adjust phase e.g. ! - it’s only a thought as teh noise burst seems to repeat - it may be something else that gives this impression mind you

1 Like

If the random generator is a fixed lookup table can be tested quite easily. Just record, let’s say, 1 minute of plain noise.

Afterwards extract one side into a mono wav file and try to compress it (zip/rar whatever). The compressed file shouldn’t be much smaller than the original if it is plain noise with no repeating patterns.


Track 1: 1 x trig, length 16 (full page), noise volume only, osc retrig=off
Track 4: Simple seq pattern, all volumes off, osc retrig=on

Sounds like this:

1 Like

Yep that’s what I hear, kind of repeated chunks rather than the smooth “waterfall” noise you get if there are no retrigs happening. Thanks for recording it!

Elektron confirmed this is a bug

We can reproduce this and the issue has been reported to our developers. It will be looked at when work on the next OS update is initiated. The bug is reproducible in older firmware versions and appears to have existed for a long time. One of our developers said there is more than one noise generator, so the issue is likely due to a firmware bug. I have no immediate ideas for workarounds, unfortunately.


good to know, thanks for the update

1 Like