MIDI Plays Free tracks won't play 'Direct'

yep ’ looks like @Clancy concluded on the same issue…
… this looks like an easy bug to fix… should there be any bug fixes ever again

1 Like

Do you know if anyone has submitted a support ticket regarding this?

No I haven’t yet submitted a ticket on this. Last few time I looked into it it seemed like I was uncovering another bug. It’s also one that’s hard to pin down and explain / elimnate my own error / misunderstanding of intended behaviour, - but it’s related so I’m going to mention it here. Please let me know if I’m missing something or if it does seem to be another bug and maybe we can get these ironed out in the next (last?) update…

So - the DIRECT setting doesn’t work on plays-free midi tracks and I resolved to try to work with a quant setting. So, I set it to 1/16 as that is the nearest I could get to DIRECT in terms of musical flexibility.

Well, I found that I could NEVER get it to start when I wanted (and yes I’m aware that won’t be when I hit the button). Always a 16th late. I figured it could be my bad timing, so I slowed the sequencer right down and had a reference track playing every 16th note at a tempo that made it very easy to be sure that I was dropping the trig in the gap between the step I wanted it to start on, and the step before.

Doesn’t work, always a 16th late.

Worse still, this appears to be the case on AUDIO tracks too! arrgh!

So it seems that trig quant 1/16 and trig quant 2/16 behave exactly the same. They both behave the way you’d expect 2/16 to. So started testing the performance using 3/16 and it seemed even less predictable, with varying steps elapsing before the plays-free track would start.

That was around the time I ran into my 3rd hardware problem in 18 months and really lost the will to investgate further. I thought of using a separate sequencer to do the trigging, while providing master clock, just to get as a more accurate test but meh… Just over 18th months with my OT and 3 hardware failures and 4 previous confirmed bugs have left me pretty jaded!!:unamused:

Any confirmation, insights (or just pointing out how I’ve misunderstood!) very welcome

1 Like

unfortunately I can confirm all of the above. never been able to clearly pin point this but seeing it written down makes a lot of sense to me. can’t comment an audio tracks though.
seems like a major flaw to me. would anyone be able to confirm this with the latest OS?

edit: would an admin or the opener care to rename/add this thread to “…won’t play ‘direct’”?

1 Like

I edited the title

I’d be surprised if this wasn’t an acknowledged / submitted issue

Maybe @Ess can clarify this or comment on the background of the issue

but it certainly doesn’t surprise me that transport has to be active

cheers @avantronica
i also opened a ticket: #13769
thanks everyone


quick update: elektron has acknowledged this as a bug. no time frame for fixing it obviously. wonder what you had working @avantronica ?.. cheers

1 Like

i think the illusion it worked was short lived when i tried the Direct option, it did play ball quantised though - i can’t recall if play mode was significant, don’t think so

1 Like

nvmd then… I was silently hoping that i was just using it wrong (I would love this to work)

thanks for the update tasmansea! appreciated

BTW did you raise the quant trigging issue too (1/16 trig quant behaving like 2/16 etc.)?

hey @Clancy ,
sorry for the delay - I have just added this to the ticket (after running a sanity check again with a 16th click track on 30bpm)… cheers!


pretty skeptical about further OT bug fixes - arent there a couple of known bugs that are years old at this point?

Thanks! I appreciate you logging it. I was having my OT repaired and didn’t want other tickets running until that was done

1 Like

Yes this one is very fundamental and sounds like it’s been around for a long time. (Samples get assigned to the wrong machine and the wrong slot):

Another one which constantly requires work around (changing the memory setting mutes machines):

Here’s hoping

Im running 1.25E … because I thought it was the newer updates that introduced the bugs… i will try to replicate this one above with the slots and report back later sometime

1 Like

I did run into the same problem - i wanted to quantize the track start when playing the track in free mode.
As far as i did understood the manual - the track is set to plays free, and should be individually started via:
track + play and start after some configurable step settings.

I can see that the track is playing in the display , but actually there is no LED running from left to right to show this.
Also no midi notes are generated.

I had a sequence which was 16 steps, master length 64.

When i put the track back to normal, the sequencer triggers the steps again. I have not tried it with audio tracks, but i will do that soon. I think its very annoying because it would solve a lot of issues i have.

Is there a similar start /stop behaviour possible in the RYTM ?

Function +Project > CONTROL >MIDI SEQUENCER >check the CC DIRECT CONNECT box

Function +Project > CONTROL >SEQUENCER >should show PAT LEN ( i had here 16/48 =?)

Function +Bank> Pat Scale Mode = Per Track . T1 - T8 check Plays Free and Trig mode ONE2, Trig Quant TR.LEN

At least my problem was solved with this settings, Allen gave me some hints on Facebook, and i thought i share it with you.

1 Like

Did we ever find a solution for the PLAYS FREE MIDI tracks not playing all the way through? This needs to be fixed for the OT to be a full on live brain for shows that use external gear sequenced by the unit/

1 Like

i made my peace with the OT for all its (perceived) quirks but with the ‘plays free’ bugs. something I’m using extensively and wish could be fixed. there are numerous threads on here about quantization issues. I opened a ticket with elektron some time ago and they said it was indeed bung.


I’m not even worried about the quantization. My timing has gotten a lot better. I’m worried about not being able to trigger MIDI sequences live separate from the PLAY button.