MD Won't Turn On (SOLVED!)

EDIT - Tech at the shop says that the power switch was dirty and the connection just wasn’t being made. If you have a similar problem check there first!

Spent about 2 hours going through my iTunes library finding things to sample through my Machinedrum UW, I bring the laptop over to plug in and to my surprise the MD doesn’t turn on… I’ve been using it every day for the past week and haven’t experienced anything that would tell me anything was wrong. I don’t think it could be a power surge issue, it’s been being used beside a Monomachine plugged into the same power source the whole time. It was powered down last night along with the rest of my gear before I went out for the night. Aside from someone breaking in and dumping water inside the unit while I was away I don’t know what could have happened.

I tried swapping the power supply on the units, the MnM powers up using both, MD doesn’t power up at all. I popped the lid and couldn’t see anything physically wrong but I’m hoping there is maybe a fuse somewhere I can’t see that’s been blown.

Has anyone else had this happen? I was in the middle of recording stuff I’ve been working on for the past year and I’m absolutely gutted. This is my favourite instrument I’ve ever had! What should I do?

You could try ensuring that all the connectors between the various internal boards are connected firmly.

Other than that, I suggest that it’s time to open a support ticket on Elektron’s website.

1 Like

:grimacing: Wish you a simple fix!

Maybe it’s the internal battery.