MD UW (upgraded to +) issue accessing snapshots

Hi all,

I had my MD UW MK2 upgraded to have a +Drive, by Elektron themselves.

I received the Machinedrum last week and used it over the weekend, and it’s showing some really unusual / incorrect .behaviour.

It’s all shown in this video (sorry about my dumb decision to turn my phone around part way through): https://www.youtube.com/watch?v=g8dhEfjcrEc

In words, what’s happening is:

  1. Go to Global Settings

  2. Select any Slot

  3. Go to File

  4. Select +Drive > Snapshot

  5. Go to “Load”

  6. Try to scroll down

  7. The entire unit freezes up when trying to select snapshot 002 to load, or move past that to load a different snapshot

I’ve emailed Elektron support, but didn’t know if anyone here had any advice?

Hi!
I suggest you wipe all content and try again.
Maybe its something stored pre mod, mangled data.

1 Like

I’ve tried updating the OS, but was trying to avoid wiping all the content.

Makes sense though, will try that tonight. Thanks for the tip.

This worked! Thanks again.

2 Likes

Glad it helped! Great machine!