Machinedrum UW seemingly freezes when sending from C6

Hi, im (trying to) load samples into my machinedrum sps1 UW with C6, but its been stuck on this screen for about 5 minutes here

and my c6 screen looks like this

any ideas? am i right in thinking that the c6 program converts the wavs into sds WHEN you press send? or do they need to be loaded into c6 AS sds files?

Following because I can’t sent or recieve anything from MD to Computer or vice versa. All I was able to do was send the x 04 firmware and that’s it.

No Sysex will send or recieve, and no samples will either.

ya it should do.
looks like it sent some data. but your MD only received the first part.
what speed ( delay (ticks) ) is it set at? try a bit slower may 4/5/6/7.
try to limit other processor heavy apps (chrome/daw etc) open on your computer during the transfer.
aside from that could try a different midi cable…


OMG thank you, changing the delay to 7 worked a bit! this is actually progress!! the bar fully went up on C6, but on the machinedrum it said “error;wrong packet” at least something changed. thank u
ill google what this means.

edit:btw when i tried this the delay was at 0ms

ok now i played about with the delay and above 10 it seems to give ‘unhandled checksum’ error. hmmm ill report back if i fix it

ok i FIXED IT, i put the delay all the way up to 30ms. such a good feeling watching the little bar go up on the MD screen…although im playing back the sample and its just a tiny little click. maybe the sample is too short…ill try load another


THANK YOU. This worked for me also.


does this mean you can back up your sysex now?

It gets stuck at the very end but after I click stop Rec. It shows up under file name on C6.

Long live the Machinedrum.