MachineDrum Update Fail

No matter what i do, my MD fails to update to either the latest official OS nor the unofficial OS.

When trying to update to 1.63, It always hangs on the last trig and “CP” led. C6 says “Done”.
When trying 1.71, in the last third it will prompt that update failed (while C6 says “Done”)

I tried to play around with the turbo settings of C6 (set it to 1x, 5x, 10x, 6,7x and “NONE” and marked resend files) …

Did anyone experience some like behaviour?

all help appreciated,

cheers, rawghy

if you bought el-cheapo midi interface then you run the risk of losing/corrupting bytes - i have seen this, it happens mainly with sysex - if i were you i’d send the sysex dump as slowly as possible - in this regard sysex librarian (mac) is useful as you can introduce pauses between bytes - i have no MD knowledge about other areas to investigate - you’ll possibly be able to do something similar on PC

2 Likes

el cheapo it is! but is it likely to fail exactly on the same point 10 times in a row?
ill try sysex librarian, thank you!
on c6 i cant really set the send speed?

not at the exact same byte - but perhaps it gets overwhelmed (a theory with some credibility depending on device quality) after roughly the same amount are sent through

perhaps there are two ways to update MD as per other devices

one is whilst device is on … the other is via the startup menu (used less frequently and i have less experience of doing so there, so use with caution via that route)

perhaps re-download the .syx and note down your steps for an experienced MD user to look over

not really - if it can negotiate a Turbo hookup it will - it can be turned off - so it’s normal rate or 10x - i have no idea if the sysex is sent at the same rate, but for sysex librarian the gap between bytes can be set and lengthened - do not go much higher than default or the update could take ages - i guess a few ms is about right

thanks for all the input.

i believe the MD only can be updated via the startup menu. (i did not find another update option as the rytm offers)

i will try some things and let you know.

thanks again!

1 Like

Which MIDI interface are you using? Poor ones will not reliably transmit SysEx messages.

In C6, you can set delay (as a number of ‘ticks’) in the ‘Config’ screen’. Start with a low number.

2 Likes

i’ve had some trouble with different midi interfaces in the past. do you have any audio interfaces with a midi out? that could be worth a shot.

also, do you have both midi in and out connected to the MD?

i must have overlooked this - good to know

and this is actually what solved the problem! delay to 2 and it worked.
running 1.71 now!

not sure if it is about the sps1mk1 being to old for the newest c6 or if it is the cheap-ass midi interface (actually just a 12€ cable from usb to midi in and out).
i did only connect the midi out cable to the midi in port of the MD (as the MD does not need to send something)

cheers to you amazing people!

3 Likes

This.