Issues with New Elektron Website?

Anyone else experiencing issues with the new website, or am I just special?

For me, the site is glacially slow and when attempting to purchase sound packs, the “checkout now” button doesn’t work in any browser I’ve tried.


1 Like

The new site is not up to Elektron’s usual standards. It’s slow, buggy, has redundant content and some bad visual design details (like clipped titles). 8 times out of 10 I can’t log in using desktop Safari.



Yeah the website is one of the worst out there, and I thought Akai was bad :frowning:


Other observations:

1 Like

I refuse to use their new website until it has song mode.


Yeah it’s painfully slow.

Gosh yea… I was on their website trying to get latest Digitone OS etc… Was not very smooth, I guess it will get better over time.

However, objectively speaking, I thought the website looked the worst Elektron website so far. The photos look strangely cropped, and the information layout felt very outdated.

Unsurprisingly surprised.


Also no Release Notes (firmware) are available. Either “page not available at server” or only the latest patch notes (firmware x.xx) are visible. So no way to find out what was added - changed - fixed since the release of a unit.

Release notes of products that I have tested: Model:cycles and Octatrack.

The company could use a new desktop publisher too. Sorry, so many errors and text inaccuracies, improper lining and text spacing etc…
And pages load extremely slow.

Good to know it’s not just me.

Checkout still absolutely not working at all, in case anyone wanted an update on that.

I thought the previous version was excellent. The typography was top notch, the structure made sense, the visual design balanced clarity with just enough personality. The new one stands out for its mistakes not its successes.


I think the new one is OK but feels a little bit more generic and e-commerce oriented - especially the homepage. I even think the Support section is a bit better with resources less scattered and releases notes directly available.

Some UI issues like buttons that have an hover state that do not match their clickability are a bit annoying!

It’s a shame they did not do an SEO audit of all the links the previous website had to provide proper 301 redirects on the new website tho, because coming from Google a whole bunch of links are dead - namely manuals (and then you have to find the resource by yourself).


I did like the old brutally oversized typographic version.

This time it has a kind of retro game style, I actually think it’s cool as well!

The bugs will surely get patched over time.

On thing I noticed though is that SEO has not been retained. When trying to visit many google search results, you get a 404 page not found error.
You do need to retain URL structure when redesigning a webpage (or redirect from old URLs), otherwise you will lose your rankings. And the 404 thing is a bit frustrating as a search engine heavy user :nerd_face:

1 Like

You beat me to the seo thing :slight_smile: Yeah it’s a missed opportunity for sure. To rank stuff from scratch takes a while…


That was made immediately clear to me from the home page url - shows your country’s currency, not country.


it is indeed slow, even the browser is complaining the page is slowing things down. doesn’t really feel responsive, looks like nothing is happening for a bit…could be the images, scripts being loaded…either way, not the best experience :expressionless:

This is the worst website ever. I’ve tried to order stupid buttons because it’s sticky for a Digitakt I never use. I had to try over and over about 50 times and I’m not exaggerating before I could get through that order… The website they had before was perfectly fine and working well but they had to change it for this… Great…

The Google Lighthouse score for performance is 37. Oooof!

1 Like

It’s all of the above - slow scripts, images not optimized, way too much data being pulled over the network on the initial page load. Almost 7,000 elements being rendered. Brutal.

I’m able to check out at the shop though, so there’s something…

1 Like

Checkout still not working.

Yep, was trying to pick up a Digitakt sound pack… wasn’t happening. Just kept giving me an empty basket. I’m a software tester by trade so it really surprises me that they released this in such a mess.

1 Like