How do you make RYTM follow OT patterns?


#1

How do you set up RYTM so that it follows pattern changes from the Octatrack?


#2

Try setting PROG CH RECEIVE channel in the MIDI CONFIG > MIDI SYNC menu.
Make sure INPUT FROM setting in MIDI CONFIG > MIDI PORT CONFIG menu is set appropriately.


#3

OK,
Right now I have it like this

AR/GLOBAL/MIDI PORT CONFIG/INPUT FROM MIDI
AR/GLOBAL/MIDI CHANNELS/PROG CH IN CH 11

OT/PROJECT/SYNC/PROG CH Send checked, Channel 11
OT/PROJECT/MIDI/CHANNELS Auto Off

This allows me to use a midi track on the OT set to channel 11, and the Program Chg # on that midi track determines the pattern number on the AR.
Problem is, that prog Chg # is attached to the Part.

This is where I get confused. How do I make the AR follow OT 1to1 pattern wise?


#4

I believe that you can’t do this with the AR under control from the OT.
It works with the other Elektron instruments as slaves because they have Multi Map functionality where a specific MIDI note sent from the OT can trigger a specific pattern on the slave machine.


#5

I was afraid of that.
I though I had seen that bit of info when I first got the AR, but since I had seen some threads describing the OT A4 and thought maybe this had changed with the AR too.

Thanks for the help.


#6

Is that true ? I can’t slave the AR to the OT, so when OT changes to Pattern B2 the AR does the same… ? What a f… !!! I’m gonna sell my AR (I just have for some days, and today wanted to try out slave him).
Does it work the other way around ? AR as master ?

thanx for answer
tubman


#7

If send program change is enabled on the OT, it will indeed send a program change every time you change pattern. The slave device ought follow, with the slight “hiccup” that the OT has 256 patterns while the other Elektron boxes have 128 so bank I-P on the OT will repeat send the same 128 programs as banks A-B, unless you have a device that handles 256 programs and a bank select message. It is beyond me why Elektron made their analog series incompatible for 1:1 pattern playback with the OT .
Of course, you also have the option to link program changes to parts which still falls short because there are only 64 parts within a project and 128 patterns that could be useful to select. I really don’t get why Elektron doesn’t strive towards a bit more continuity between boxes for core functionality.

Anyways, what was the question again? :slight_smile: btw, I’m assuming you have your AR MIDI ports configured correctly?


#8

I think what JuanSolo was looking for is a more advanced way of pattern changing control from OT to AR (correct me if wrong!) using midi tracks but how you describe it works perfectly fine after some setting up.

I have my OT as master and controlling pattern changes on both my AK and AR no bother at all - unless you attempt to go into banks I-P but even then it isn’t a huge issue.


#9

Im not trying to do anything complex at all, I simply want to change patterns on the OT and the AR and A4 do exactly the same.

Anyway to make that work, I wanna know.

Still haven’t figured out if it’s possible, but I see dataline doing it in his videos I think.


#11

If all you want to do is have the AR switching to (for example) pattern C7 when the OT switches to pattern C7, then you can simply use NRain’s suggestion above.

The AF has the Multi Map feauture which means that you can do more generalized pattern following.


#12

I’ve little doubt that everyone in this thread is a more advanced OT user than I am so please forgive me if I say something stupid or have misunderstood what you’re asking, but can you not p-lock the Program Chg # on the MIDI track per step?

I thought I saw Dataline doing this from the Monomachine sequencer in his Bass Station II video.[/quote]
I believe that the Program Change on the MIDI tracks only has effect when you change to a different Part, but someone please tell me if that is not correct.


#14

That is all I want to do, but I am still a bit baffeld by NRain’s suggestion.
Anyone care to give a short step by step on how to set that up?
I was certain I had set it up properly, but I am not getting any results.
The only results I get is using the per part program change.
As far as I can tell you cannot p-lock pgm changes.
Thanks!


#15

peter hanes told you correctly

go into:

1 midi config
2 midi sync
3 down to prog ch receive and check the box

should work if you also have prog ch send checked on OT


#16

JuanSOLOI set everything up like this.

AR/GLOBAL/MIDI PORT CONFIG/INPUT FROM MIDI
AR/GLOBAL/MIDI CHANNELS/PROG CH IN CH 11

OT/PROJECT/SYNC/PROG CH Send checked, Channel 11
OT/PROJECT/MIDI/CHANNELS Auto Off

No results.

When I posted this earlier Peter replied he didn’t think AR would work like this.

What am I missing?


#17

Holy oversight batman.
When setting the ProgChg channel on the OT I kept setting the Receive channel, NOT the send channel.

Working beautifully!

Thanks you guys.


#21

Im glad this topic was discussed. I was not changing [auto] -> desired channel. So anyone else landing on this thread, never count on the midi [auto] setting.

Currently when I change patterns on the OT, the pattern doesn’t actually change until the pattern runs to completion. Is there a setting for it to switch patterns instantly?


#22

OT master? You can use Pattern Change Behavior (min 2 steps).

PATTERN SETTINGS MENU This menu is opened by pressing [FUNCTION] + [BANK] when GRID RECORDING mode is not active > PATTERN CHAIN BEHAVIOR.


#23

Perfect! Many Thanks sezare56!!