How do I record AR sequencer MIDI data into Logic?

Hi All,

After updating the Rytm to v1.50 and discovering the hidden “Track sends MIDI” setting in the QUANTIZE menu(?!) and enabling it for all tracks in my pattern, I then duly went about trying to record said pattern as MIDI in Logic.

Well, no matter what I do, no matter what MIDI port, track, channel or assignment I try both on the Rytm or Logic, the Rytm ALWAYS outputs all tracks to C3 in the DAW. So, all 12 tracks end up being on C3.

Worse… the Rytm only seems to want to RECEIVE notes on C1(?!) and there doesn’t seem to be any way to configure this assignment.

Suffice to say, it doesn’t seem possible to record the Rytm’s sequencer MIDI data in Logic at time of writing, unless someone has some magical piece of information that I’m missing. :slight_smile:

Am I missing something?

BTW, this is via USB or conventional MIDI.

Hey Mark. We talked about this on GS yesterday.

Let me rephrase this question / request a bit (as far as I understood):

The issue here is that the AR outputs multi-channel MIDI notes which means that you have to create multiple tracks in many popular DAWs like Logic in order to record them.

What you want is some kind of simplified MIDI output mode where the AR outputs trig-notes (C0…B0) on a single MIDI channel instead, i.e. similar to how other drum machines like the Roland TR8S operate.

As far as I know, there is no such mode at the moment but I believe it would be very easy to implement this (@Elektron: please do !).
There should also be a (global) configuration option for this.

While I for one prefer the multi-channel mode, I can see how such a single-channel mode can be useful if you are not interested in recording chromatic notes and prefer to record all drum pattern notes to a single DAW clip (in DAWs that otherwise require separate tracks for multichannel MIDI).


This is discussed in another recent thread fwiw - but the Track MIDI channels can be set to be the same - then if you offset the Note param for each track the default (non-chromaticized) patterns will come through on a given range of notes, offset in semitones or whatever, but within the range that the AR can transmit chromatically

Right now there is a documented bug whereby the sequencer plays back two octaves higher than the tapping of the pads which can mean that auditioning what you are playing and getting the same back is subject to a bug fix, hopefully asap

Thirdly, the AR will respond to the lowest 12 midi notes (0-11) and can be played from afar that way, but it won’t output those low notes, it only transmits on the Track Channels over the viable range (currently borked upwards by 2 octaves)

It outputs MIDI in a number of ways, multi/single channel, it’s up to you to master how to catch that particular data in Logic - if you want to use chromatic mode on a track then you simply have to use separate channels

The 2-oct offset bug affects external MIDI playback, not the internal voices, but the sequences you send today may be different to those sent after the bug is fixed (but transposing in a DAW is easy)

1 Like

Thanks for your reply! Yes, we got to the bottom of it on GS after I posted this so the question is a bit redundant. I apologise. :slight_smile:

Returning my (second) ARII and repurchasing the TR-8S (again) though as, for all its shortcomings, it just works in my DAW workflow. Today. I appreciate that the global setting is something that Elektron could implement “quickly”, but I’ve lost all patience in them as a company, if I’m honest, after first buying the ARII from new when it was released with the promise of Overbridge and then finding it didn’t spit out MIDI pattern data, selling the ARII at a loss because it didn’t and then buying a TR-8S to replace it (which worked right away).

Now, a year and a half on there’s promise of sequencer MIDI output so I re-buy the ARII (again, at a loss) and Overbridge is now getting there (great!) but I still can’t record MIDI pattern data into Logic! So I’ve had enough. Back it goes.

Not going to hold on to some gear (no matter how good it sounds) with the promise that it may work in my workflow in future. Ya know?

I mean no offence to anyone in what I write, I just don’t have the patience anymore. It needs to work for me today.



Thanks for your reply!

Multiple MIDI tracks in Logic is not how I like to work. In 2019. :wink:

I’ll revisit the ARII again in a year or so, or when the ARIII is released. If everything works as it should then - Overbridge (released, not beta), MIDI pattern data works as it should in a DAW, pad sensitivity is fixed so that I don’t have to break my fingers to make them sound, then I’ll consider it then. For now though, it’s too little too late for me.


I didn’t even advocate that.

If you don’t want to understand the architecture of the device and appreciate that it has to operate on multiple channels if you exploit the chromatic modes fully then that’s your choice, whether it’s 2019 or not. I took time to explain the way to output the MIDI sequence on a single MIDI channel, as I had done before, it’s basic (having also rectified the original misleading topic title which suggested it couldn’t be done).

If you don’t want or look for solutions or understand the basis for the MIDI design or even like it that’s your call, but don’t be confused that the AR Mk3 (which will have the same MIDI constraints if it operated chromatically) would be any different. You don’t need to like it, but it’s not helping the bigger debate by misrepresenting the issue.

I don’t understand the need to create a topic on this if you already didn’t want the answer you sought (30 minutes later) , and especially if you already had resolved this dilemma the day before and don’t like the pads etc etc

So for the benefit of anyone interested in sequencing on a single MIDI channel (assuming you don’t also need to exploit e.g. DVCO chromatically, in which case it unavoidably has to be on more than one channel), do so as explained above, it’s trivial, just disable the chromatic mode in the Sound Menu (Fn+FLTR) and set the transmitted MIDI track notes to be sequentially chromatic by offsetting the TRIG/NOTe parameter for the respective tracks.

Before you send the AR back:

It looks to me as if Logic actually can record multiple channels to a single track (which would solve your problem).

Check out this video. It describes how to setup a Roli Seaboard (MPE) in Logic (MPE = basically one MIDI channel per voice).

Seems like you simply have to set “MIDI Channel” to “All” (in Logic) and the DAW will then record all channels to a single track.
Can you give this a try ?

That’s not the problem. The problem is that regardless of what channel I set the tracks in the ARII (let’s for the sake of argument say that they increment sequentially, so track 1 is set to MIDI channel 1, track 2 to MIDI channel 2 and so forth…) ALL the tracks come through to Logic REGARDLESS of what MIDI channel is selected.

If I set Logic to MIDI channel 1, ALL the Rytm’s tracks come through. All on C3. If I set Logic to MIDI channel 2, ALL the Rytm’s tracks come through. All on C3. If I set Logic to MIDI channel 14, 15, 16 or whatever… ALL the Rytm’s tracks come through. All on C3.

Because of this it is not possible to set up individual tracks in Logic as all tracks would contain all notes from all tracks in the Rytm.

Is this something you have done and have got working in Logic, or is this theory?

Here’s my setup:

  • Brand new ARII with latest OS
  • Latest Overbridge installed on the Mac
  • Logic Pro X (latest)
  • ARII USB set to Overbridge
  • ARII Tracks set to “transmit MIDI” in the Quantize menu
  • ARII MIDI Routing set so that each track has its own MIDI channel

Now, create a new blank project in Logic Pro X. Now create an External MIDI track. Set the MIDI channel to 1. Press Record and record the pattern from the ARII.

At this point I would expect to ONLY be able to receive Track 1 from the ARII as that’s the only one routed to MIDI channel 1. Would you concur?

Well, I don’t. I receive ALL tracks. ALL on C3.

1 Like

Okay but why is that a problem ? When you set the input channel to “All”, the notes might be all on C-3 (or whatever note is selected on the AR via p-locks or the default note transpose that is set on the “trig” page), but they will all be on different MIDI channels so there are no collisions.

That being said, there currently is a firmware bug that causes the transmitted notes to be off by 2 octaves, i.e. you need to select all clip notes and transpose them down by 2 octaves before you play the clip.

Because it doesn’t work as it should. I may very well be able to find a “workaround” for recording the pattern into one track using this bug - and it is a bug, as all tracks shouldn’t be coming through to one MIDI channel. But, as soon as that bug is fixed… poof. That no longer works.

2 octaves? They’re being recorded at C3 yet on my ARII I can trigger sounds from C-2. I make that 4 octaves off. :thinking:

I appreciate both of your help here but having spent close to 8 hours on this, I’m done now. It’s going back. Too many “workarounds” needed, I fear.

One day, perhaps. But not today.

Please feel free to close this thread.

1 Like

I understand that you’re frustrated but I think you can still make it work.

The AR definitely does not send everything on the same channel.
You can verify this with a MIDI Monitor.

Like I told you on GS, the AR has two keyboard zones:
The first one, in the bottom octave, is for triggering any sound from any channel (i.e. C=BD, C#=SD).

The notes sent by the AR are always in the second zone which starts one octave higher.
A note’s MIDI channel corresponds to the track it belongs to, i.e. ch#1=bd, ch#2=sd, and so on.

You should be able to record that into Logic and play it back, after transposing the notes two octaves down (due to that silly firmware bug which I’m sure will be fixed ASAP).

1 Like

Lol, i wish that somebody learn the midi protocol…And the logical midi transform…:innocent:

1 Like

nope - this is essentially user error coupled with a lack of appreciating/acknowledging what was actually written above

If you get pads all transmitting on the same channel then you have PADS (not the seq) set to output on Auto Channel, this should be set to Track Channel when MIDI sequencing, again discussed elsewhere

If you took the time to read you’d see that the issues you present are all explained - they’re not “workarounds” - the workflow scenario you’ve imagined is in fact a fiction, this takes a bit of effort, you can’t transpose the solution from a fundamentally different machine just because it makes drum sounds too

This was explained, use NOTe offset, the Rytm tracks are chromatic, they necessarily default to the middle note of the 49 note range (-24 > +24)

Did you read/understand the reply and try (rhetorical)? we are discussing the AR here, your challenges in Logic are another matter, the AR works exactly as I described in terms of MIDI output and it is that way for the reasons I described - notes come through wherever you want, within a 49 note range

It’s easy to get a range of Notes from the sequencer on one MIDI channel, you don’t need Logic to see that

again, this was explained above by numerous people and is in the manual, the AR receives any MIDI note across the lowest 12 midi notes on ANY channel as inputs to the respective 12 tracks, this is a separate zone for triggering from machines which are limited to one MIDI channel


This could very well be the case, but it’s not straight forward at all and it fried my little brain. I’m sorry for not being as knowledgeable as yourself and I apologise for making you seemingly irate and frustrated at me. That was not my intention.

What you don’t seem to grasp is that I am not you and, fundamentally the ARII doesn’t function how I would like it to function “out of the box” without having to transpose this, midi merge that, set this thing over here etc.

…and this is the real problem. The ARII doesn’t work how I want it to work so there’s no point either of us getting frustrated about it. The ARII sounds great and has a feature set aimed at many people, it’s just not aimed at me. Nothing wrong with that.

As mentioned earlier, thank you for your replies but this thread is closed as far as concerned as the ARII went back today. I’ll re-purchase a TR-8S as that better suits my workflow.

Thanks again,


1 Like

By default Logic routes all incoming midi on all channels to all record enabled midi tracks and records the midi to the selected track. To split channels on tracks you need to enable the “auto demix by channel” in the project settings midi section…



1 Like

What do you want to do? Get Midi data out of the Rytm into Logic?

Im having the same issue where I set up 8 different external midi instrument tracks all using midi channels 1-8 hoping the tracks will only have those pads on them. I end up getting all the sounds on all the tracks. How do you access the second zone?