Frustrating glitches when recording to ableton via overbridge


So I recently bought a digitakt, love the machine and work flow but found it difficult to record uninterrupted audio jams without experiencing glitches.

I have been trying to record into ableton with each drum on a separate audio track via overbridge. For the most part this works ok in terms of the audio being allocated to each channel, sometimes overbridge can’t seem to find the device but closing and re setting up the session usually fixes this. The real problems occur once I actually start to record.

At first the recording sounds great, but at some point the recording and digitakt will start to glitch/ dropout/distort, this usually lasts around 2-3seconds and sometimes sounds as though the digitakt is speeding or pitching up, then it will continue as normal. It can happen at any point but seems particularly prone to happening when I use either the Fill button or use the mute mode to bring drum channels in and out of the mix. I have tried various changes to the settings to get round this but with little success.

My specifications are as follows:

Digitakt: - latest firmware

            - overbridge selected  

            - clock receive 

             -audio routing is standard 

Overbridge: - beta 2.0

                  - coreaudio

                  - buffet size 512, I have tried lower as recommended but did not fix.

                  - output was none but just switched to core audio but same results 

Mac desktop: macOS Mojave 10.14.6

                     2Ghz intel core i5 

                      8GB 2133 MHz ddra 

                      811.43 GB of 1TB available 

Ableton: - Trial version, I found overbridge integration with logic poor so I downloaded ableton trial. I had wondered I this could have been part of the issue but having read about various problems with over bridge and not being a computer genius thought it might be something else. I also tried recording just via overbridge without ableton and encountered the same problems.

           - audio input: digitakt core audio, or bit accurate have tried both 

           - in/out sample rate: 48000, ableton won’t allow to go lower with digitakt selected 

           - buffersize: I have read both that matching the buffer to overbridge’s and using a higher number such as 1024 should improve things but neither has fixed the problem.

            CPU: 3%

Sorry for the long post just thought i would be thorough,

1 Like

did you try with wifi deactivated and other applications closed? I had similar problems and going offline fixed some trouble on my side. hope this helps


i have been so far running with minimal other applications open but ill have ago with wifi removed and see the results, thanks

Yeah that didn’t work unfortunately

New overbridge was just released. 2.0.19
Release notes say the previous driver was problematic. Maybe related?

1 Like

I have experienced the same thing. It runs fine for a little bit, and then starts to glitch out. And then, abruptly, the problem will go away. It sounds as if something is filling up, like there was a buffer getting full or something, and then when it empties everything is fine again. Not only would I like a solution, but I’d like a definition of the problem.

What other USB devices are connected to your computer?

1 Like

Also check the loop settings on samples

Some one shot samples if with loop on will sound like their “building up”

1 Like

In response to those last few comments, Yeah unfortunatley i actually have so i dont think it can be that.

A buffer filling up and emptying is exactly how i would describe how it feels yeah.

And my Loop settings are (apologies if this isn’t what you meant new to ableton):
File type: aiff
bit depth: 24
count in : none
exclusive : arm solo
clip update rate: 1/16
record session automation in: armed
start play back with record: on

Loop/ warp short samples- auto
Auto warp long samples- on
default warp mode- beats
create faded clip edges- on

oh and i only have my focusrite which links to my speakers on the other usbs

i mean on the Digitakt check each sample to see if you have loop on ay one shot samples…

ah right no not as far as i can see

also when i play direct into my speakers with no mac involved it never seems to happen

hello Jrea,
have you found a solution to this yet? i have the exact same problems with the analog rytm 1.
and yes mostly in mute mode too where i start muting and unmuting stuff.
and also only when recording the session. when just playing around everything runs mostly smooth, but as soon as i hit record in live it starts getting these glitches and tempo changes.
cpu is around 15-20%.
my buffer size 128

i have an imac (late 2015) with mojave 10.14.6
2,8 GHz Intel Core i5
Live 10
overbridge beta
analog rytm os 1.46 beta

would appreciate any help, thx!

I’ve changed the buffer sample and no more glitches !

Did you change the buffer sample in Ableton or in Over bridge?

Yeah, super annoying. Although I don’t remember this with the Digitakt, I have the same problem with A4 mk1. I can only hope that the next Overbridge version (the one with Catalina support) will fix this.

I even thought about upgrading to mk2 just because this but I probably can’t afford.

I’ve changed ths buffer in ableton settings

People that are experiencing this problem: have you made sure the buffer range in your DAW is the same as the buffer range of the overbridge plugin in the overbridge control panel?

1 Like

Yeah sadly iv played around with the buffer in both the daw and overbridge on various settings and also matching the two but without having much impact thus far