DIY repair?

Has anyone here had success repairing the MD themselves when the display shows weird alien characters on startup? Reseating the user interface (UI) connection cable used to work temporarily, but not anymore. I can confirm that the problem isn’t the battery or the external PSU.

If it comes down to replacing a failed component (IC, resistor, capacitor, whatever) I’d like to try doing it myself before ordering a new UI and internal power supply for US$112 as recommended by Electron tech support. The thing is I don’t really know where to start. If it proves too difficult, I’ll just bite the bullet and order the entire replacement UI. Any thoughts?

Try to detach all the different pcb connectors, not only the UI one.
Detach the UI one, remove the pcb, then detach the connection ribbon cables from the cpu board, from power board and I/O board.
Eventually clean the connectors with IPA (not the beer of course :smile: ) ant then reconnect all.
On my side it worked.

Otherwise search in the forum, there are several threads about this problem.

1 Like

Thanks for the advice @Rics :+1:. I should have mentioned that I’ve read the related threads, and that I’ve cleaned and tested each connection in turn, even going as far as re-soldering the UI cable. I’ll give it one more go of testing before I order the replacement parts.

Not a pro but have some tinkering experience. It’s the connectors or otherwise the main board or the LCD is going bad. It’s all digital, there are no capacitors usually. Resistors maybe but they rarely go bad. If you have ruled out connectors, then it is possibly a bigger problem. Sorry can’t be of more help. Good luck.

2 Likes

Mine too, crashed yesterday…

Got this after intensive firmware development – lots of flashing and SDS transmission.

  • Boots into bootloader most of the time
  • Test mode show ram OK dsp OK
  • Go into function test, keys are working, except for trig 4, the the sound selection LED 4 (MT) blinks shortly and then go off, instead of keep on until release trig
  • Crash if it stays longer in the functional test

Ordered a few CPU and flash chips. Will arrive in a few days.

2 Likes

UI board connects to the CPU board with a serial port.
When the firmware finishes booting, there’s no close-loop checking whether the UI works or not.
Given that the UI works in Test Mode, IF the firmware actually boots, you’ll at least get the audio subsystem working.
If that’s not the case, it’s more likely it’s not the UI but a bad CPU board.

It’s hard to say without ever looking at one but I’d say it’s possible you have a bad solder joint somewhere from what you say and how it looks.
Is there a pot on the PCB that controls the contrast? I’d start there and see if you could touch up the solder joints with fresh solder.

I’ve repaired hundreds of pieces of music equipment and the majority of issues (if it powers on) are bad solder joints.

1 Like

Reinstall the firmware , worth a try

Elektron support has a very good point about the power supply. Not enough power -> weird behavior. I would add that to the list although it is going to be hard to check since there is no official repair manual with official voltages.

1 Like

A reply from Elektron support last night:

Normally it is the connection between the PCBs that are causing this kind of fault. PSU to CPU. Or the UI to CPU. Often the connection between internal PSU and CPU. Usually fixed by re-soldering. If you or if you know someone that could try that. Otherwise it is caused by bad UI PCB, very rare by faulty CPU.

I guess I’ll check all the connections between the PCBs more thoroughly tonight and re-solder any if necessary.
I don’t think the firmware is the problem, but it couldn’t hurt reinstalling it just in case.
I did think a faulty AC adapter might be the cause, but I’ve tried using my OT and MNM adapters instead with the same results, so I don’t think the problem lies there.

3 Likes

@ Airyck’s advice is priceless.
I remove this ribbon cable (UI <-> audio board):


It boots successfully.
I then power down, reinstall it, and audio is back.

Lesson learned: never assert the chips in the presence of wires (x

4 Likes

Last night I completely replaced two of the connections (PSU <-> UI and CPU <-> UI), which didn’t help. I then tried resoldering the PSU <-> CPU) connection and so far I haven’t had any more problems with it. :crossed_fingers:
Let’s see how that goes.

5 Likes

just finished my first MD DIY repair with a rocker switch replacement on my mk 1 and everythings working.

however my knobs are well wonky now. well, abit wonkier than before. they all work well (gave a clean up) but definitely aren’t seated as tightly as before.

was this me being wayward when i removed them? or is this always a product of opening her up and putting her back together?

Just to be clear, do you mean that the knobs themselves look/feel wonky? Or is it that the stems of the encoders feel wobbly?

If it’s the knobs:
At the risk of stating the obvious, have you checked that the D-shaped slots on the knobs are aligned with the stems? It’s possible to put them on the wrong way. Even after removing and replacing the knobs countless times, they should still feel snug on the stem.

If it’s the encoders themselves:
Simply taking off the front panel and moving the UI board out of the way shouldn’t have affected them unless they really got knocked about during the repair.
Having said that, I do find the MD, MNM, and OT mk1 encoders noticeably looser than the later Elektrons. It’s annoying enough on my OT that I’ve even thought about de-soldering all them all and putting in nicer ones.

everything’s aligned ok and seems snug. just rotation is a bit off.