Digitone midi cc sends


#1

I’m trying to get my digitone to control the filter on my bass station. The BS2 uses cc 16:48 for the filter. It’s a double range filter, So i guess either 16 or 48 will work. But neither seems to be an option when setting cc’s on digitone’s midi channels. The digitone offers a bunch of stuff that didn’t do what i want, but not the filter cc. Do i need a workaround or am i missing something?


#2

There should be no problem.

Connect the MIDI Out port of the Digitone to the MIDI In port of the BS2 with a working MIDI cable.

In the DN’s Global Settings > MIDI CONFIG > PORT CONFIG menu:

  • Set OUT PORT FUNC to “MIDI”;
  • Set OUTPUT TO to “MIDI”.

In one of the DN’s MIDI sequencer tracks:

  • In the MIDI Source (SYN1) page, set the MIDI channel number to match that of the BS2;
  • In the CC Select (AMP) page, set one of the eight CC command knobs to be CC #16;
  • In the CC Value (FLTR) page, set the corresponding value knob to the filter cutoff value you want.

I don’t know how the BS2 responds to MIDI messages, so you may need to use CC#48 instead (or both #16 and #48 on separate knobs) to get the effect you want.

Try this and report back.


#3

Right, i already have all that set up. The problem is that the digitone does not offer midi cc 16 OR 48. It stops at cc 15, then there’s a bunch of other stuff in non-numeric format, none of which appears to be the filter, then it picks up again at midi cc 20 or so. Selecting cc 16 is not an option. Similar for cc 48- it gets skipped.


#4

For CC #16, use the one after CC #15. The “non-numeric” labels are just generic labels for typical assignments.


#5

Really? That’s great news. Thank you. I’ll try that. The manual was not clear on that detail at all.


#6

I would try CC#48 first. The filter knob on BSII is 8 bit hence the double
CC numbers. (0 - 255 instead of 0 - 127 for a 7 bit message)