Digitone / Digitone Keys 1.21 : bug reports

hi,

i tried to record notes from ableton to the digitone sequnecer. Overbridge is enabled. I used an external instrument to send notes to my digitone. The notes are recorded via rec+play. its all good. the trigs are set and recorded correctly. Than i disable the external instrument to use the internal sequenzer of the Digitone.

But after that, every time i use live recording on exactly that track on the DN (rec+play again) (and only this without doing anything else) some of the trigs are like overwritten to yellow trigless trigs. after restarting the digitone its not happening again until i record notes from ableton again.

is this a bug? anyone who can try to reproduce this?

after restarting the digitone its not happening again until i record notes from ableton again.

Most probably your external gear and/or ableton are sending midi information on this channel of this track to the DN. Might be some strange CC value (some modulations/automations/OSC’s…), not necessarily notes - which is why the trigs are yellow.

Yes thats what i thought first too. but i deleted / turned off all sending devices in ableton. i also disabled midi for digitone in ableton and receive midi in the digitone settings. but no solution, still this strange effect.

Others seem to have similar Ableton related issues: Hanging notes?

1 Like

Since updating the firmware. program changes don’t seem to work when sending from the DN to external gear via MIDI.

I have the DN sequencing an arp on my Bass Station 2 and I have the trigs parameter locked to a particular patch on the BS2. It does the program change when I first swittch the DN on, but doesn’t do it again until I power the DN down and and switch it on again.

This worked fine prior to the firmware update.

I was experiencing this too. But I haven’t seen it since updating to 1.21

totally crap, reporting in december already hanging notes, just simply using the machine alone, not even using lfo’s, or the sequencer, just playing notes without anything midi attached!
In my opinion Elektron has never heard of note priority when it rans out of polyphony! It clicks or hangs notes!

Ok maybe i found a workaround. i copied the recorded trigs on the track to another track and back. after that it seems to work.

Overbridge 2.0.17.13:
Notes getting stuck with more than one sound/track being used.

Does not seem to happen if i only play on T1 (channel 1), but as soon as i try to play T2 the notes for T2 can become stuck, playing endlessly, depending on rhythm or where i happen to press pause.

Seems like it doesn’t recognize Note-Off sometimes. I have had enough space between the single notes. Nothing extravagant. No chords or anything.

I can then only recover by turning off the device. Loading another sound on the stuck track doesn’t help. T2 keeps droning.

For the first time my DN suddenly get off/on 2 times while jamming around with it. I was only playing around with one preset on one track and fx-use. This was the first time happening. Os-updates have been without any problems.

DT was the master clock and was running smothly.

I will be watching at.

Let’s say I want to live record a chord using the keyboard on the digitone keys.
If i strum my chord a little bit while recording, notes are recorded and spread on multiple trigs but velocity is not recorded on the sequencer for trigs that are off…

DN sound data is lost after sending a program change message to the DN. The sounds for all 4 tracks are reverted to the default DN patch. The program change message is sent from a Cirklon.

This is the first time I’ve tried sending program changes to the DN so I’m not sure if I’m doing something wrong, but it doesn’t seem right.

I can shoot a video if my explanation isn’t clear if that helps.

Can anyone reproduce this?

[edit] It looks like the issue only occurs on an existing project created with an older version of the Digitone OS. New projects do not exhibit the same issue. (I can reproduce the issue 100% of the time with the older project.)

Have you saved the Pattern (Fn+Yes) before you send the PRG CHG ?
Could be some kind of reload…

Same for me!!digitone can’t program change my op z…before that new firmware no problem

Can someone else confirm that bug?:thinking:

@moshforjesus @Davequartz please contact support on this problem, if you haven’t done already. It seems important enough to get addressed in the next patch.

i find the same problem on the digitakt new os

I’ve had a strange issue on recent firmware. I wrote a pattern to play along with my dark trinity on an earlier firmware (pre “scale per track”). On new firmware I engaged scale per track and now, after the pattern plays one time through, it glitches and hits the first trig twice, causing the DN to be one step behind the rest of my gear.
I’ve tested new patterns and they seem fine but it does seem patterns from a previous firmware, when altered, do this.

really disappointed why they bother to sale gears if they are buggy? it’s like they are outsourcing QC to the consumer.

I am afraid to upgrade a buggy 1.02 with a useless MUTe function to 1.21

@ammanuel Software is complicated. Any change, fixing bugs, adding features etc, has the potential to introduce bugs. I’m sure they do some testing in house but it’s no surprise some bugs get through.

2 Likes

Have you saved the Pattern (Fn+Yes) before you send the PRG CHG ?
Could be some kind of reload…

I did try saving both the pattern and project. It’s no better. Will investigate more today.