Digitone / Digitone Keys 1.21 : bug reports

Firmware 1.21 is now released.
Discuss here

Remember to back up before upgrading and even load a new empty project to avoid any damage to your current project.
And avoid upgrading before a gig. :tongue:

You encountered something wrong in OS 1.21 and want to check if others can replicate it ?
Here is the place.

Doesn’t replace a support ticket, of course, but you might want to check if it’s not a feature before declaring a bug :wink:

Please report all bugs via the Support Tickets section on elektron.se if they have not already been confirmed below.


polyrythm is bugged. The first trig of the second (same) sequence / loop is played twice after m.len has played. That’s really bad.

try trk.1 - 4 64/64 1/4x ch.length 256, m.length 64 (or 256 doesn’t matter ). Now my digitone got obsolete . :confused:

Also tried to do other lengths or m.lengths, but same issue… also tried to stich ch.lenght to 257 or m.length to 255 . same issue

See it happening at 0.31 sec

It only happens when the sequence is looped twice, after that (third fourth loop and so one), no error occur, but then you are already fubar.

*just reported a ticket


Have you written a ticket ?
A patch might arrive in the next weeks, best to describe this as good as possible so that it gets corrected in next OS :slight_smile:


Digitone 1.21: trying to back up my project via sysex dump (Project > Active Project). It claims to be sending, but only one packet ever arrives and then I need to restart the unit in order to ever transmit sysex again. Otherwise, it claims to be sending, but it doesn’t. I can send patterns one at a time (after a restart), but it eventually stops transmitting, as well (after 2 when I just tried it). USB MIDI.

EDIT: looks like I need to kill overbridge on my host machine, disable OB mode on the DT and try again with the “normal” USB MIDI mode. Now I’m receiving (slowly) a syx dump. Would be nice if OB didn’t kill sysex, though.

I cannot reproduce this.
I tried something similar but with 16 steps for the main, and different multipliers on each track, I can’t seem to get weird results.

Can you make a 16 steps track and reproduce this ?

It’s possible if it appears slow that you have USB+DIN MIDI enabled (the DIN midi rate becomes the determining speed in that case) - OB certainly needs to be off (set it to USB only (for MIDI) for larger data transfers) - but I think sysex will work fine via DIN - it’s not that it kills sysex - it’s just that it’s no longer visible as it’s sent along with the other OB stuff via the USB connection

I doubt killing the host OB engine is necessary, but I don’t own that device - if you use C6 it shouldn’t be a factor

1 Like

Overbridge eats up usb bandwidth. Best practices for backups are as follows:

Switch to usb midi only mode

Set midi in/out to USB in midi config menus. This allows turbo protocol to work.

Use c6. When entering midi config on c6 make sure your in and out ports are both pointed to the digitone/takt etc as the case may be.

After closing config verify the radio button for “Turbo” is enabled and speed multipler is at 10.

You should be able to send and receive sysex much more reliably after that.

1 Like

I already got response from the support. They suggest me to start a new project to reproduce.

A new project works as it should work. I tried to copy the whole pattern from the bugged project to this new project, but that doesn’t work, same bug occurs. What does work is copying the tracks & arps separately and copy the sounds and load them in a the new project. It’s not ideal, but it works. Now I have to copy all my projects to a new project? Or should I wait on a patch update?

Ps, an example of a song :

Trk 1. Length : 64/64 scale 1/4 (16 step arp speed : 1/8 mode : up range 1 )

Trk 2. Length : 64/64 scale 1/4

Trk 3. Length : 14/16 scale 1/4 (10 step arp speed : 1/6 mode : true range 1 )

Trk 4. Length : 64/64 scale 1/4


ch.len : 256

m.len : 256

ps, ratio offset is f**** AWESOME!! omgzwtf

1 Like

Thanks for the update but now the Digitone always lost the the sync for me even from the Otatrack

OK, well pretty good that it’s not a bug per se, but more a backward compatibility problem (even if it’s still annoying).
Have you sent them your sysex project ? Maybe a good thing for them to investigate this…

And yeah, ratio offset is the bomb ! I had really been waiting for this, I’m psyched :slight_smile:

I upgraded the Digitone and then got this message from Overbridge (2.0):


What should I do now?

(Sorry, just realized this might not be the appropriate place for this. Could this be a bug?)

Tell us exactly which version of Overbridge you are using; you may need to update to the very latest beta version.

1 Like

Yep! I just downloaded overbridge 2 days ago so I didn’t realize there was a new one. Thanks!

Hi, thanks. I’ve disabled USB+MIDI on the ports (now just USB), and have disabled OB on the device. Turbo Speed won’t enable, though, whether I connect the DT to my laptop directly (via USB-C adapter), or via a Thunderbolt hub. I can confirm that it’s a lot faster (even without Turbo, although I’d like to understand what’s up there). And the resulting sysex file is 3MB instead of 291.6KB which I got with the ports set to USB+MIDI.

I’d suggest that sysex transmit be disabled in OB mode, though, with a note on the display to that effect. As for these other oddities re Turbo Mode, I’m curious about other users’ experiences. Thanks!

Turbo mode is primarily a way to get 10x MIDI baud rate between DIN connected Turbo devices - they need to be bi-directionally connected Out to In and In to Out - it’s an Elektron protocol but a couple of other manufacturers have adopted it in some devices
It would appear to be present in C6 for the purpose of using their own TM-1 USB midi interface which was developed to speed up SDSdumps wrt the Machinedrum.

Now wrt USB midi connections, I am less clear on the applicability of the Turbo setting and whether the rate is either slow 31250 bit/s , turbo 300k bit/s or faster

However, due to the funkiness of the program and wrt the my experience part of your question- my C6 workflow is as follows

If the device attached is the last one connected to C6 you should see that the Turbo indicator is on when you start C6 up - if you toggle it it will go off and stay off (but may still be a speedy transfer?!) … so I have got into the habit of checking that the device I want to Tx/Rx from is selected in the menu and then close/re-open C6 and stay away from that menu&toggle - it’s always been fine for me - it’s clear that Transfer is the future MIDI program for Elektron, but I read too many anecdotal reports of hanging uploads on that and I tend to view it as safer for sample transfer only and recommend C6 (or even trusty Sysex Librarian by snoize)

Wrt the dumps captured, this is where C6 is handy, it will show you the contents summary in terms of sounds/kits/patterns/etc


The Control All Revert feature still only reverts the current page and not every control-all tweaks done on several pages. If you keep holding the MIDI button and go back to the different pages you were tweaking and press NO they will revert to their default state.

This is a bug since it doesn’t work as described.


@eangman do you confirm ?

Yes it is a bug. It has been reported to the firmware team and they will have a look at it.


I am also experiencing issues like @erikie with ARPs drifting slightly after changing to scale per track. Also after the first loop.

In the first half you can hear the ARP being tightly synced to the metronom of the DN but after changing to scale per track, the ARP gets out of sync in the second round… Am I missing something?

Update: I can confirm that after increasing M.LEN the drift appears later - right after hitting M.LEN…

Update: Feedback from Support:

We have confirmed this as a bug. The issue is due to scale per pattern not being defaulted to 1x when changing to scale per track. Setting per pattern scale to 1x manually is a workaround until we have a fix out. Thanks for reporting!


Encountered some weird shit I never had before but with this new update:

-I was in function mute mode, when quickly track muting and selecting a non muted track volume control affects all the tracks! (bug or function I don’t know of?)
-when jamming with MD midi out to DN midi in, DN with long reverb I pressed double stop to cut the verb and lost midisync, DN refused to start on MD’s midiclock, had to powercycle!