Digitakt + TB3


#1

Hey Everyone.
I’m trying to use the Digitakt as an replacement of the Roland TR8. However with the current connection it does not work properly with the DT as master clock.
I’m having the L/R Out from TB to DT’s Input. Next I have the Midi Out from the TB to the Midi In of the DT.
Using two separate Midi channels, on DT: Midi A, Channel 1. On TB: Channel 2.

The TB won’t start when I press play on the DT. However when in recording mode and switched to internal there is a signal coming in, but the TB’s sequencer keeps quiet. And so is the sound of the “midi channel” of the DT.

One last thing. When I change the Midi cable on the TB from in to Out and on the DT I switch it to In, then when pressing the play button on the TB the DT starts playing. However this is not my intent as the TB should be the follower.

Thank you in advance for everyone thinking with me!!


#2

Your post doesn’t make sense…

First paragraph; With DT as Master, surely it MUST SEND midi therefore it WILL use midi OUT to TB midi IN.

You want the DT as master, to send clock and note info to the TB

Maybe its a language/translation thing, dunno, maybe someone else could be more instructive.

Str.


#3

@Conjecture, @stretchyman is right. If you want Digitakt as Master, it has to send MIDI data to the TB, so Digitakt MIDI out to TB MIDI in…and you have to use the same MIDI channel!


#4

Yes. I’d like to have the DT as master, however in doing so I’ll indeed have the DT on Midi Out and the TB Midi In, but then pressing play on the DT it won’t start the TB.

Could have been my explanation which made in unclear. But I’m having the as said DT Out, Tb In.

Cj.


#5

I’m using the DT Out and Tb In, and on both devices I have switched them to channel 2.
However still no sign of a working TB on the clock of the DT.

Any other suggestions? Or is there something else that I am missing here?


#6

Check MIDI settings, is digitakt sending transport and clock data. And is Tb3 set to react tot clock and transport?


#7

Now those terms sound about right for what I am trying to achieve here. However I do not know of any other settings within the DT as the ‘chan’, ‘bank’ and ‘prog’, on the TB there is to my best knowledge only the possibility to change the midi channel itself and not what it is receiving/how it should behave.

Would you be able to enlighten this for me?


#8

Hmm…the TB “manual” only talks about MIDI channel setting and clock, there is nothing described about transport messages, maybe it doesn’t support them?

I don’t own a TB, so i can’t test it myself.

EDIT: The MIDI implementation chart shows that the TB-03 can receive and send start/stop messages, so it should work.


#9

Mhm. It indeed can send. If TB = Out and DT = In, play/pause of the TB controls the DT.
However receiving seems to be the issue here although it ought to be no issue when on the same midi channel. Unless of course there is more to it…? But I haven’t found it. May also be the case that it indeed does not support it.

EDIT: The sending part is a bit off too since the TB is controlling ‘track 1’ and it’s parameters instead of playing it’s own sound…


#10

@Conjecture Wait…after reading your first post a second time…it looks like everything was working from the beginning, but you missed to raise the level for the inputs of the Digitakt. Maybe this is the problem?


#11

To synchronise the two devices, you need to do the following:

Physical connections:
Ensure you have a functional MIDI cable connected from the DT’s MIDI Out port to the TB-3’s MIDI In port.

In the DT’s SETTINGS > MIDI CONFIG menu:

  • In the SYNC sub-menu, activate CLOCK SEND;
  • In the PORT CONFIG sub-menu, set OUT PORT FUNC to “MIDI” and set OUTPUT TO to “MIDI”.

On the TB-3:
Turn on the power while holding down the [SCATTER] button, then press pad [C] until it is lit, then press the [PLAY/STOP] button.

There is no need to set any MIDI channel numbers in order to get synchronisation working.

If this works then let us know and then we can help you with the audio signals, if necessary.


#12

make sure to turn on monitoring “yes” in DT’s sampling menu!


#13

My man! Haha awesome! Such simple settings I wasn’t aware of. Thank you!

After changing ‘no’ to ‘yes’ on the Direct menu there was sound!

I am very thankful for you to share your knowledge. :blush:

Case Closed!