Digitakt / Ableton Program Change

I am using a 4bar 16beat pattern that I wish to change with a batch of audio clips using program change, Ableton Live in Clip View. Theres an problem I cannot overcome.

  1. Program Change MIDI channel is on ch16 (all working fine)
  2. Set up a scene with audio clips and a MIDI clip to program change to Pattern 2, PR-CH 2 in other words.
  3. Play scene, program change fires, change doesn’t happen until a whole 4 bars repeats.

For the moment, this makes PR-CH unusable.
All clips change, PR-CH data us sent and Digitakt is late by 4 bars, almost as though if it receives a PRCH on beat 1, but won’t actually initiate it until beat 64.

Its exactly the same if you hit play and start a scene, it wont change the Digitakt until the 4 bars in my Pattern have played once.

Even though its a work around - I don’t want to use the Ableton TRACK VIEW and position a program change 4 bars in advance, as it means I cannot jam and have to write a track.

  1. Is there a reason for this behaviour?
  2. Can I get around this?

Barry

Does it happen when you change to that scene while Ableton is already playing or when you hit play in Ableton? When you hit play you have to make sure the cursor is all the way back at bar 1.1 so that the PCh actually gets sent. I always double hit the stop button to make sure everything is properly aligned and reset before hitting play.

Also try using a Midi monitor to really make sure if the PCh gets send or not so that you can determine if the problem is on the Ableton or the DT side.

Neither. Its always 4bars late in my example. If you start it on one SCENE or another it won’t change until you are 4 bars into the tune, as though it has to do one complete cycle.

The nature of Clip View means there is ‘no position’ for the their start and end in relation to a time line like TRACK VIEW in Ableton.

I can see it send the data as soon as I hit PLAY. Being only 1 bar, the PR-CH clip stops playing, whilst the other samples continue to play. If I then change SCENE, the new program change data is sent, then 4 bars later, after one complete cycle, the PR_CH occurs.

Any recommendation on a MIDI Monitor?

Ableton always tracks the position no matter what view you’re in.
I don’t know what operating system you’re on, so just google Midi Monitor and you’ll find tons of free options.
The problem might be the timing of the PCh message. If it gets sent right on the first beat that might be too late for the DT to register it so it waits till the end of the patterns before it takes
effect.
Maybe try around with a negative track delay setting on the Midi track in Ableton?

If you read to the this end of this post, you can see another user with the same issue - it’s exactly the same on the OT and nothing has changed.

I’ve been thinking about this and why it would occur, it must be to do with sample loading. If you change to a pattern that doesn’t hold all the samples currently in memory, it must have to load them from disk, which would cause a delay, samples not to fire. Queuing the PR-CH gives time to load it all - that’s my guess.

This queuing is literally a deal breaker for me. It means the Digitakt is the only machine in my hardware setup that will not load a PR-CH when requested. It means that I cannot be used as a reliable live performance tool alongside Ableton, or indeed any setup that requires it to respond to program changes immediately. All program changes have to be fired at least a bar / 4bars early (depending on your sequence), which means you can’t use Ableton Clip View to simply jam along with the Digitakt as everything is consistently late. Ok, I could just change patterns manually, but it gets messy, complex and essentially worrying, which such a shame…

I’m going to email Elektron directly - my MPC1000 never acted like this, as far as I can remember…

This is an old thread, and maybe you already found the answer, but it took me awhile to find so maybe this will help somebody out there.

If I sent a program change in the first 4 bars of a 4 bar pattern it wouldn’t change until bar 9, making it always one whole pattern behind. In the midi clip’s launch window I turned quantization to off and this resolved the issue.

e.g. 1st clip has no midi notes and is bank 1 pattern 1. 2nd clip is bank 1 pattern 2. Both clips are 4 bars long and both patterns are 4 bars long on the Digitakt. Now I can select clip 2 anywhere in the first 4 bars and it will change on the 5th instead of the 9th. I also got it working on my recently acquired MD and MnM the same way. Now I can just fire off a pattern like a normal clip in Live. One thing to note is that you have to preselect the starting pattern on the Elektron before starting the Live sequencer. i.e. if you left it on pattern 10 and start the Live sequencer firing off pattern 1 it will start on 10.

Oh yeah, and pattern B1 on the DT is actuall Bank 1 Pattern 17 in Live for anyone who missed that.

2 Likes

Is there really no way to instantly change pattern for the Digitakt? It is so annoying to have to place the program change midi clip 1 bar ahead of when the change is desired. Makes for a really confusing arrangement.

Late program changes are a known bug that is apparently getting fixed.

1 Like

Great news, cheers!

Did it ever get fixed? My Digitakt is in stasis right now until all this / Overbridge etc gets sorted…

I’m relating to a Model Samples but since the sequencer and most probably it’s versions are the same across all Elektron devices, I’d like to share an interesting finding I made. Hope this is not obvious and has been posted already: Ableton prgramm changes are late but when I send a program change from my SL MKIII all is working fine… So isn’t the issue more on Ableton side but on the Elektron sequencers?