Digitakt 1.11 : Bug reports

Firmware 1.11 is now released.
Discuss here

Remember to back up before upgrading and even load a new empty project to avoid any damage to your current project.
And avoid upgrading before a gig. :tongue:


You encountered something wrong in OS 1.11 and want to check if others can replicate it ?
Here is the place.

Doesn’t replace a support ticket, of course, but you might want to check if it’s not a feature before declaring a bug :wink:

Please report all bugs via the Support Tickets section on elektron.se if they have not already been confirmed below.


3 Likes

Hi all,

I’ve updated the digitakt OS to use the Randomize feature but nothing is changing.

I press Amp and Yes and expect randomization, but nothing.

Anyone else experiencing this?

Cheers,

Bill

Hi,
Win10, Transfer 1.1.0, Digitakt 1.11
and Transfer is not able to connect to my Digitakt. :frowning:
Unbenannt|677x500
Can you help?
Cheers,
Konrad

I’m not sure if this is a bug, or if I’m just misunderstanding scale per track.

If I set a track to 1/8x scale it only plays the first 2 trigs (the playhead cycles between them).
I was expecting to see the play head go slower across all 16 trigs.

EDIT: I found it was just M.Len, so it works fine. It was just me :slight_smile:

Best regards,

Gino

2 Likes

@Gino M.len?

2 Likes

Yep, that fixed it thanks. I don’t play with those much, so time to learn!

Master length sets how many steps are played before the pattern loops.

1 Like

@digimatt yeah thanks. I was telling Gino that that’s why his whole track isn’t playing.

There’s a confirmed bug that will cause a trig with a ‘1st’ condition to retrigger at the loop point of each M.LEN when certain track scale settings are used. hopefully a fix shouldn’t be too long.

4 Likes

I have same problem here… But I had some upgrading issues – might have something to do with that…!?!

1 Like

yep, I’ve updated the OS via C6 and Sysex Librarian and both times it’s said successful, my Digitakt says it’s on the new OS and yet, none of the new functionality is present.

Not sure what’s going on!

YESSSSSSS. That did it. I had some Beta version that must have been up there temporarily. It works now, and was very quick over Transfer app. If anyone else is struggling I’d suggest redownloading the sysex…and Transfer app, for me anyway, was super quick.

I am having an issue using ableton and the digitakt. after updating I am having a hard time sending midi from ableton to the digitakt using overbridge and usb. No matter what channel I send on I only can get the digitakt to respond on channel 1, even when there is no midi channel selected on track 1, it still responds . In the past I have been able to send midi to the Auto Channel via usb and use my computer as an external keyboard. This seems to no longer be working.

Unable to update 1.11, using transfer app, progress bar stuck half way, after a restart OS showing as 1.11beta6 but new functions are not present, anyone else?

1 Like

I found a bug that I’m noticing in 1.11, though I’m not sure if that’s when it started. When I’m on a non-Master parameter page (e.g. AMP) and I switch to Master/Comp (with FUNC + LFO), the Master/Comp page that was last shown flashes for a brief moment and then switches to the other page, almost like I had double-tapped the button to switch pages, but it happens with a single button press. Switching pages still works if I’m already there, but if I’m trying to get to the same page I was on before (e.g. I switch from Comp to FILT and back), I have to basically do it twice.

Can anyone confirm this behavior?

Thanks!

1 Like

Mine doesn’t behave this way… All smooth like an elektrobutt :slight_smile:

1 Like

After more poking around it seems like the midi Auto Channel always triggers track one, and the selected track, regardless of midi settings.

I have the same problem…sadly I cant help you. It would be nice is this crap did not happen hey,

I have found that the comp/master pages mostly skip each other but not any of the other combos, I suspect its software as the button doesnt skip without function being used.

I’ve solved my issue: I had to switch from Overdrive mode to Midi in Settings and it worked again.

1 Like