Digitakt 1.04 : Bug reports

Sounds repeatable.
File support tickets!

1 Like

Same encoder behavior here

I had the same problem (multiple tries required to get midi channel and prog changes activated) in 1.03 and it remains in 1.04. I first thought I do something wrong and did not worry since it always eventually works and is only required occasionally. This has also been discussed previously, but no harm mentioning it again until someone has an explanation/solution :slight_smile: The 1.04 update made a huge difference to my DT experience… hardly trouble now ( o chrashes so far) and I am starting to enjoy the machine now.

1 Like

I think it has to do with the encoders being sensitive. When you press it you might also turn it slightly. In which case the press doesn’t get registered. This is my guess… Should be an easy fix for Elektron.

Correct. If the encorder is turned even so slightly when you push it, it wont register the push. Its a known problem and is on the fix list


This is correct.

Reported it to support and Simon replied with the same info, if the Encoder are registering a minimal turn when using the “push” function the [X] boxes will not register the push, due to overly sensitive encoder resolution.

Since i got this info i really try to push the knobs as centered as possible, which has improved my success rate by 95% i would say :wink:

Still, should get improved since it feels dodgy when beeing unaware of the issue.


Got an issue with program change that wasn’t happening on 1.03. If I have it enabled on my Virus C then it doesn’t play the first note of the pattern on it’s track properly. It’s like it reloads the patch on the first note hit instead of playing, if I solo the channel (via mixer) then there is an audible ‘pop’ on that step. Plays fine afterwards and loops round fine.

I tried taking out the MIDI in, coming from thru on the Virus and still does it, I’ve disabled ‘receive PC’ and it keeps on.

I have submitted a report ticket for this, can any body reproduce?

  • When adjusting more than one CC knob at a time, one of the knobs stops sending real-time CC values until power cycling the device.

Locked CCs still will fire, as will the “default” full set of CCs when there are trigs in the sequencer. Loading a new pattern or project does not remedy the situation, only power cycling the device.

Exact minimal repro steps:

  • Create a new project
  • Go to track MIDI A
  • Go to SRC page
  • Unlock and set CHAN to 1
  • Go to FLTR page
  • Unlock the first two knobs
  • Drop a trig or trig-less lock on the sequencer and hit play then stop, or simply manually trigger the track at least once (1)
  • Power cycle the device and wait for it to boot back up
  • Twist CCs knobs ONE AT A TIME. Notice this works as expected.
  • Twist at least TWO CC knobs at a time. Notice that one of them will immediately stop sending CC values.
  • This process can be repeated with any combo of knobs, the end result is only a single knob will be working as expected.
  • Power cycle the device and wait for it to boot back up
  • Notice that knobs again work as expected (so long as they are not being twisted at the same time)

This has already been confirmed and reported.


Tried some more advanced midi stuff today, 2x complete crashes and one boot that froze. Turned it off for a few hours and then tried booting again and it worked.

Stability has been better for me since 3.04, but I’m still getting freezes when using MIDI in (keyboard) and out. Sometimes the sounds will play direct from the trigger but stop playing from the sequencer, and sometimes complete freezes. Recording into the sequence from external MIDI keyboard seems to cause it most often, even though it sometimes works as it should.

nice catch, but what a PITA. :frowning:

Ok, everything I thought was a bug, is not. BUT updating threw my stuff out of wack that I had to manually restore it all, like the patterns setted to 10/16 instead of 16/16 like I originally had them. Little things, easy fixes on user end, but will mess up your day.

Get freeze and have no control except the volume level when using keystep to send random arp signal to digitakt, which controls 0-coast and has some trigs at the midi track. It usually happens when I try to stop or pause the arp.

1 Like

Might be user error, but I think I noticed someone else post this too: on the trig page, FLT.T doesn’t seem to work. It never retriggers the filter envelope.

Edit: I mean on lock trigs (Triggless trigs)

Edit: hmm it does work. No idea why it didn’t at one point, but pretty sure it was my own fault :stuck_out_tongue:

I get this too, i think It’s just receiving MIDI in general and then either Receiving a stop message or pressing stop on the device.
Also, still having crashes when playing a MIDI track with external input or pressing trigs in chromatic mode whilst the sequencer is stopped. It freezes when you press play after haivng the sequencer stopped for a while, doesn’t happen every time but still pretty annoying.


Same here. Usually have to press knobs 2-3 times to enable MIDI functions.

Problems with enabling MIDI functions (button press) as well. really prevents a good workflow,
the same with changing small values. when turned too slow the value doesn´t change, when i turn
it a little little bit faster… it changes 2-3 values. hope both of these things get fixed soon.

Had a new bug today. Midi-information (sequenced stuff, not the clock) was sent out after having stopped
the sequencer. I mutet all midi channels… changed to an empty pattern, switched the unit off and on…
nothing helped. after changing the midi-channels several times… it worked again (nothing plugged into
midi in or usb!)

Already sent to elektron: Automation resets the note values, which is supposed to be normal as answered.
It definitely feels like a bug. Hope this strange bug-“like” behaviour will be changed.

Not sure if this is a bug or user error … I play a a note on the first trig that runs the full 64 step length. Now I have a note looping every 64 steps. when I live record the p-lock to change the pitch slowly down over the course of the 64 steps, when it gets back to step 1, the note now cuts off after 1 step. when i go into grid record mode, I can see my first trig in red and the rest of the trigless locks in yellow, but all I hear is that one first step of the note. What am I missing? Is pitch not p-lockable?

One of my folders that should be full of samples has nothing in it if I go into the folder I can’t back out and I can’t delete the folder because it has samples in it… at a loss on how to fix it. any ideas?

1 Like