Clickup Machines

@sezare56: Thanks for your experiments!

I use the OT to create & manipulate drone-based music, so I am as well affected by the clicks and the missing crossfade. I think I deal with 2 separate issues.

Issue (1): Fade implementation
My understanding is that
(a) the OT applies the fades in realtime, i.e. during the actual recording
(b) first the fade out is applied, followed by the fade in.

As a proof of (b), I made a drone recording of 64 bars, set FIN and FOUT to 32, no overdub, this is the resulting recording:

This means that the OT fades by principle can not help with fixing clicks that might occur at the transition (or loop cycle jump, whatever you might call it) from the end of the loop recording back to the start of the recording.

I drew up a little diagram illustrating my issue with the current fade implementation, I already posted it in a different thread, so I am sorry if I bore folks who have already seen this. Based on the OT screenshot above I think this diagram gives a simplified yet correct explanation why the current fades can’t solve the click issue (and in fact produce more trouble than good in a ping-pong loop situation).

Issue (2): How to avoid clicks
Alas, I have yet to find a 100% reliable way to avoid clicks when creating drones (continuous sounds) with the Pickup machines. But most of the time I do get along pretty well with a combination of
(a) manually created crossfades, and
(b) recording over the “loop” point of a pickup machine

The manual crossfade requires a volume control (e.g. via an external mixer, or via a THRU machine) to manually control the level of the signal I record with a Pickup machine. I start the Pickup recording with the level control turned completely down, then gradually increase the level, until I reach maximum level shortly before the end of the pickup loop. When the pickup machine loops back, it automatically enters overdub mode, and after it did that I gradually turn down the level until it is completely gone. With a bit of practice, I am able to align the turning up and turning down of the level in a way that it somewhat resembles a crossfade.

Recording over the “loop” point of a pickup machine is a bit hard to explain. This is – at least in my experience – the point at which clicks normally happen. In my understanding these clicks happen if the signal at the beginning of the loop is not a direct continuation of the signal at the end of the loop. As the fades don’t help to avoid them, I intentionally record over the loop point to ensure that the signal at the beginning of the loop is really an actual continuation of the signal at the end of the loop point.

Most of the time, the combination of both gives me relatively clickless drone loops. Unfortunately I have not yet found out why it doesn’t work all the time – I guess that’s kind of similiar to the issues sezare56 has been reporting in his experiments: sometimes he does and sometimes he didn’t get clicks.

While this frustrates me big time, I will still react very unfriendly if someone tries to take my OT away from me :wink:

Hope this helps, thanks for reading so far.

1 Like

BTW: I have the RC-505…no clicks if you listen to the loops on the RC-505…but if you exported the loops to your DAW via USB, you have to manually create Fade Ins and Outs on each loop, as the fades on the RC-505 seem to be calculated in realtime and not written into the actual file.

Hi. Thanks for your tests. :wink:
Just before your post I tried a white noise with fades, to see the fade curve, but I had my fade out added at the end of the recording.

I think I had the fade out a the beginning too, but I was with Os 1.25c and today I’m with to Os 1.25H. What is yours?

Anyway, the real fade in curve seems to be always the same, exponential, after a silence if you have more than 1 step. Fade out is the opposite, but is added at the end of the sample.
Didn’t try with both tonight.
It cannot work as you said. Buy a volume pedal for fades!
More tests later!

I have the Rc 505 too!
I think I will sell it for sponsoring Analog Heat but I know it works well!

I’m also on OS 1.25H. Perhaps the fade position depends on the length of the fades? Would like to do more tests, but need sleep right now…

Some of these clicks could be a bug that creeps up here and there. I rely heavily on pickup machines for my OT usage, use them every time I turn it on. Most of the time I do not get clicks, hundreds of times, all good. But there have been a few times where clicks started happening. When the clicks arose, I would get them even if I recorded pure silence. No track recorder or PU settings were changed. Once the clicks arose, the only way to stop them was by reloading the project, and before that I triple checked the settings, reloaded part, and power cycled… This reminds me to really investigate more the specifics of pickup machines, and file support tickets. I would love so much if the community could narrow down exactly what are the PU issues and when exactly do they happen, and hopefully squeeze another bug fix or two from HQ so we can have some fully functioning pickups before were left in legacy land…

@wolfgangschaltung : I hesitated to get up to check this! Maybe it behave like this with long f in and f out.
Good night.

@Open_Mike : Maybe internal audio sync problem… Sleep.

My last test was on a normal recorder, not a PUM. You’re right, with PUMs, fade out is added at the beginning of the sample. USELESS!

I just tried with a with noise, 16 step record with 8 steps for F in and F out, almost the save as your picture!

I remembered your diagram as well as Olle’s response. Here it is:

Soooo doesn’t seem there is a “fix” in store…hmmm…

Those are good tips, though. If I run into it I’ll remember them.

For what it’s worth I have not yet come across any issues using ONE2 for my PU. Admittedly though I’ve been doing more beat-extensive work than ambient/drone presently. I’ll be sure to update if and when I come across it.

Do you use fades? Maybe F in with a short is usable. F out is insane.

Always, yeah. 0.063 on both. But again they’re mainly beats which I think any implementation of Fade Out would handle fine. It’s the really difficult stereo, droney ambient washes that I’m sure are very difficult…

Are you recording stereo tracks? If so, consider they would then have two different lengths…

Like Olle said “it cannot predict” when we’re going to cut it. Though I would think “reading” the RLEN should help?

EDIT: How RC505 can do it answered by wolf above.

This thread is filling up with great insights, good stuff, i’m minded of a previous pledge - to start a very focussed thread for getting the most out of Pickup Machines … a catchall for all the pitfalls and tipis that will allow a user to get into them and use them fairly reliably - a sort of power users thread, it would be reliant on lots of user feedback as there are many subtle ways to interact differently … i’ll have a think about that and hopefully we can create a useful resource thread/sticky with everything one needs to know … let’s do it before Elektron release a looping pedal though :wink: i’ll digest the above replies soon, just wanted to say this whilst there was some community interest in this topic

As an aside - i have had the original expanded Lexicon JamMan from new, it also has MIDI sync though it takes as stereo signal in and out it sums the input to Mono - but in all my time with it i never once ever recalled having heard clicks

another aside, sometimes there is no possibility to avoid a click, especially with low frequency stuff with few pure harmonics, those waves will simply not fare well to being interrupted and the resulting transition even with a clever fade or crossfade will be audible, albeit mitigated to some extent, your chances of not noticing anything increase when you start to work with staccato phrases and noisy content which would mask the possibility of a click

Rc 505 use proper internal fades, with audio overlap. Stereo or mono, it works.

Ot can overlap with PU in overdub but the fades curves are silly, as I wrote too many times, it cannot be exponential for crossfades. Logarithmic or linear at least.
The last not the least, if you increase the fade time, it adds silence before or after the fade, instead of smoothing the curve.

we need to collate all this great info into a super-thread - then use it as ammo for a case to Elektron to tweak a few things

i returned an RC-300 many moons ago (when released) as it clicked real bad fwiw

I had and sold 2 Rc 300, 1 Rc 50, I don’t remember bad clics. Anyway the Rc 505 is much better. I’m sure there will be a better looper one day, maybe a Elektron?
Or just even a correct fade implementation in a Ot update with auto save samples and I’d buy a second Ot! :sunny:



Sooooo I said I’d report back here if I ran into Clickups. Ohhhh did I.

I accidentally set my pickup to record 32 bars (not sure what I did). I had been using ONE2 for hours before without a hitch. But when it was accidentally setup for automatic length, clicks galore.

Crazy. What could be the difference? Maybe the limited length doesn’t consider the FIN/OUT and just cuts it?

Again, mainly beats, but some stereo FX and textures.

What do you mean by automatic length ? RLen set to Max ?
I use Plen on Qrec and Qplay, without Fin/out.