Can't use Digitakt with Overhub into my new MacBook Pro


#1

So I picked up a Digitakt and using a new MacBook Pro which only has 2 USB-C inputs. I need one of those for power, and was hoping to use a USB Hub for the other. But the Digitakt is only recognized and works with the Transfer App if it’s “directly” connected to the computer. If I try to use the Elektron Overhub it doesn’t work which seems crazy because it was designed for this equipment. I will definitely need other inputs to my computer and wondering if this issue can be overcome. If not, the Digitakt will be going back to the store, unfortunately.

Any ideas?


#2

Do you try that ? have success with my RYTM with that one
borrow one or test it in a apple store.
Maybe it’s a system OS problem compatibility with software and firmware…
Elektron told all come back on track in February :wink:

Open a ticket support maybe they have a solution for you :wink:


#3

Yep. That’s why I bought an iMac instead. Didn’t work though, none of my Native Instruments hardware wants to work with it anyway.


#4

Hey @davidjez - I have this problem with the new macbook pro that I bought. However, I am trying to connect the A4. I can see the A4 but the Overbridge doesn’t not work how it should do.

Im thinking it either the usb connection or the OS system (OS Sierra)

@William_WiLD - Tempted to try the usb connection cable you have suggested. Pretty bad how it is so expensive though. But I suppose that is what mac does to you.

I be interested to see if / how you resolve the situation.


#5

I’m using a 2017 MacBook Pro.


#6

Forgot that one… yes and less-expensive too !


#7

@William_WiLD

Unfortunately it doesn’t solve my problem. With only two USB-C ports on my MacBook Pro and one used for power, not being able to use a USB-Hub essentially renders my music setup unusable.


#8

You tried to contact Elektron support ?


#9

A “pro” laptop without USB 3 or Ethernet ports. What a fucking joke.


#10

@William_WiLD

Yes, I guess that’s the next step :slight_smile:


#11

@William_WiLD

So by fluke I tried one of these USB Hubs and everything seems to work now…

Not sure why, but I’m back in business!

Dave


#12

I have the same one. My old d link hub (which was apparently Apple Mac certified) didn’t work as well as this one.