Can I set the musical scale for MIDI input?

Help!
I’m trying to control the Digitone with a midi control device from Playtronica. But I need it to only play in a D# ionic scale. I can decide what notes the Digitone’s keyboard plays (or doesn’t play), but the midi input plays all the notes. How can I get it to only play the right notes in the right scale?
Please help!

set the control device to play on the Auto Channel of the DN (default Ch10) and it will act like the onboard one

so you’ll get no output from the Keys not in the scale of your choosing - just like it does when you set a KB Scale on the DN itself

welcome to the forum btw :thup:

edit : clearing a pattern in stop/realtime-rec mode will wipe the KB scale assignment too - so erase a track whilst using step mode if you want to retain that assignment

5 Likes

Nice!!

1 Like

Wow! Thank you for the quick respons and for welcoming to the forum! I’m not sure of I can charge anything on the MIDI output from the device, it seams to send on channel 1. Can I change the overriding channel on the DN from 10 to 1?

Yes. If you set the DN Auto Channel to 1 then it is wisest to set channels using 1 to something else. This is so that the Auto Channel number is unique from other channels. It’s simplest. Auto on 1 will work fine but will be more work to keep on top of midi issues as 1 is so very ubiquitous on other gear. Basically you need to be more mindful of channels than if it was ch10

1 Like

Is it possible to use an external keyboard while having the Digitone set to a certain key / scale.

I have my keystep hooked up at the moment, and it doesnt seem to pay attention to the phyrigian Am scale I’ve set up when I use the keystep.

It only pays attention to this with the keys on the digitone.

Is there a way to turn this on? Or does this feature simply not exist?


I’m also trying to scroll through sounds / patches and preview them by pressing the keys on the keystep, but I have to hit function / yes or yes each time to hear them using the keystep.

Again, can I turn this on in the settings somewhere? (External MIDI Preview or something?)

Pretty sure it will only play the notes of the scale… notes not in scale are silent…
You must be sending midi to the auto channel to preview sounds from browser

1 Like

Thank you, great to know!

1 Like

Is it this thing?

Just heard about it on Keyboard Corner from the guys that tend to do this in response to playful devices like this Playtronica