Brand new DT exception error

Hi,

i bought myself a DT for xmas. After fiddling around with it for a couple of hours I got 2 freezes with an error message “exception DT0032”…im on firmware 1.11

could it be a hardware problem ?

EDIT: is it possible that some weird characters in my imported samplenames is causing that ? because im importing a lot samples with transfer and the naming got some weird characters and even some jpg in the folders…when im not mistaken both freezes happened when i was on the "dt samples explorer"in the settings menu…

Did your filenames have special characters before or did they import then appear to have odd characters? When you say there is some .jpg files in there do you mean you bulk transferred files and forgot to deselect some invalid file types? I think you’re correct in assuming that those files are causing problems. I would initialize the DT and re-import the samples but take note to rename any potentially odd file names and definitely make sure to only import files that the DT supports.

i just did that and observing now…is there some kind of database for the exception error codes ? the meaning of them ?

Elektron would likely be the only folks that would know what each exception code means. You could search the forums or Google to see if others have run into the same exception code. Perhaps that would shed some light.

Did you record the exception code? If so, post it here. You may gain more insight from fellow DT users.

I hope the steps you’ve taken have resolved the issue. If not, I’ve heard Elektron has great support. Open a ticket with them :slight_smile:

EDIT: I see the code in the first post :slight_smile: Still waking up on Xmas morning :stuck_out_tongue:

1 Like

File names and .jpg files and aren’t likely the source of the crash you are seeing.

Like all Elektron machines, the DT only supports a limited character set on the +Drive. Transfer converts and limits file names before sending.

Transfer also ignores non-audio file types during bulk uploads.

Of course, you may have uncovered a bug in these two functions, but they are expected to be handled.

2 Likes

if it is a software bug I can live with I don’t want to put to much effort in the file system and later find out it is hardware related and I have to change it…worst timing :sweat_smile:

…yup…stay calm…if this is ur first elektron, it’s pretty common to feel a bit unsafe with them in the first days, cause they’re made by nerds for nerds and are truu deep dive musical instruments…created and coded by creative musicians for other creative musicians…

strictly not made for everybody…

so give ur new instrument some time…because there is no elektron music machine outthere, that does not include lot’s of happy accidents, lucky dips and musical concept surprises u’d never thought of before…enjoy ur new friend…it will serve u well, promise…
and be warned…chances are pretty bad that this one will be ur last…once talking swedish hardware, u want more…

1 Like

Happened again and this time after powering off and on again it didn’t boot up and I had to plug it off…maybe it’s a hardware issue…if I had to guess I would say psu

Sadly - this looks like a HW issue… if you are using the Elektron PSU - I’d say now is the time to submit a support request directly to Elektron - and it will probably be a HW swap. (Unless you got it from music store that handles returns/swaps for you… do any of them do this anymore!!!)

If you are not using an Elektron PSU… then perhaps you could suspect the PSU. Note that the Digitakt takes significantly more power during boot-up than once running. If you are using a PSU that is lower than 1A, it might be dodgy during boot, but work afterward if it gets through boot. The official PSUs are 2A.

1 Like

i know how to reproduce it…one drum folder in settings -> samples when i select any sample in that folder and push the left cursor the dt freezes…im not sure why

Oh! That’s different, then! I’d be happy to dive deeper into this and figure out what is up with those samples. I’ve sent you a longer message about it.

2 Likes

hi mark,

please check your pm

1 Like

With help from @mikeO, I dived deeper into this, and wow! it is one weird bug!

First, the good news: Nothing is corrupted, and nothing is broken - just the menu operation you tried crashes with those directory names. Restarting the machine¹ brings everything back.

Workaround I’ve found so far: You need to rename the folders as follows²:

  • Remove the _(WAVs)_! prefix from the one directory that has it
  • Remove the _(WAVs)_(Bonus)_ prefix from the directories that have it
  • Rename the top level directory to something simple, like: LMBKV9 - that worked for me

After that, everything should work just fine.

I spent some time trying to narrow it down. It isn’t the parenthesis or exclaimation point on their own - those are both legal, and work in other places. It isn’t just both of those, the name must be at least 28 characters - but not any 28, some work, some don’t (replacing Blap with Bxap for example, works! I will poke at this some more this weekend and submit a detailed bug report.

Meanwhile, @mikeO, it would be great if you’d file a ticket via the support page. You can feel free to let them know that I (they know me there!) can repro the bug and will have additional example cases soon.


¹Note: The Digitakt tries hard to keep everything live in memory, so sometimes after a crash like this you need to not only turn it off, but leave it unplugged for 15 seconds or so.

²This kind of renaming is very easy to do in elk-herd - try it!

4 Likes

Hi mzero,

really appreciate the confirmation. I already submitted a ticket…lets wait and see.

The good thing it is not a HW issue and i can keep the unit :partying_face:

2 Likes

Hello, I’m getting absolutely the same Exception when browsing and loading a sample. But I have my digitakt since nearly 2 years now and never had this Problem before. I updated the os to 1.11 but I still have the same problem. Im using the same samples like I did before and the sample names dont have any weird characters in them so it cant be related to that. Could you solve the issue somehow?

Make a support ticket on Elektron’s website.

It’s a bug but I’m not sure if it’s fixed I sold my digitakt shortly after and bought a mpc one and it’s everything the digitakt was missing FOR ME !