AR and A4 losing sync!? Can anyone explain this?

You mentioned ‘PC info’ in the original message, what does that mean? do you have other devices connected?

I just meant Program Change Send/Receive is set up correctly in both devices’ Sync page.

1 Like

whats the OS?

Are you using Turbo midi? I just spent some time comparing A4 out -> AR in (normal midi) vs A4 -> AR in, AR out -> A4 in (turbo checked). There are some differences in behaviour off the bat (I’ll record a quick video later)

For example, I have some bank G. In normal mode I do this: go to G4 on A4, then I hit song mode on AR and double tap stop on AR, and it goes to the start of the song I have prepared on AR, while A4 remains at G4. I hit play on A4, and AR starts playing the song, while A4 plays pattern G4. All good.

In Turbo mode I can’t play the song on AR. Hitting STOP twice on AR to go to the start of song mode doesn’t change the pattern to the start of the song. I can manually change to the first pattern in the song on the AR, and press song mode, but when I hit play it jumps to G4 (the pattern on A4.)

I don’t say this to suggest it is your problem, but I do suggest you try turbo mode. Their does seem to be some inconsistency in the implementation of these boxes at least.

I guess, this may be the problem. If you use sequential pattern change, the pattern on A4 will play to its end, before changing to the new one.

I have them both set to INF length and to CHNG after 16 beats, so I thought that should keep them in sync for the changes.

It varies, but I thought ‘16’ makes it change at the end of the current bar you’re in regardless of your positioning within the pattern.

As I said earlier, it works perfectly when it’s working, it’s just when it slips and the A4 stays a bar behind that it’s an issue.

Maybe try length 64, not INF and test that.

1 Like

All I know is, it never werked right. Until I started moving the change message back.

Start with a clean project, default pattern lengths, only change the midi settings, see if it works.

I have the exact same problem with the AR and A4

It works totally fine when you set pattern length to NORMAL. But once you choose to set length per pattern synchronisation is off.

Do you have any of the individual tracks set to lower resolution timings? So instead of 1 do you have 3/4, 1/2, 1/4 or 1/8th?
I found that this caused issues…

Also, for people saying go A4>AR, while that might be more stable I MUCH prefer to have the AR as the master for several reasons (mainly for the ergonomic layout of the AR’s Bank buttons and that it feels more natural having the drums/tempo/beats in control of the clock/transport).

No lower resolutions on my tracks. All 1x. I mean, pattern sequencing is a super simple thing. It should listen to that event and take into account the LENGTH parameter. And that works as long as you are in NORMAL mode. Somehow the ADVANCED mode it becomes buggy.

I remember I had this issue years ago on my DT/DN combo as well. Never gave it much thought back then.

I raised a ticket at Elektron Support.

Let me/us know what they say please…

I have found it way more stable since starting from scratch, and I also have my Digitone changing in sync (AR>A4>(thru)DN)… every so often the A4 will lose sync, but Stopx2 seems to fix it. It’s still not ideal though… I wouldn’t feel confident in playing this live, which is an issue.

Yeah, I’m gonna start blank projects too and if it works try to break it. See where it loses sync. So weird though because it’s really consistent in the way it lags behind. Clearly the pattern change event is received but somehow delayed/queued for a cycle.

Will keep this thread updated.

1 Like
  1. Pressing next pattern
  2. New pattern number starts blinking
  3. New pattern starts
  4. On other device new pattern starts blinking
  5. End of pattern it starts the new pattern

The problem here is that the Pattern Change event is not sent when you select a new pattern but when the pattern change takes place. Hence it lags behind a cycle.

1 Like

didn’t solve it. Also hard to start machine together.

Just tried with initialised projects on both machines.

First. Pattern Length NORMAL mode. Perfectly synched pattern changes.
Second. Pattern Length ADVANCED mode. LENGHT 1024 (could also be any other value) and CHANGE 16. Result. Pattern change on slave machine (A4) lags one pattern cycle.

I even kept patterns initialised. Meaning standard 16 steps. No time scale changes or pattern lenngth. All super default. Just changed from NORMAL to ADVANCED mode on Pattern Scale

This must be a bug. A pretty fundamental one if you ask me.

1 Like

Why do you have the length set to 1024?