Analog Rytm connectivity issues - USB-C adapter


Currently own an AR MK1, I am running two machines an iMac which has a standard USB input. In this instance, the Analog Rytm is detected and shows up in the overbridge engine. Having said this, when I try and do the same with my MacBook pro I am required to use an additional adapter to convert to usb-c. In this case, the Rytm is not detected and therefore cannot be used. The connection I’m using is Apple’s.

I’ve gone through the global settings and making sure it is in the correct mode etc. It detects on my one machine but not on the other. I have no other issues with I/O devices on my MacBook Pro, just the Analog Rytm which is making me think it has something to do with the adapter. If anybody could shed light or point me in the direction of somebody to talk to, I would be forever appreciative.



What year is the MBP from? Some early USB-C ones have a minor issue where some stuff only works when there’s an USB 2 hub in between.

This sounds silly, because with USB-C it shouldn’t matter which side is up, but: have you tried to plug the USB-C cable the other way around in (upside-down)?

I just stumbled across an USB-C to USB-A cable where this was necessary to get it working.

1 Like

Thanks for getting back to me. Macbook pro is 2017 I think they were introduced in 2015 but I could be wrong. Do you think it would be a good idea to explore that route? I have multiple usb c adapters and multiple usb cables. I’ve tried them all and obtain the same results.


Thanks for getting back to me. Yeah I think I’ve tried all combinations at this point. Different usb cables, adapters. Same result.

Have you tried all of the different USB-C ports on the MBP? I believe the left and right sides are two different busses. If one is problematic the other might be ok.

A related issue with this is having two devices on the same side that draw a lot of power - it can be that moving one to the other side solves the power issue by drawing from the other bus.

You can also try resetting the SMC and/or PRAM.


Thanks for getting back to me. Sadly the model MBP only has two slots on the one side (It’s the model without the touch screen strip). I have tried to change the slots and it doesn’t seem to have an effect.

This idea you’ve raised about the two devices drawing too much power is interesting as I do have two devices connected. An external soundcard and the machine itself. Maybe using a hub to connect both devices to one port would be something to test? Using a hub was mentioned further up so I’m thinking that this might be a path to explore.

Concerning SMC/PRAM article you’ve directed me to, surely if inputs are working correctly for other i/o devices I shouldn’t have to do this?

Thanks a million.


It worked for me back when I had that model MBP.

Ok sure, Did you have the same issue?
would you mind referring me to a good one? Can I just get any or is there something I should be looking out for? I’ll explore this and I’ll see what happens.

Thanks for your help, I really appreciate it.


You can test this with any USB 2 hub, in the end you might want a good one that does multi-tt.

Thanks for this, I’ll try that and see what happens.

Take care,


1 Like

What I do experience on my mcbook pro sometimes is that when I hook up a new device to a port where I previously had connected another device the new device is not recognized. Apparantly the mac remembers which machine used to be there and then it goes wrong. I can fix this by opening the midi audio configuration window. In the midi studio window I delete all the devices and the IAC file. Now when I restart the computer then the new device is detected and everything works

Hi quick update,

I purchased a hub. Sadly, this didn’t work for me. I’m not too sure where to go from here.