Analog Four/Keys OS 1.40: bug reports

Hmm - bit of a pity this one and something that could hopefully be reviewed

FX Track is a great track to use for MIDI, it doesn’t mess with Poly and keeps the CV stuff clear

But what if you want to P-lock FX, this could’ve been fun, alongside Note Trigs, maybe with P-Locks (Now called Lock Trigs)

So the Note Trigs do MIDI nicely as expected, but the Lock Trigs ALSO trigger midi even though on any other track they wouldn’t play the track Voice (as both Envelope Triggers are Off)

Now what is Encoder J doing presently, nothing, that could be nice as a toggle for MIDI stuff

So that a Lock Trig could have it’s default MIDI tendency removed, or any way to achieve this, even implicitly if the Trig is a Lock Trig just don’t allow a MIDI Trig

I may ticket the latter as a bug as it’s broadly unexpected/undesirable imho

1 Like

AK 1.40 - Poorly implemented feature: When chaining patterns you have to enable the MIDI Tx per pattern, per track. When in Chain or Song modes you would usually want the MIDI track out assignments to be persistent so the MIDI notes don’t drop out if you dial up a pattern that you haven’t enabled individual track outs on yet.

Other than that I love MIDI out. Wish it worked on Arp notes as well.


Great thread, about to update and feel fully informed now.
Thanks folks.


With os 1.23 and the previous non-beta OB it was possible to have the A4 (MKI) show up as a midi device while in OB mode and with INPUT/OUTPUT TO/FROM in the midi port menu set to USB.
Seems this is no longer possible which is a real shame because I like to regularly exchange sysex to backup sounds I’ve created and make backups etc.
Now I have to shut down Live, turn off the A4, disable OB engine, turn A4 back on, enable midi mode, trans/rec sysex and repeat the steps in reverse order.
Also seems if I don’t do everything in this exact order shutting down the OB engine with the A4 still on makes my computer (mbp with high sierra 10.12.6) crash instantly.

Not sure if this is the right place to mention this but I’m also with those who earlier said they preferred the old OB lay-out. Big fan of the new graphics and menu’s but the previous layout was a bit more efficient.

A4 Mk1
When i wan’t to change the bank via the buttons i can’ get the specific bank first but jumps around, after pushing the buttons two or three times … this also appears on my AR

since the new OS-Update for both machines (no program-change involved)

is it related to this change Analog Rytm OS 1.50: bug reports ? That’s reported fwiw

1 Like

oh man yes, the description is more accurate

first i thought this could be a hardware-issue

1 Like

In “List of changes from OS 1.35B to 1.40” it is stated: “Added support for Elektron Transfer.” However, when going to the A4mkII support page on, Elektron Transfer isn’t listed for download. When instead going to the ARmkII support page, you can download Elektron Transfer 1.1, but this software doesn’t work with Analog Four mkII.

When asking this question in the main thread for the A4 1.40/AR 1.50 release I was told that the compatibility referred to Elektron Transfer 1.2, which isn’t public yet.

As of now, I would consider this a bug. If you write that a device is supported by a certain piece of software, but don’t mention a version number of that software, the most reasonable interpretation is that it is at least supported by whatever version of that software that is out at the day of the release of the patch.

So, update the release notes and make it clear that it’s Elektron Transfer 1.2 that is supported, and preferably say something about this on the A4mkII support page. Or better yet: Make the Elektron Transfer 1.2 release public :stuck_out_tongue:

It’s not a bug.

To clear things up, the Analog Four (firmware) now supports Transfer. And that is why it is mentioned in the relase notes for Four. However, as you and others point out, Four is not supported by the current version of Transfer. And I totally understand that this looks a bit odd/bad/misleading, but its neither untrue nor a bug. To make a specific sofware work with a specific hardware, it requires that this connection is supported on both sides. The work is compleate on the Four but it is still work in process on the Transfer side.
In hindsight it might have been better to leave this item out of the release notes to avoid the confusion, but done is done.


Not sure if this has already been noted but with a track playing at half speed, any trigs set to condition 2:2 never play.

Nothing is quite that straight forward, I can make 1/2sp Track 2:2 trigs sound when using longer Master Length

There’s a subtlety to when these TRC states are ‘accounted’ for and it relates to patterns getting to their end iirc - this links to the Master too, so there’s a few variables to look out for … I’ve just heard 2:@ trigs play back in a way I wouldn’t have expected/predicted, so there is scope for their being a bug at play, especially as the Track Scale has been introduced, but it’s not so straightforward as in that statement (for which a longer Master Length may remedy).

It needs a bit more exploring and keep in mind the way the TRCs are tallied does not relate to when you hear them, that’s not when the stats are updated - this should really be covered with official comment, I need to look at the manuals to see what they state these days (even in other products’ manuals that may have better/later explanations of the subtleties)

Thanks for the reply. To elaborate, 4 bar pattern, page mode advanced, one track set to 1/2 speed, measure length = 128, trigs set to 2:2 don’t play. Tried exactly the same on the Digitone and they do play so maybe a bug or a different way of working?

If I change the measure length to 256 though they do play.

I am looking at this a bit more and it does seem that a half speed track needs more than 2x/double the master length to work

however, when I go to 4x length, whilst the 2:2 TRCs on the half speed track now play, they do so in an unexpected way imho

On a 16 length pattern with both a 2x and a 1/2speed and also a base 1x track the TRCs all work as expected except for later into 1/2 speed playback, each track only has 2 trigs, one is a 1:2 and the next is a 2:2

So each track is doing A / B / A / B and so on alternating between the two TRC types

However, the pattern for the 1/2 speed track is A / B / B / A or 1:2 2:2 2:2 1:2

The best reference point may well be an established bit of gear, if it differs from that then it could be a bug - this doesn’t look quite right to me, so it would be good if someone else had a look at this and offered an opinion / confirmation on this test

In your case try 256 Master and see if the ordering of 2:2 is as expected - or just try a structured test for a longer 64step pattern

1 Like

2:2 breaks as you described here, it won’t play if the pattern is 128 long and it does ABBA if set to 256

I’d reported the former, but I suspect this is related to a broader issue affecting many of the TRC conditions

e.g. taking 2:4

The pattern is

something is not quite right, there’d be no point investigating further until the root of this is tackled

This is also happening to me. I tried on FX channel first but then on first four tracks to confirm. Internal keyboard doesn’t work for me either, even when I set to send to external in the Port Config menu.

This isn’t a bug. You need to set the setting Output CH to Track, it is currently set to Auto.

7 posts were merged into an existing topic: Analog Four/Keys 1.40 & Analog Rytm 1.50

I bet you wish you had a dollar for every time you’ve typed that.

1 Like