1 bar delayed External Pattern /Program change

Howdy all,
I had and sold a Digitakt that I loved and have returned to the wonderful world of Elektron with this Cycles as my drum machine, it’s amazing!

I have run into what appears to be a feature of the cycles sequencer that it will wait 1 bar before changing a pattern when sent a midi program change.

I can work around this for recording but it makes jamming /writing less seamless.

I have read that this is a known issue in the digis etc. But I’m wondering if there is any new way to make the patterns change happen on 1:1 instead of 2:1


You just need to make sure the program change is received by the M:C before the end of the current pattern. The Chg length in the Scale setup can also have an effect as it will wait X number of steps before changing.

Thanks for the reply!
That is actually my workaround, I should have mentioned that.

I think I may have it working the way I want where the change is on 1:1:0 so each pattern in my Akai Force and corresponding Cycles pattern is order and length agnostic, so I can move back and forth as i listen and work on it etc etc

I’m not 100% sure what I did to get it working but i adjusted the pattern length page, I set to pattern and set the LEN to 2.

Not sure what that means exactly but itbseems to be working.

I will test more later and report back, thanks!

What that means is “this pattern has only 2 steps (trigs) and then it repeats” so I’m surprised it works. Are you sure it’s playing all the steps you want it to ?

EDIT: From the manual

LEN Length sets the step length (amount of steps) of the pattern/track.

Yeah, I was mistaken about that, it’s at 16.
CHG was the parameter I’m unsure about though I haven’t looked it up.
Not sure why it works now but after adjusting those, but it works.

You may want to take a look at this thread. It’s not exactly the same scenario, (in my case the PC sender was another model box), but there’s some overlap … you seem to be discovering the things I did about the setup of the model box that’s receiving PC messages.

That’s great info thanks!
I have now officially RTFM on the CHG parameter and I still don’t understand it.

At any rate, my setup is currently working exactly how I want it with the pattern changing immediately.

Not sure how to describe the fix other than to say that the key is in that menu.

I may run into issues if I get fancy with pattern lengths but for now it’s working perfectly

1 Like